1 2 Previous Next 20 Replies Latest reply: Dec 14, 2012 11:20 AM by Reegor
riiiic Level 1 Level 1 (0 points)

Hi Guys,

 

I've just bought my Time Capsule 2Tb and started making back up with time machine in my MBP (mid 2010 with Lion) and till this morning all was ok.

 

Suddenly I undestand (working on word documents) that while time machine is backing up, word is anable to save a thing. Actually it looses the position of the file. If time machins is working, when I push the save button in word (or word makes an aouto save), word automatically renames the file i'm working on and tell me to choose another file name because the file is open in another session and it cant be read/written.

 

Why is that happing ?

 

Please help me


MacBook Pro (13-inch Mid 2010), Mac OS X (10.7.2), 500 GB HD
  • 1. Re: Time Machine makes MS word 2011 unable to save files....
    riiiic Level 1 Level 1 (0 points)

    Could, someone at least, try to louch a back up while is workin on word with an auto save every 1 minute ? so I can undestand if it's my system that's gone or office that's is not work in pair with time machine and lion ?

  • 2. Re: Time Machine makes MS word 2011 unable to save files....
    Pondini Level 8 Level 8 (38,720 points)

    I don't use Word, so can't test this.

     

    But I've not seen a similar thread here, with any app. 

     

    You might try the things in the green box or #D2 in Time Machine - Troubleshooting.

     

    You might also try setting the autosave to, say, 5 minutes, if you can.

  • 3. Re: Time Machine makes MS word 2011 unable to save files....
    Vamvakeros.A Level 1 Level 1 (0 points)

    riiic,

     

    I don't have the answer, but I can confirm the exact circumstances you have reported. If all of these circumstances are true, then the exact error you have reported will occur on my configuration, and the two recent major bug fixes as of April 2012 do nothing to correct this:

     

    1. Time Capsule backups are on (no need even for a current backup, just tracking of files for the next backup being on)

    2. Saving a large MS Word file.

     

    If you do that, Word creates a temp file first, then attempts to rename the temp file to the original file name. The rename fails, you are left with a missing file, but the data is in the temp file. You will also loose all embedded links to external MS Office files. Sometimes, you will even get a corrupt file and need to do a disk repair. It is a real mess for something as simple as saving changes to a file.

     

    The solution: turn off Time Capsule backups. Do your updates. When done, either do a manual backup or turn on Time Capsule backups again when only modifying small MS Word files.

  • 4. Re: Time Machine makes MS word 2011 unable to save files....
    Astroleptirobot Level 1 Level 1 (0 points)

    I have this exact issue by the way, and can confirm that this Word bug will happen regardless of whether Time Machine is actually backing up - this happens to me frequently while I'm at the office, while my Time Capsule is at home. Time Machine is running, but it's not performing a backup when the Word save fails.

  • 5. Re: Time Machine makes MS word 2011 unable to save files....
    tykockin Level 1 Level 1 (0 points)

    I also have the same problem.  I've turned off autosave in Word, and enabled the "make backup copy" option instead.  Granted it means I have to save manually or risk losing what I've done, but at least I get a backup.  Then I can manually do my TM backups.  This was not a problem until my Word file got to about 40 MB (it's my dissertation, so that's why it's huge).  I can't decide if it is just a problem with TM, or with the autosave in Word.  It's odd because I have PPTX files that are over 1 GB and there is no problem there...Wish I knew why 40 MB of a Word doc is too much to handle.

    Needless to say, this makes Word - and my Mac, sad to say - an extreme hindrance to productivity.

  • 6. Re: Time Machine makes MS word 2011 unable to save files....
    Pondini Level 8 Level 8 (38,720 points)

    I don't recall seeing any other reports of this sort of behavior with TM.    Many other apps use the same technique for saving (or autosaving) files, without apparent conflicts.

     

    At the very least, if TM happens to be reading the file when Word wants to rename it, Word certainly ought to handle that more gracefully -- such as waiting for a brief period of time, then putting up a message allowing you to do something, even if that's to just save the file under a different name.

     

    By all means, report this to Microsoft.

     

    It's also worth filing a Bug Report with Apple, of course.  See Reporting a Problem to Apple. Be sure to include full details and logs (assuming there's something in the system.log and/or any log or messages Word produces).

     

     

     

     

    It's obviously no help now, but there are reports that Word may support OSX's AutoSave and Versions in the future; if so, that should eliminate this problem.

  • 7. Re: Time Machine makes MS word 2011 unable to save files....
    Pondini Level 8 Level 8 (38,720 points)

    tykockin wrote:

    . . .

    This was not a problem until my Word file got to about 40 MB

    While this problem certainly shoudn't happen, that's a huge word processing file.

     

    Can you split it into pieces, so the whole thing doesn't have to be recopied every time you save it (or it's autosaved)?  

     

    If you're connected to your TC wirelessly, transmitting that 40 mb file could easily take 2 minutes (on a good connection).  That means the temp file may be open that long if TM happens to start backing-it up before Word tries to rename it.

     

    Another workaround might be to exclude the temp file from being backed-up. 

  • 8. Re: Time Machine makes MS word 2011 unable to save files....
    tykockin Level 1 Level 1 (0 points)

    Tried that...no difference if I exclude that directory or not.  It even hangs if I open - and close -  the file before TM does its backup thing.  If I open the file, change 1 letter and then save it, it won't do it.  Says I have to rename the file.  I can't split the doc...it's my dissertation.  But if I turn off auto-recover then everything is fine.

  • 9. Re: Time Machine makes MS word 2011 unable to save files....
    tykockin Level 1 Level 1 (0 points)

    Thanks; will-do.  And yes, that would fix the problem.

  • 10. Re: Time Machine makes MS word 2011 unable to save files....
    Pondini Level 8 Level 8 (38,720 points)

    tykockin wrote:

     

    Tried that...no difference if I exclude that directory or not.

    I don't use Word, so bear with me here.

     

    Do you mean the directory where Word is putting the temp file? Is that a different folder from the original?

     

    If the folder the temp file is in is excluded, TM won't touch it.  Are you sure it's the temp file that's getting locked, not the original?

     

    It even hangs if I open - and close -  the file before TM does its backup thing.  If I open the file, change 1 letter and then save it, it won't do it.  Says I have to rename the file.

    It won't do the equivalent of "Save As" with a different name?  

     

     

    I can't split the doc...it's my dissertation.

    You can't split it until you're done with it, then reassemble it into a final product?

     

    But if I turn off auto-recover then everything is fine.

    Is "auto-recover" the equivalent of "auto-save"?

     

    Prior to Lion's AutoSave and Versions, many apps that did autosaves would write the changed version of the file to a temp file (often in the same folder as the original, with something like "autosaved" appened to the end of the name).  Then delete the original and rename the temp.  Is that what Word is doing?

  • 11. Re: Time Machine makes MS word 2011 unable to save files....
    mszargar Level 1 Level 1 (0 points)

    You really have to be Microsoft to release 14 versions of a software and still not to know how to manage the file read/write process within a specific file system. I guess Bill Gates himself has written the code in DOS and it has not come to anybody else's mind in Microsoft to refactor it, since they have been too busy making a tools ribbon up there to waste 10% of our screen's vertical real estate and add a 10-minute seek time to our every instance of tool use.

     

    I have the exact same problem. I lost all the work I have done today despite CTRL+Sing literally every two minutes and not getting any error. My file is not even 10 megabytes, and yet nothing has been saved for hours and hours. Word used to make temporary hidden files in the same directory as the main file before, so at least the temp files could be backed up (my work directory is backed up by both Time Machine and DropBox). But now it has been UPGRADED to an autorecovery system, so it saves the temporary files wherever it wants, in some obscure folder that never comes to your mind to back up (I actually have backups of that folder as well but nothing shows up).

     

    So, I launched word and saw that although there was no recovery file saved anywhere, my file was recovered and only last sentences were missing. So, I pressed CTRL+S immediately, and guess what? Word crashed again. I am just wondering how this piece of c*** has become the dominant word processing solution, to the point that if I edit my file in any other software, I will have compatibility issues with the whole world. When will the software developers will be held responsible for their criminal acts?

  • 12. Re: Time Machine makes MS word 2011 unable to save files....
    riiiic Level 1 Level 1 (0 points)

    Hi Guys, I solved the problem by manually doing TimeCapsule Backup when I'm not working.....

     

     

    I hate Office suite for mac and as a metter of fact I'm obliged to use it in parallel session. Even in paralle, office 2010 is faster than MAC-Office.

     

    The only way to escape all this **** is to have a better (not-office like) iWorks suite!!

     

     

    I cross my finger and hope for the future!!

     

     

    p.s. after some months I made a clean install of Lion and the problem seemed to be solved. I think is something that falls some time after that currupt the file and so the aouto save or whatever. I will make you a list of bugs of this office suite, but it will useless, everytime they update it it becom worst :-P

     

     

    See you and thanks

  • 13. Re: Time Machine makes MS word 2011 unable to save files....
    knd79 Level 1 Level 1 (0 points)

    Hello,

    We've had a very similar issue with a large word file (example.docx, >20mb, mainly text but also some pictures) in a shared dropbox folder using MS Word 2011 v14.1.0 & Dropbox 1.4.12 on a MBP 13" early 2011 running OSX Lion 1.7.4.

     

    When working on the file from this machine, saving would have Word asking to renaming the file for, it pretends it to be open in another session and unwriteable. Providing a new name resulted in Word saving the updated file under that new name (say, example2.docx) BUT the original file (example.docx) was deleted and a file named "Word Work File L_XXXXXXXXX.tmp" (with the X's being numbers) would appear. And as expected, the deletion of file example.docx was propagated to the others sharing the folder.

     

    The problem never occured to other users working on the same file but with different machines (e.g. MBP 15" 2011 SSD-equipped and Word 2011, v14.2.3).

     

    We tried reinstalling the whole machine (OSX and Office) but this did not solve the problem...

  • 14. Re: Time Machine makes MS word 2011 unable to save files....
    Vamvakeros.A Level 1 Level 1 (0 points)

    Just a follow up. As of the upgrade to OS X 10.7.5, I cannot reproduce the problem and it appears to be resolved. Prior to this, I would have the severe manifestation of this issue resulting every time in a loss of the original file, with .tmp file losing all changes since the last Save. In any case, I have not dared reproduce the exact circumstances too many times just yet, but several attempts show that this no longer occurs after the OS update.

     

    No one is more critical of MS than me, but if my current experience holds, is it possible that this was an OS X issue all along?

1 2 Previous Next