Previous 1 2 Next 20 Replies Latest reply: Dec 14, 2012 11:20 AM by Reegor Go to original post
  • Vamvakeros.A Level 1 Level 1 (0 points)

    So sorry folks, I spoke too quickly. OS X upgrade to 10.7.5 and subsequent MS Office patch as of today does not resolve the problem. Loss of data is about the worst error that can happen with an application as basic as MS Word. Very disappointing circumstance.

  • Allen Hall Level 1 Level 1 (30 points)

    I can confirm 10.8.2, MS word 14.2.4, Retina MB, Time Machine turned to On, but not actually updating.  MS word is unable to save files.  I get two complaints- one is: "word cannot save while the file is in use by another process...." after which trying to save with a different file name (as suggested) results in a "improper file name" error.  The only work-around I've found is turning off Time Machine.

  • ancientscream Level 1 Level 1 (20 points)

    perhaps ignore a little the standard search microsoft forum response above for the moment, the problem may lie with apple, as I doubt these problems occurred with snow leopard and previous, as its the new OSX file versioning autosaving features that seemed to have cause allot of issues not just with office, my clients cant stand the lack of "save as" for instance, these new autosave features also has a hidden ability to lock files older than a certain age hidden within time machine preferences this might and I say "might" be the issue in question although "blocked" is more unusual in contrast to to the more common "locked" as an error, follow the following points in order >

     

    1: just check this article to see whether it may help with your issue.

     

    http://www.maclife.com/article/howtos/how_disable_os_x_lion_file_locking

     

    2: do the standard updates software routine to both office and osx you can, ie to 10.7.5 for lion for instance.

     

    3: do the standard disk utility permissions repair, although this sadly only affects, files other than user folders, user folder permission repair can be done but is more complicated.

     

    3: some with this issue recommend turning off time machine backups completely, as it also seems to interact with this issue, test this ?

     

    4: Note also lion and mountain lion have changed and tightened quite a bit the permissions and user control over OSX and file locations etc, for the endless over perceived security risks out there, meaning for instance lion will no longer let you save files to root without putting in your password etc, so Might I suggest also making sure that where your saving your word documents is within the user folder ? and see whether that resolves the issue. ie the file saving location in question maybe the issue.

     

    5: Sadly if you recently did an "upgrade to Lion", some Software issues may also resolved by reinstalling the said software afterwards, negating the point of an upgrade install, but anyway … as that can sometimes resolve issues with software from a Lion Upgrade.

     

    further :  if this is related to a temporary file save location within the application package as some software makers seem to do ? then permissions repair may have resolved it or it may require a microsoft update to the office if so, I thought doc temp files as regards microsoft documents were saved alongside the original file ? could be a temp file elsewhere though perhaps in the Microsoft folder in the user>library>application support maybe the issue stems from permissions there ? a search can reveal how to repair the permissions on the user folder which cannot be done through disk utility as standard.

  • Allen Hall Level 1 Level 1 (30 points)

    Sorry, while these are all good ideas, there are no solutions in your reply.  All preferences and disk repair functions have been performed, the problem still exists.  It does not appear to have anything to do with the save-as function, this happens on a command-S save whenever time-machine is in the ON position.

     

    Further reading about the issue is describing some instances of hard-drive corruption due to the way word saves files.  Some have had to completely reformat their drive, reinstall the os and files from backup.  There have been file-extent errors as well.  This screams a problem with Word's method of saving.  Why would file extent issues occur?  They're overwriting bits on the drive they shouldn't be.  These are likely two issues, but for now, I'm forced to turn time-machine off (and manually backup when I remember)- as well as manual saves on the files.  I'm also working with all word files in a sparsebundle disk image in order to attempt to save my drive from corruption.

     

    I hope that M$ realizes that these are real problems.  Couple this with the retina display rendering issues since Word refuses to use Apple's rendering engine, and I'm going to do my best to avoid M$ word in the future in every possible way.

  • Happy Dog Level 2 Level 2 (195 points)

    Having the same problem, and not thinking to check this discussion, I called Microsoft support.  At the end of the day they told me Word won't save while another process is saving.  I noted that Time Machine was not actually saving at that moment, but they repeated the same statement/ I inferred even having Time Machine set for automatic backups will mess with the save function in Word.  Since iWorks doesn't meet my needs, I guess I'll have to set Time Machine on manual.  Funny how so many of the timesavers save no time at all.

  • Reegor Level 1 Level 1 (0 points)

    This problem has been fully analyzed on another thread:

    https://discussions.apple.com/message/20593770?ac_cid=tw123456#20593770

     

    Turning off Word Autosave is not sufficient. The only proven solutions are:

    1) Don't use Word. I have switched to Nisus Write Pro, with surprisingly little trouble.

    2) Keep Time Machine set to OFF when using Word.

     

    The bad news is that this bug can and will sometimes force you to reformat your entire drive and reinstall!! Most of these reports have been people using SSDs, but we have one report at least from a conventional hard drive.

       Look at the last few pages of the above thread - a bug fix is on the way from Apple.

     

    Here is the known workaround, from MMWeinstein:

    Keep TimeMachine turned off most of the time.  When backing up, close MS Office programs, run your backup, turn TimeMachine off again, resume use of Office.  This is what I've been doing and it's worked so far (knock on wood).  Since my backup drive uses a USB connection, it's only connected at the end of the day, so switching TimeMachine on and off isn't too much of an annoyance for me.  If you use a wireless time capsule, you may have issues with this idea.

Previous 1 2 Next