Previous 1 2 3 Next 133 Replies Latest reply: Nov 5, 2014 7:04 PM by kanneric
iPhone 4sA Level 1 (0 points)

I just bought a new factory unlocked iPhone 4S from Canada and viber isn't working properly on it.  After I click on end to end the call, it ends the call.  But when I click on the home botton it goes to the home screen but it shows on the top of the screen that viber is still active, as if i'm still on a call. I would have to start the phone application and call someonen to end viber!

anybody has the same problem?!!! Please help....

iPhone 4S, iOS 5.0.1
  • razmee209 Level 7 (29,260 points)

    you might want to direct your query to viber app maker directly.   They can probably answer your question or maybe come up with an update to fix your problem.

  • theViberTeam Level 1 (105 points)



    This is a member of Viber's development team.


    That is indeed an odd issue...


    Did you try to uninstall and reinstall Viber?


    Viber Team

  • iPhone 4sA Level 1 (0 points)

    Yes, I have tried to delete and reinstall Viber and it did the same problem.  I even restored the phone (even though it's like a week old!).  I found a guy on YouTube with the same same problem.  (I will add the link below)


    Notice in the video that when the guy pushs viber from the home screen, it takes him to call log in Viber.  It is supposed to only take him to an active call (if there is one).  In this case, he end the call and went to the home screen but it showed that Viber was still active via that red bar at the top!


    This video is exactly what heppend with my iPhone. However, it's been working fine for all of yesterday and today. I don't know why, I didn't do anything different. 


    I hope it doesn't do it again!


    Okay, here's the link:

  • theViberTeam Level 1 (105 points)

    Hi again.


    We've just released a new version of Viber (2.1.4) to AppStore. Please try uninstall your current version and install the new one, and see if the problem persists. If it does, please let us know.

  • Momo.hbg Level 1 (0 points)

    i am having the same problem and even more problems.....


    when i call some1 it rings and rings but he doesnt get the call, its the same with every1 on my address book, it works perfect with iphone 3....



    also after a few calls when i call some1 it doesnt ring... then i have to reboot iphone before it starts ringing


    not to mention the "viber is still actrive" red line when ur not calling....


    i always have latest viber and i have restored iphone and updated it (i did factory restory and i havent installed anything but viber on it atm) and still same problem...


    this is frustrating i dont know if its wrong with iphone or viber.....

  • iPhone 4sA Level 1 (0 points)

    I have these same problems too. I also did the restore as well and I was still having the same problems! And I got really frustrated that I almost threw my iPhone out the window, so what I did was tried not to think about and used Tango instead!

    Tango is FaceTime over 3G network but you can use it as voice only. It's actually more clear than viber in general!


    Do you have an iPhone 4s?! If so, check and see you if you can access the Internet while you're on a GSM call for me please?!

    On my iPhone 4 I was able to do it but on my iPhone 4s it doesn't work!!!

  • Asterii Level 1 (10 points)

    Viber team, if you read this, please note that I have the same problems with my iPhone 4s!!!

    Now when I call, it shows "Ringing", but there is no sound at all, and no connection. Most often you have to call 10 times or restart the phone to use Viber.

    Then, when you finally end talking (if you were lucky) and quit the app, it is still on with a red tape above, exactly like on the YouTube clip.

    Yesterday when I tried to restart the phone to end the Viber red tape, it even crashed the phone!

    What's going on?! It is supposed that apps should get better with every release, not worse.

    It is very annoying, as I have a lot of contacts on Viber and I liked to use it.

  • HumayunViqar Level 1 (0 points)

    Is viber worked in UAE!,I just installed viber on my iPhone 4s (5.0.1 9A405), installation was ok but I could not see any viber contact.

  • theViberTeam Level 1 (105 points)

    @Asterii -


    I apologize for my late response.

    Please make sure neither you nor the other side are connected to networks that might be blocking Viber (for example - a router running a firewall).


    1. First, please try uninstalling and reinstalling Viber when connected to different WiFi networks. Does it work now?

    2. Also, please make sure the following ports are enabled on your routers or firewalls:

    TCP: 5242 + 4244

    UDP: 5243 + 9785


    (if you are not sure how to enable ports, contact your router manufacturer)


    * Also, please specify what country you are located in. It might be related to the issue.


    @HumayunViqar -


    The authorities in the UAE have decided to block Viber in the whole country, and that is why you are experiencing this issue. Unfortunately there is not much we can do to help

    Try contacting the authorities and ask for the reason for this block.

  • iPhone 4sA Level 1 (0 points)

    Could there be some type software/hardware conflict on the iPhone 4s??!!!!

    Because, apparently, many people are having the exact same problems!

    I've giving up on using it because I get really frustrated that it doesn't work! It worked GRREEAAATTT on my iPhone 4!!!!


    theViberTeam, please test and try to fix with an iPhone 4S.



  • HumayunViqar Level 1 (0 points)

    well, if it is blocked by telecom authorities in UAE then why viber works with iPhone 4 not with 4S.  It might be issue with 4S release of viber, develpment team need to focus on that.

  • theViberTeam Level 1 (105 points)


    iPhone 4sA-


    We are about to release a new versino of Viber on AppStore quite soon (hopefully several days). Once released, please try it out and let me know if the problem is resolved. I'll redirect you to the relevant department in our company to get more info from you so we could finally solve this issue. Thank you in advance


    @HumayunViqar -

    We are not sure about the technical details of the block in the UAE, but as far as we know it is gradual, meaning for some people Viber might still work and for others it will be problematic, until it generally doesn't work in the whole country. We apologize, but there is really not much we can do to help users bypass this legal block

  • Beny@Dubai Level 1 (0 points)

    Good afternoon,


    I've been using Viber ever since I came over to the UAE five months ago. I hold a subscription with du and never had a problem except for some network performance issues not related to Viber itself.


    The fact is that I've been facing problems over the last couple of weeks and I've removed and reinstalled Viber 2.1.5 and it does not work. I've been prompted to reintroduce my local number and got an answer back telling me that I would receive a code over an SMS as if it were registered for the very first time. The SMS does not come through and I cannot activate the application.


    As a consequence of this, I can't use my contact list and I cannot get it up and running.


    I would appreciate if you could cast some light on the subject.


    As I understand it, they are in the verge of prohibiting it in the UAE. I thought that the limitation only existed in Etisalat but not in du.


    Thanks in advance for your help.


    Best regards,




    iPhone 4S, iOS 5.1

  • iPhone 4sA Level 1 (0 points)

    The New version they've just released, version fixed all the problems that a lot of people were having on their iPhone 4S.


    Thanks Viber team. It works GREAT now!!!!


    I don't really know about the UAE problem.  Try to request a call back instead of an SMS for the Code!

Previous 1 2 3 Next