2 Replies Latest reply: Jan 29, 2013 1:43 PM by grantliddell
PeerK Level 1 Level 1 (0 points)

Hi,

 

I REALLY hope someone can help here!

 

I've been reading every ressource I can find on the subject but this I cannot fix! I've bought an Airport Express and connected it to my stereo to use as an Airplay device. Sometimes it will work for hours and hours before whatever goes wrong happens - sometimes it starts pretty much right away.

 

The problem is the sound becomes choppy for a little while and then completely stops. It doesn't matter if I play from iTunes on my Mac Pro or (which was the whole idea of my purchase) from Spotify on my iPad or iPhone - although the problem seems to be much worse when playing from iPad/iPhone.

 

If I plug the minijack from the AE directly to my iPad it works perfectly - so it's not getting the data from the internet to Spotify that's the problem.

 

My AE is running the newest firmware and is setup to just join my wifi - WPA/WPA2 Personal, Channel 7 (I have tried them all), Allow Ethernet Clients is off, hardcoded IPv4 address (have tried DHCP), AirPlay enabled (of course) - no password, no printers.

 

The "main" wifi router is a Linkys WRT54G. I have tried B Only, G Only and Mixed as the wireless network mode, and as I mentioned all the different channels. I have tried changing Beacon Intercal, DTIM Interval and friends with values from some other posts in here - currently they are :

 

Authentication Type : Auto

Basic Rate : Default

Transmission Rate : Auto

CTS Protection : Auto

Fram Burst : Disable

Beacon Interval : 75

DTIM Interval : 1

Fragmentation Threshold : 2304

RTS Threshold : 2307

 

It's not a range issue either - it doesn't matter if all devices are right next to eachother.

 

There are no errors in the log-file as far as I can tell - here's what it looks like :

 

Jan 23 16:22:58Severity:4AirTunes stream from fe80::8ac6:63ff:fee9:7614%bridge0 started.
Jan 23 16:38:10Severity:5Clock synchronized to network time server time.apple.com (adjusted +0 seconds).
Jan 23 17:03:09Severity:4AirTunes stream from fe80::8ac6:63ff:fee9:7614%bridge0 stopped.
Jan 23 17:03:14Severity:4AirTunes stream from fe80::8ac6:63ff:fee9:7614%bridge0 started.
Jan 23 17:03:45Severity:4AirTunes stream from fe80::8ac6:63ff:fee9:7614%bridge0 stopped.
Jan 23 17:03:51Severity:5Connection accepted from [fe80::21d:4fff:fe46:3a38%bridge0]:53223.

 

It stopped working at 17:03:45 (after failed attempts to resume it from Spotify, I assume).

 

Really hope some experts are out there! :-)