2 Replies Latest reply: Sep 29, 2012 8:09 AM by Mcboy
believe1389 Level 1 Level 1 (0 points)

I have a 2008 black Macbook. Recently, my orginial charger blew and I ended up buying a new one. Once I received my new charger, I charged the battery and took it off the charger. However, once I went to charge my computer again the charger would not register that it needed charging. So, I thought maybe the battery was dying (as it was the orginial one) so I bought a new battery. I thought the problem was solved as once putting in the new battery the charger immediately recognized the computer needed to be charged. However, I've run into the same problem again. If I unplug the charger it won't charge the computer once I plug it in again (though after a few days it'll charge it again, but if taken off I run into the same problem). Is there a problem internally within my computer (as it can't be the battery or charger since they are both brand new) and has anyone run into the same issue?


MacBook Black 13 in. (Early 2008), Mac OS X (10.5.4)