Skip navigation

sudo: can't open /private/etc/sudoers: Permission denied  |  sudo: no valid sudoers sources found, quitting

21210 Views 20 Replies Latest reply: Jan 5, 2014 2:40 AM by kbiz01 RSS
1 2 Previous Next
AidanBW Level 1 Level 1 (55 points)
Currently Being Moderated
Jan 24, 2012 12:17 PM

Hi,

I've had this problem before on an old machine and managed to fix it quite quickly, but the things I tried before don't seem to be working on this machine.

 

Basically, when I go in to Terminal and try running something with sudo, it just echoes:

sudo: can't open /private/etc/sudoers: Permission denied

sudo: no valid sudoers sources found, quitting

 

I also get the same message when booted in to Single user mode, thinking it might just have been an issue with my users id. I have already tried changing the file permissions, editing the sudoers file to add in my local users record etc...... but then it just gives me a different error message (eventually coming back to the above when I try changing something else to fix it).

 

I've run Applejack and Diskutility, but as expected they don't work either........

 

Any help would be much appreciated!- my new MacBook Pro won't even install anything requiring root permissions any longer, giving the same error message in the /var/log/install.log! :-(

 

As you can understand, I'm very upset because it is a new machine, and I have no idea what would have caused this to happen. The usual cause is editing the sudoers file without using visudo, but I can never recall doing that.

 

I need my root access back!

 

Kind regards,

Aidan

iMac, Mac OS X (10.7.2), Hardware Serial: VM025TDGB9S
1 2 Previous Next

Actions

More Like This

  • Retrieving data ...

Bookmarked By (2)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.