5 Replies Latest reply: Jan 27, 2012 2:27 AM by woodmeister50
jeremy_c Level 1 (15 points)

I purchased a brand new Mac Mini about a month ago, an i7 2.7GHz. I purchased it with 4g of ram and purchased on the side 8G of ram by Corsair (DDR3 1333 SODIMM modules, 9-9-9-24). I purchased the "Mac Memory" version of these sticks. Put them in (super easy) and all is well, or so I thought. On my first backup with Time Machine, hard lock. Second backup, hard lock. I never could get a good backup. I ignored it for then. I then went into iMovie. Working on a project for more than 20 minutes results in a hard lock. So, I put the old 4G ram back in and everything works great, no hard locks.


I put MemTest86+ on a USB drive, put the 8g ram back in and booted. It gets through one full test successfully and then hard locks 1/2 way through the second test. Bad ram I figure.


I purchase a different brand, Centon. DDR3-1333 8G SODIMM modules (unsure of the CAS rating). Put the sticks in, everything works great. I did a full Time Machine backup just to test, and did some heavy video editing just for the fun of it, no hard locks, yay! Then about 3 hours into using it, the screen goes gray and I get the OS X "You must reboot" message. Rebooting yields 3 beeps and black screen, 3 beeps, etc... I popped the bottom thinking that maybe one of the sticks was not fully seated (I admin hundreds of computers and have installed countless number of memory modules but one can always make a mistake!). Everything seemed fine, but I reseated them for the fun of it. Same thing, 3 beeps. Nothing I do makes that memory work again. I read where resetting the NVRAM could do the trick, I reseated the memory, I cleaned the contacts, still 3 beeps.


I put the trusty 4g that came with the mac back in, everything works fine. At this point, I put the Corsair back in (that I think is faulty) and ran the Apple Diagnostics (D) tool 3 times with extended testing turned on. It found no problem. I thought maybe the NVRAM reset trick that I learned may have made this ram now work. So I started OS X, ran iMovie and in about 10 minutes, hard lock.


So... in the end I have tried Corsair Mac Memory and Centon memory (non-mac version) with no luck. One is unstable, the other doesn't work.


I know it is possible that I got two different packages of bad sticks but unlikely. The nearest store that sells this stuff is an hour away, so I'm not sure I want to go for a third try.


Any thoughts? About handling the ram, I do know how to handle it and the original 4G that I have swapped in and our quite a few times now works great, so I don't think I am zapping the memory or anything. I've handled the original 4G twice as many times as the new chips and they are great. Oh, I am using OS X 10.7.2, but I don't think that has anything to do with it as I have lockups in MemTest86+ that I booted into (i.e. no OS X software loaded at all).


Thanks for any help,



Mac mini (Mid 2011), Mac OS X (10.7.2), i7 2.7GHz
  • den.thed Level 7 (25,615 points)

    Mac's can be very picky and lots of folks have reported problems with Value RAM and off brands. Your best bet is to stick with third party suppliers that work well for others here in the forum like OWC (macsale) or Crucial.


    Apple Mac mini Memory DDR3 / Ram upgrades for 2011 Mac mini unibody models


    Crucial Memory Upgrades for Macs - Apple Memory


    Adding that, I'm not sure why the Corsair RAM is not working (my Early 2006 iMac has had Corsair RAM in it for almost 6 years without an issue) unless you were sent the wrong spec's, an unmatched pair or a bad module?


    Mac mini (Mid 2011): Memory specifications and upgrades

  • jeremy_c Level 1 (15 points)

    Corsair is, I thought, a very high end name in Memory. Maybe I just have a bad stick from them. My local store sells Centon memory, that is how I wound up with it. The apple store does have Centon products for sale. The current status of my mac mini is this:


    I returned the bad Centon ram to my local computer shop in exchange for the more expensive Centon ram (same specs) with the "Mac Ready" logo. After installing it, I have been running iMovie, Memtest, MemTest86+ and Prime95 (torture) test with no locks and no errors.


    I guess I simply had two bad packages of RAM. Hard to believe, but it seems so. I will be torture testing this RAM for a few more hours and we will see how it makes out. If it fails, I will make a purchase from macsale.

  • woodmeister50 Level 5 (4,835 points)

    Is the Corsair RAM you are using hve this number:



    I have put these kits into both my 2011 Mini Server

    and my 2011 Macbook Pro and they work quite well.

    Suprised that you have problems.  Perhaps you are just

    unlucky at getting bad memory.


    Although it is 20/20 hindsight now, you may have tried

    just one card at a time (with one of the originals) and

    switching slots to see if you had just one bad card.

  • jeremy_c Level 1 (15 points)

    woodmeister50, yes, that is the exact model number I have purchased. I did not install just one of the Corsair chips because with both they boot, it was just unstable with two in. I guess I could have narrowed it down to which was the bad chip but it would still mean I have to return the two, as they are a pair. When I got the second pair (Centon) I then went into it further because they had similar problems, so I then began suspecting Mac Mini problems.


    In the end, I guess it turned out to be two packages of bad ram. The third time was the charm for me. I let MemTest86+ run last night until this morning. It was able to complete 6 tests in that time and there were no errors and the system was still running, i.e. no hard locks. That is in addition to what I did above.


    So, I am hoping I am in the clear. I am doing another full time machine backup again to be sure as that was where I originally started having the problems with the Corsair memory.

  • woodmeister50 Level 5 (4,835 points)

    jeremy_c wrote:


    woodmeister50, yes, that is the exact model number I have purchased.

    Just wanted to make sure.  Sometimes things get mixed up in

    shipping and you may not get what was ordered.


    Glad to hear things seem to be working well.