Previous 1 19 20 21 22 23 Next 386 Replies Latest reply: Nov 27, 2015 4:36 AM by ncsny Go to original post Branched to a new discussion.
  • MacPear Level 1 (0 points)

    Be careful. One user here had this problem also in a wired setting, even using apple time capsule. The problem really seams to be backing up in a network. Reducing the frequency of this error may be wired backup. In my personal experience disabling HDD sleep in OSX setting did also help, but this was maybe to much for mine and shortly after it broke down , so I wouldn't suggest this anymore .


    Really not sexy but considerably is FW or USB3 backup. And we should contact print and online media. If their writers would be as upset as we are and write about this TM software bug, Apple would maybe react and redesign TM.

  • fullframesf Level 1 (0 points)

    I have had this problem on and off for a long time.  I've been using a ReadyNAS Pro.  I do not believe the problem is wireless.  When I had a desktop (connected via ethernet), it would occur on my desktop too.  Eventually, I gave up and added another internal drive to the Mac Pro and used that for Time Machine.  Currently, I only have a laptop, and this problem develops whether it's connected via ethernet or wireless.


    I've given up.  I am going to purchase a USB 3 drive and use that as a backup.  Time Machine is simply unreliable when backing up over any type of network.  I'm going to clean out my NAS and put it up for sale since it's primary existence was for backups.  In the future, if there is an alternative to Time Machine, I will definitely switch.  Apple apparently does not care enough about this problem and a fix doesn't appear to be coming anytime soon.

  • pointpeninsula Level 1 (0 points)

    I was somewhat active on this forum with this problem, and now I just lurk a little. My sollution was pretty simple - I just quit backing up.


    I had a Netgear ReadyNAS Duo, and I've exchanged that for a Synology 4-bay unit. I keep all my files on the NAS, never on the MBP or iMac, so it doesn't matter much to me if my harddrive melts down. The only advantage to the backup would be to restore my OS and apps.


    I find that iPhoto and iTunes run better on my iMac (acting as a media server), so I let the files live there, but they're manually copied to the NAS when I purchase music or take some photos.


    Time Machine has a cute interface and all, but it's just not worth the aggravation. (FWIW, Microsoft never got backup right, either. Norton Ghost worked great for my Dell when I was a brown-suit guy, and yes, wirelessly.)


    I'm not sure I buy the explanation about wireless being less reliable than wired, and wired less than a Thunderbolt or USB connected drive. The lower layers of the network protocol abstract the hardware from the application, and will supply error-free data to it.


    This solutionn won't appeal to a lot of folks, but it works okay for me. One advantage is that if my MBP were stolen or lost, there's little on it that could enable an identity thief.


    I figured, if you can't fix it, quit!



  • mosley1 Level 1 (15 points)

    I too dont believe the problem is wireless. As I have posted on this forum previously, I have two computers running time machine: an iMac (10.7.x) and a MacBook Pro (10.8.x). Both are wireless. I have a Synology NAS (ethernet). I have only experienced this problem with my MacBook Pro. I have never, not once, experienced this problem on with my iMac.


    I have been experimenting with Carbon Copy Cloner, and so far I like it. I soon may saying goodbye to TimeMachine for good.


    @pointpeninsula - I also keep all my important files, photos, movies and home movies on my NAS, which I back up to an external USB drive.

  • lukasco Level 1 (15 points)

    I tried carbon copy cloner but in the end ran into similar problems of the sparse bundle not quite working. Don't remember the exact issues, but trouble with user names/connecting to the nas and backups failing. Gave up on that too. ChronoSync works because it just copies files but isn't quite right for full backup, and the only actually working backup I've found is crash plan to their servers. Crash plan to the nas also had problems though is now working reliably after I stopped the laptop sleeping WiFi.


    Frustrating at every level is my verdict.


    So my solution: crash plan for the off site emergency backup. Good luck with the rest!

  • mpatric Level 1 (10 points)

    I also switched to Carbon Copy Cloner and for a while it worked fine. I also then got an error. The message was something helpful like "Could not backup, an error occurred". I eventually had to created a new disk image for it to backup to and restart the backup from scratch. This was annoying for many reasons, not least of which was that I had just shelled out for a licensed copy of Carbon Copy Cloner. I'm sticking with it for now and hoping the error does not persist. But those thinking it's the solution to your time machine woes, it may not be.

  • kanek Level 1 (0 points)

    Pondini, I want to thank you for being such an active contributor to this kind of topic all over the 'net, and for your very helpful website!


    I bought a ds213air a couple months ago to try to protect myself against drive failure, and for all the other streaming and NAS benefits.  I setup Time Machine and thought it was running, did have to rebuild the backups every so often, but thought I was protected.  However, May 4 my laptop disk failed, and although I had a Time Machine backup from May 3, Time Machine cannot "see" it.  Files are still there with those dates.  I've tried copying files over to local disk with SuperDuper and then repairing with instructions found, no dice.  I've tried Data Rescue 3 acting against that copied local filesystem from SuperDuper, no dice (I did recover a few files that way, not much).  I took the failed disk to a local guy to see whether he could recover it - quote of $500 at least I'm still waiting on, may not be worth it for me.


    I tried seeing whether DiskWarrior could repair the original Synology attached files, but they must be local.  Am considering getting a USB drive enclosure to attach it to the local Mac and see whether Data Rescue or DiskWarrior can get anything from it, anyone had luck with this?


    Are there any other good software people have used to read TimeMachine files that has a chance to recover files for me?  I'd most like to recover my turbotax 2012 file, much of the rest of the data I think I can get elsewhere (but I never know what I've lost, you know?!?!).


    Thanks in advance to any replies, this thread is very helpful.

  • kanek Level 1 (0 points)

    Should have added that I'm running OSX 10.7.5, and synology DSM 4.2, thanks.

  • EdHayes3 Level 1 (0 points)

    Website looks really ghetto, but I have heard many good things about SpinRight. you could give that a try. I've never used it thought. You may need a PC to run it, but it will repair a MAC HDD. And I think they offer money back gaurantee.


    A shame you dont have any bootable images of your hard drive made with SuperDuper.

  • kanek Level 1 (0 points)

    That's for sure.  I trusted Time Machine entirely too much, never had issues I needed to restore, before, plus got caught in transition, in between old and new backup USB drives that I used to use to back occassional files to.


    Going forward I will probably abandon Time Machine to NAS (or entirely abandon Time Machine), and either just create regular weekly clones locally, then copy then to NAS, or something similar as others have said here.  For what it's worth, so far on the copied files, I've also tried:

 ,08,27,169,fix-time-machine-sparsebundle-nas-b ased-backup-errors.html

    and ran across this site which illustrates that my pain has been felt by others:


    Thanks, I'll add spinright to the queue to try, do recall hearing other good things, too.

  • macgnu Level 1 (0 points)

    Hi all,


    I am new to this forum and have just finished reading (most of) the postings on the 21(!) pages to date of this thread. I can't offer much in the way of solutions to the problem, I'm afraid, but would like to share my limited experience.


    I have an iMac (new in Feb. 2010; OSX10.6.8), a Retina MacBookPro (my wife’s – new in Jan 2013; 10.8.3) and a QNAP-NAS TS-219P II (new in Dec. 2012; FW 3.8.2). Before I had the NAS I backuped to a USB-HD attached directly to my iMac with TM and never had any problems.


    With the advent of a 2nd Mac and because the space on the USB-HD was getting crowded, I decided to buy a NAS, mostly to backup both Mac’s to it. Obviously I shouldn’t have believed QNAP’s claim that their NAS is TimeMachine compatible. A few weeks later I saw the dreaded message "Time Machine completed a verification of your backups.  To improve reliability, Time Machine must create a new backup for you" on my iMac for the first time. The iMac is connected to the NAS via cable through a Fritz!-Router. Shortly afterwards the same message appeared on the MacBook (on a Wifi connection). I tried the “Garth method”, but apparently the sparsebundle was corrupted beyond repair. This time (third time on the iMac, second on the MacBook) I’m experiencing permission problems accessing the TMBackup share on the NAS …


    To sum up my experience: the problem persists regardless of cable or Wifi connection, with OSX 10.6.8 and 10.8.3, and after I updated the NAS-Firmware. As I found out in a QNAP forum, even the newest firmware release (3.8.2) does not incorporate the newest version of netatalk – so that may be (a part of) the problem.


    I have  renamed my iMac because the name originally contained blanks, an apostrophe and a non-ASCII letter (this was a tip from a  forum). The Wifi connection should normally be good – the MacBook usually sits next to a repeater (which is connected to the router via cable) when it’s backing up.


    Needless to say, I, too, am very frustrated by the apparent lack of response by Apple and QNAP (in my case).

  • macgnu Level 1 (0 points)

    FWIW: the firmware version on my NAS is 3.8.3 (not 3.8.2 as stated above). [Can't seem to be able to edit my original post any more.]

  • Cristinita Level 1 (0 points)



    After having had many problems backing up TM wirelesly with my LaCie Network Space and not having found a solution for it, I am about to switch to a LaCie Minimus (only connectable via USB).


    Before I do that, I just wanted to know if I would still be able to use Time Machine with it.


    Can I set up TM to back up to a USB connected disk? Will it back up only when it is connected to the drive, or do I need to have the drive connected to my Mac all the time?



  • Pondini Level 8 (38,740 points)

    Cristinita wrote:

    . . .

    Before I do that, I just wanted to know if I would still be able to use Time Machine with it.


    Can I set up TM to back up to a USB connected disk?

    Yes.  That's the most common, fastest, and most reliable way to back up (with any backup app, not just Time Machine).


    Will it back up only when it is connected to the drive, or do I need to have the drive connected to my Mac all the time?

    It's usually a good idea to keep it connected when convenient, of course, so Time Machine can do it's quick hourly backups.  Just be sure to eject it before disconnecting.


    When the drive isn't available, Time Machine will just wait patiently for you to connect it.  If it goes 10 days without a backup, however, you'll get a notice once a day. 


    See Time Machine - Frequently Asked Question #21 for setup instructions.

  • Klaus Blume Level 2 (310 points)

    So..., we have a new Time Capsule. Does anyone know whether Time Machine has also been updated to reflect the concerns expressed in this forum?

Previous 1 19 20 21 22 23 Next