2 Replies Latest reply: Jul 13, 2012 5:53 AM by dragontam73
Nabil123 Level 1 (0 points)

As stated above. I have had this problem for the last 2-3 days. I have always been able to connect to the internet over wi-fi using my iphone but this problem had persisted these few days. This is a problem because my iPhone shows that I do have connection to the internet. ( I assume this from looking at the internet signal stregth bar at the top of the screen.) My laptop and computer have no problem but the message "safari cannot open the page because it could not connect to the server," keeps on appearing on my phone whenever I try to access the internet.

     If it is of any relevance I use an iPhone 4s, reasonably new, practically 2 months. I have never had problems before this. Thank you for your help in advance.

iPhone 4S, iOS 5.0.1
  • JimHdk Level 7 (28,340 points)

    The connection strength icon you are referring to has nothing to do with the Internet. It simply indicates the strength of your connection to your local WiFi network. However, even when this icon appears you may not really be connected to your WiFi network.


    Your router may not have given your iPhone a valid local network IP address. To check on this go to Settings > Wifi > your network name and touch the ">" to the right to see the network details. If the IP address starts with 169 or is blank then your router didn't provide an IP address and you won't be able to access the Internet.


    Sometimes the fix for this can be as simple as restarting your router (remove power to it for 30 seconds and restart). Next, reset network settings on your iPhone (Settings > General > Reset > Reset network settings) and then attempt to connect. In other cases it might be necessary to update the router's firmware with the latest from the manufacturer's support web pages.


    If you need more help please give more details on your network, i.e., your router make, model and version, the wifi security being used (WEP, WPA, WPA2), etc.

  • dragontam73 Level 1 (0 points)

    Thanks solved my problem.