Previous 1 2 Next 17 Replies Latest reply: Jun 17, 2015 6:48 PM by spiderluke
Nick3rs Level 1 Level 1 (0 points)



Im play alot of games online under bootcamp using windows 7 ult 64bit however for the life of me I'm unable to get the input line to recognize my mic...


Does anyone know how to fix this??? Much appreciated!

MacBook Pro, Mac OS X (10.7.2)
  • Jaygyver Level 3 Level 3 (735 points)

    What are you using, Headset/Mic, or just the built-in Mic? Are you using Skype, Steam, TeamSpeak, etc,? What have you tried? USB audio adapter?


    Some headset/mics aren't compatible with some of the services. Can you see the Mic work in Windows in the setup panel? The biggest thing is to get it to work in Windows before you try anything else.


    My kid uses Steam and Skype and have no problems, at least after figuring it out.

  • Nick3rs Level 1 Level 1 (0 points)

    Im using a headset wich has a mic here's the exact product: Link


    I have the line out plugged into the speakers on the headset and the line in connected to the microphone part of the headset.


    Im using skype and steam and am not trying to purchase a bulky usb adapter thats going to take up 1 of my few usb ports.  They way I see it the line in should be sufficient.


    Windows and programs show the line in however it doesn't recieve sound and defualts to the build in microphone on the mbp.  It actaully took me awhile to notice the mic on the headset wasn't working becuase the laptop was picking up my voice, untill one day my firends heard a conversation i was having with a sibling.


    I have also not had the mic work in lion

  • Jaygyver Level 3 Level 3 (735 points)

    Did you go into the Sound control panel and select it?


    We have a couple of cheap USB audio adapters (and an el-cheapo headset/mic) that we just plug into a USB hub and it shows up in the Recording tab, just double click on the Microphone device,(yours should be under Line In) select the Listen tab, and select your device again. That's all I had to do with mine. (My selection was just "Generic USB Audio Device") Oh yeah, and i changed the Icon to a head set instead of whatever it had there before.


    It's been awhile since I've played with this stuff so that's about all I can help you with. Maybe try leaving them unplugged the next time you restart into Windows then plug them in and see if it will find it? Does your Device Manager say anything?

  • Nick3rs Level 1 Level 1 (0 points)

    Like I said, Its not a USB connecting headset, It connects via a 3.5mm headphone a microphon jack.

  • Jaygyver Level 3 Level 3 (735 points)

    Jaygyver wrote:


    Did you go into the Sound control panel and select it?


    We have a couple of cheap USB audio adapters (and an el-cheapo headset/mic) that we just plug into a USB hub and it shows up in the Recording tab, just double click on the Microphone device,(yours should be under Line In) select the Listen tab, and select your device again. That's all I had to do with mine. (My selection was just "Generic USB Audio Device") Oh yeah, and i changed the Icon to a head set instead of whatever it had there before.


    And like I said yours should show up under the LINE-IN description. The rest was to give you an example on what to look for as you didn't say what you have done or where you had looked. (Those 3.5mm pins plug into the USB adapter, again as an example.)

    Either way Windows should show it as a "named"  or a "generic" audio device.


    I believe @CSound1 is knowledgeable on this stuff so hopefully he will catch site of your post.

  • Nick3rs Level 1 Level 1 (0 points)

    I see what you mean by usb adapter...


    This headset doesn't have that, thus not having a power suply I also found out if the headset doesn't have a power supply it wont work with the mbp's hardware since the line is, is only a line in...


    Returned this and order a simply logitech headset which should work..usb connection


    Thanks for you help!

  • Jaygyver Level 3 Level 3 (735 points)

    Most of the head phones and combo's do still come with just the 3.5 mm pins so if you don't want to use a USB adapter just look for one that comes with the pins standard or that the adapter is separate. Also make sure they have a dual pin onless you have a dual connector that sepearates the signals.


    My el-cheapo combo one has ONE 3.5 pin that also came with a separate "1 into 2" adapter that turns into TWO 3.5mm pins for plugging into separate connections, mic/speakers.

    I just have the dual pins plugged into the USB adapter as I don't have a Mic connector on my computer. Turns out if it didn't come with the 2/1 adapter I would have had to buy it anyway. Just saying.

  • bstordy Level 1 Level 1 (0 points)

    Hey there,

    I'm having a similar issue... I have a headphone & mic headset with a 3.5 mm jack on my iMac which is running windows 7 ultimate, OSX Lion and the most recent bootcamp and my mic is not recognized.Tthe built in mic works, but i can't seem to get the headset to work. (its a Bose MIE2i earbud/mic set)


    I have gone into control panel > hardware and sound > manage audio devices and have clicked "show disabled devices" etc to no avail.



  • palessi Level 1 Level 1 (0 points)

    I'm having the same issue. Line in mic works fine in Lion, but I can't get any sound out of in in Windows 7 under Boot Camp.

  • Jaygyver Level 3 Level 3 (735 points)

    @bstordy and @palessi


    The only thing I can suggest is to do a search here or via Yahoo/Google and just read through the post's. It's an on going problem with the Boot Camp drivers and even the Window drivers not working for some reason.


    From what I've read the things that sometimes works: is to go directly to the manufacrurer's web site of the sound card you have and try downloading the drivers directly from there.

    Some have had to use an UNinstaller and completely uninstall the drivers completely and then reinstall them. Other do finally get them to work just fiddling with the different preference's/property's.

    And some head phones just don't seem to work.

  • Nick3rs Level 1 Level 1 (0 points)

    Bottum line is, this is a problem Apple should be well aware about and needs to be fixed

  • kerzhul Level 1 Level 1 (0 points)

    I guess i'm a bit late to this thread, but from what i gathered a few years back, only sound sources with sufficient power (amplified ones) work with the line in. IE, i used a cheap turntable i have that has pre-amplification on it to record some old vinyls and it worked fine but had no luck with any non-powered microphone.


    I wonder if the newest version of the Carcharias (the one which works with the xbox too) has power enough?


    Then again, i'm talking of my own iMac and macbook (2008ish and 2007ish).


    Also, as was suggested, the manufacturer drivers can work wonders. I hardly had sound under bootcamp with imac (win7) and installed the default drivers available at


    Try and fiddle with it i guess.


    And apple doesn't give a rats a** if the line in doesn't work with a microphone under other OS that it's not mac os x...

  • Moodywa Level 1 Level 1 (0 points)

    So from the date of the most recent post, this seems to be an issue that never was resolved and I'm stumbling upon a bit late in the thread but...


    I was sitting here using my MC721*/A or MacBookPro8,2 and had started using a 3rd party online client to team-speak/voice-chat for a game. Previously I had only used integrated/in-game software based voice-chat interfaces so this was the first time I actually encountered this issue.


    And I find it bizarre. Read through all the possible solutions and methods of trying to utilize a headphone/mic combo input (such as the one provided with iPhones and other apple devices). Now that I am addressing the issue from a Win 7 64x level approach, I'm completely baffled that it isn't possible/isn't a solved/addressed issue with the Apple hardware and bootcamp drivers.


    This is even stranger to me because previous while playing (SoE's Everquest 2) and using the in-game voice interface, the options allowed me to select my headphone input as both the incoming sound device and as an independent playback device. This was nice because you could select whatever permutation of the options was best fit and even had some level of scrubbing/masking of speaker playback that might come through on the input mic. I would sometimes use the built-in mic just because I thought I sounded more clear from a distance than 2 inches from my mouth, but when the fans where going at full-steam I would switch to the headphone based mic and had no issue whatsoever selecting it and using it as the input device.


    1 - I had the earbuds plugged into the audio-out/headphone symbol jack

    2 - I have now attempted to plug in via every method I was able.

              a) have tried having 1 set up earbuds in 1 jack for volume (audio out works for that at least ) and a second pair in the audio in/optical digital audio in port - Resulted in good audio out but no recognized audio input via jack.

              b) Bose provided a airline headphone adapter that plugged into both inputs perfectly and attempted using single earbud via adapter just for the heck of it and only audio out was recognized

              c) Restarting with input devices plugged... (we can go on and on here) but needless to say I was ultimately unsuccessful.


    I'm not the most hardware integration/software compatibility savvy person on these threads, but I can personally attest to the fact that using the identical setup in a game, the audio in from the combo earbud plugged into the AUDIO OUT jack worked. Just for the doubters out there, I'm inserting a screenshot of audio in/out options and successful testing (whispered under the desk into the mic and got recorded feedback verification of working input).



    Maybe based on this we can figure out if there is a 3rd party driver we can install that will bypass the Cirrus-latest driver failure at the OS level and not just ingame.


    In-Game Input-Output Options.jpg

  • SvenSwag Level 1 Level 1 (0 points)

    You should be lucky that you have the 2 ports for the mic and the speakers... I have the retina model and there is only one port for both. I think the problem is that windows wants to extra jacks with the 2 rings on it. My single jack headset has 3 rings, like the ones for smartphones. I think windows needs just a driver to recognize this single jack micro.. but does such a driver exist?

Previous 1 2 Next