Previous 1 2 Next 20 Replies Latest reply: Jul 22, 2013 4:10 PM by Mr. EMan
nancystr Level 1 (0 points)

Safari 4 was set to ask before closing multiple tabs, but when I upgraded to 5 this was no longer an option. I've looked in Preferences with no luck and the Help menu has no information. Now I lose websites when the window is inadvertently closed.


iMac, Mac OS X (10.7.2), Safari 5
  • Carolyn Samit Level 10 (103,360 points)

    Now I lose websites when the window is inadvertently closed.

     

    Several alternatives...

     

    If you close a window or quit Safari, when you relaunch Safari go to the menu bar click History > Reopen All Windows From Last Session.

     

    And since you are running Lion you can enable the Lion "resume" feature.

     

    Open System Preferences > General

     

    Select:  Restore windows when quitting and re-opening apps

  • Mac OS XP Level 1 (75 points)

    Not sure, I don't see the option either. It may be because now in Lion, if you quit an app, it will "resume" when you open it again.

     

    Regardless, I myself have moved on to Chrome. That browser does give the option to warn before quitting at least. Chrome is basically Safari except it's even leener and more forward-looking.

     

    You may also want to look in to Firefox. I prefer it to Safari too, and that for sure has an option to warn before closing multiple tabs.

  • nancystr Level 1 (0 points)

    Thanks for the Chrome tip. I gave up on Firefox because multiple didn't show up on the top bar - I had to use the pull-down menu to move between tabs. Do you know how to change that?

  • Mac OS XP Level 1 (75 points)

    I'm not sure what you mean about Firefox's tabs not showing up, unless you mean that you had like 30 open tabs, in which case it may not handle it as well as some other browsers. But on that note, another cool feature that is unique to Firefox is that there is a button you can push which shows all the thumbnails of all the open tabs, and you can organize these too.

  • nancystr Level 1 (0 points)

    My open tabs were only showing up in the thumbnail, not across the top - even when I had only 3 or 4.

  • Mac OS XP Level 1 (75 points)

    That shouldn't be happening...Try to go to ~Library/Application Support/Firefox and delete that folder. Then open Firefox and everything should be fresh. Then download Firefox 9 from http://www.mozilla.org/en-US/firefox/new/ and install it. Then open Firefox, and everything should be fresh, including a functioning tab bar.

  • William Donelson Level 4 (2,495 points)


    If you close a window or quit Safari, when you relaunch Safari go to the menu bar click History > Reopen All Windows From Last Session.

     

    And since you are running Lion you can enable the Lion "resume" feature.

     

    Open System Preferences > General

     

    Select:  Restore windows when quitting and re-opening apps

    This does not restore the page scroll position, the playback times of videos, etc

  • hmab Level 1 (0 points)

    Just installed new updates for Safari 5.1.5 and still Safari doesn't  ask before closing multiple tabs, what gives, is  anyone at Apple listening

  • nancystr Level 1 (0 points)

    In case of accidental closure I've started adding tabs to the "read" column, and then deleting them later. Or sometimes I just use Firefox, since it does ask before closing multiple tabs.

  • William Donelson Level 4 (2,495 points)

    I suspect this is the iPhone crew forcing my desktop computer to look like a phone.

     

    News Flash: My desktop Mac is NOT A PHONE. STOP RUINING IT.

  • William Donelson Level 4 (2,495 points)

    Anyone have any solution?

  • pictorialism Level 1 (0 points)

    Is Apple listening?  Resuming is not at all the same as avoiding an accidental quit!!!

     

    Command+w (close tab command) is right next to command+q (quit safari); for some of us, that warning before quitting is crucial for avoiding accidents!

     

    Apple, please think of all the things that can't be resumed: email login, anything requiring login, text entry, audio playback, video playback.  Now recognize that resume isn't sufficient for a great many uses. It's ridiculous.  Also, please recognize that when we DO mean to quit safari, we don't want to sit there while Safari tries to load all of the windows I had open the last time.  It's backwards!! 

     

    AT LEAST GIVE US THE OPTION!!!

     

    Please.

     

    Thanks.

  • evenhuis Level 1 (0 points)

    Not exactly what is wanted, but it is possible to disable Q in Safari.  I rarely quit Safari so losing this feature is a minor inconvenience compared to the occasional rage-inducing accidental quit.

     

    1. Go to System Preference > Keyboard. 
    2. Choose Keyboard Shortcuts
    3. Click Application Shortcuts
    4. Press the + button
    5. Under Application choose Safari
    6. For Menu Title input "Bring All to Front".  (You could use some other innocuous menu option here)
    7. For Short Cut use Q

     

    This remaps the Q, thereby avoiding quitting if your fingers miss W.

     


  • nimmo Level 1 (0 points)

    Thank you evenhuis!  This is a hack work-around, but totally serves the purpose!  For the past few months, I've been accidentally command+Q closing Safari every couple of days when meaning to hit command+W, but no longer.

Previous 1 2 Next