2 Replies Latest reply: Jan 26, 2012 8:32 PM by Don Hutchinson1
Don Hutchinson1 Level 1 Level 1 (5 points)

With a loose key pm ,y Mac Book Pro, I started (successfully) to use an older separate keyboard

Worked fine

But now it has stopped working. The mouse does not light up wem plugged in to the keyboard - but does work

when plugged in to USB socketon the MacBook.   No power getting through to key board?

 

The keyboard on the MacBook continues to workl as does its trackpad.

The USB mouse works when plied directly ony yjr MacBook

 

When I go to Sytsem Preferences and then help,  Help tells me to go to Change Keyboard Type

But theris no such button

 

Puzzled

 

Running with Snow Leopard.


MacBook Pro, Mac OS X (10.6.4)
  • eww Level 9 Level 9 (52,975 points)

    Your message would be easier to decode if you had proofread it before posting.

     

    Does your keyboard work when the mouse is plugged directly into the computer instead of into the keyboard, or does the keyboard not work at all? If not at all, then it sounds as though you're right in guessing that the keyboard isn't getting power for some reason (bad cable? bad connection inside the KB? USB port on computer shut down?) If the KB works when the mouse isn't plugged into it, then the mouse and KB together are demanding more power than the computer's USB port can supply, and neither is getting what it needs when the mouse is connected to the KB. In that case, plug the mouse directly into the computer to use it.

     

    The USB port in your keyboard probably doesn't put out enough power for the mouse you are using. This is typical of older keyboards, which were designed to power old-style electromechanical mice rather than the laser mice that are commonplace today.

  • Don Hutchinson1 Level 1 Level 1 (5 points)

    Sorry anout the typing.

    I tried all the things you suggested. Direct connections to the keyboard and mouse, and also through a USB powered hub.

    The puzzle is that it was working  hqppily a  few days ago

    I did notice grom the system Preferences, Keyboard, Help that cited a Keyboard style button as something  to click. That button was not visible in my window.

     

    Throughout this episwode the keyboard and track pad o the power book continued to function

     

    I plan to spend some time cleaning up with Tech Tool Pro and Disk Utility.

    There may be some underlying problems there