7 Replies Latest reply: Jan 29, 2012 2:46 PM by Mike Boreham
tusharar Level 1 Level 1 (0 points)

i did not delete my iPhoto. but it somehow got 'inactivated' while exporting a photo. So I went to time machine and tried to restore the iPhoto from the day before. But then I got a message that it could not be done..due to some files being 'locked'..whatever that means....and now on opening iPhoto, i m asked to reinstall it!! So,

1) how do i reinstall it?

2) will i have to pay for it , as my laptop is still quite new and the application came along with it. There was no installation cd along with the laptop.

rgds.


MacBook Pro, Mac OS X (10.7.2), iphoto trouble…
  • 1. Re: how do i recover my photos?
    Mike Boreham Level 4 Level 4 (2,095 points)

    Your photos are in your iPhoto Library, not the iPhoto application. Try restoring your library then launching iPhoto.

  • 2. Re: how do i recover my photos?
    tusharar Level 1 Level 1 (0 points)

    Thanks Mike..but when i try to restore the iphoto library, it asks me to choose a floder from the applications...and iphoto cannot be selected. I have another Hp photo application...should i choose that folder?...I apologise for being such a dumbo with mac!

    Tushar

  • 3. Re: how do i recover my photos?
    Mike Boreham Level 4 Level 4 (2,095 points)

    I am afraid I am finding it difficult to understand what is happening.

     

    Is your iPhoto library present? If so maybe you don't need to restore it from Time Machine at all ( but restoring it from TM shouldn't ask you what application to use)

     

    http://support.apple.com/kb/HT2604 tells you how to re install iPhoto.

     

    The HP photo app won't be able to see any photos in your iPhoto library.

  • 4. Re: how do i recover my photos?
    tusharar Level 1 Level 1 (0 points)

    mike...thanks again... i went to the link....but i  did not get any installation cd with my mac. guess i need to take it to a repair shop !!  but thanks so much for taking the trouble..and giving your time. And I would really appreciate it if you let me know any other way, if its not too much trouble..

    thanks a lot, once again.

    tushar

  • 5. Re: how do i recover my photos?
    Mike Boreham Level 4 Level 4 (2,095 points)

    I guess that link was written before Lion and the App Store came into being.

    Try googling "reinstall iphoto lion". you will get a lot of hits and can read up and choose the one that applies to your situation.

    I assume you have tried just rebooting. I have never had an app become "inactivated" on a mac. You may not need to reinstall the app.

  • 6. Re: how do i recover my photos?
    tusharar Level 1 Level 1 (0 points)

    this is what i get when i try to open iphoto:

     

     

     

    Process:         iPhoto [392]

    Path:            /Applications/iPhoto.app/Contents/MacOS/iPhoto

    Identifier:      iPhoto

    Version:         ??? (???)

    Build Info:      iPhotoProject-628000000000000~3

    Code Type:       X86 (Native)

    Parent Process:  launchd [140]

     

     

    Date/Time:       2012-01-30 00:38:07.875 +0400

    OS Version:      Mac OS X 10.7.2 (11C74)

    Report Version:  9

     

     

    Interval Since Last Report:          78109 sec

    Crashes Since Last Report:           15

    Per-App Crashes Since Last Report:   14

    Anonymous UUID:                      5390C335-FDA3-44B5-8107-0490731B64C2

     

     

    Crashed Thread:  0

     

     

    Exception Type:  EXC_BREAKPOINT (SIGTRAP)

    Exception Codes: 0x0000000000000002, 0x0000000000000000

     

     

    Application Specific Information:

    dyld: launch, loading dependent libraries

     

     

    Dyld Error Message:

      Library not loaded: @executable_path/../Frameworks/Geode.framework/Versions/A/Geode

      Referenced from: /Applications/iPhoto.app/Contents/MacOS/iPhoto

      Reason: image not found

     

     

    Binary Images:

        0x1000 -   0xd1afeb +iPhoto (??? - ???) <68601E93-E4CF-3B4C-AFFD-4781A92DD58B> /Applications/iPhoto.app/Contents/MacOS/iPhoto

      0xe83000 -   0xf63fe7  org.python.python (2.6.7 - 2.6.7) <61DBA92A-C39A-3A52-86F2-59CF9D310CB4> /System/Library/Frameworks/Python.framework/Versions/2.6/Python

    0x8fe23000 - 0x8fe559c7  dyld (195.5 - ???) <134323A7-49DC-3A9D-ACFD-32FAD0FD6BA2> /usr/lib/dyld

     

     

    Model: MacBookPro8,1, BootROM MBP81.0047.B24, 2 processors, Intel Core i5, 2.3 GHz, 4 GB, SMC 1.68f98

    Graphics: Intel HD Graphics 3000, Intel HD Graphics 3000, Built-In, 384 MB

    Memory Module: BANK 0/DIMM0, 2 GB, DDR3, 1333 MHz, 0x80CE, 0x4D34373142353737334448302D4348392020

    Memory Module: BANK 1/DIMM0, 2 GB, DDR3, 1333 MHz, 0x80CE, 0x4D34373142353737334448302D4348392020

    AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0xD6), Broadcom BCM43xx 1.0 (5.100.98.75.18)

    Bluetooth: Version 4.0.1f4, 2 service, 18 devices, 1 incoming serial ports

    Network Service: Wi-Fi, AirPort, en1

    Serial ATA Device: Hitachi HTS545032B9A302, 320.07 GB

    Serial ATA Device: OPTIARC DVD RW AD-5970H, 1.27 GB

    USB Device: hub_device, 0x0424  (SMSC), 0x2513, 0xfa100000 / 3

    USB Device: Apple Internal Keyboard / Trackpad, apple_vendor_id, 0x0246, 0xfa120000 / 5

    USB Device: BRCM2070 Hub, 0x0a5c  (Broadcom Corp.), 0x4500, 0xfa110000 / 4

    USB Device: Bluetooth USB Host Controller, apple_vendor_id, 0x821a, 0xfa113000 / 6

    USB Device: FaceTime HD Camera (Built-in), apple_vendor_id, 0x8509, 0xfa200000 / 2

    USB Device: hub_device, 0x0424  (SMSC), 0x2513, 0xfd100000 / 2

    USB Device: IR Receiver, apple_vendor_id, 0x8242, 0xfd110000 / 3

  • 7. Re: how do i recover my photos?
    Mike Boreham Level 4 Level 4 (2,095 points)

    I think you need to take it in. Too difficult to understand and resolve like this.

     

    As I said before your photos live in the iPhoto library, so provided that is still on your machine in your user/Pictures folder, you should be able to get to them again when you have sorted out iPhoto.

     

    Have you tried double clicking on the iPhoto Library? Does iPhoto just crash as above?