Previous 1 2 3 Next 38 Replies Latest reply: Dec 27, 2013 9:04 AM by lhuima Go to original post
  • MessagingTech Level 1 Level 1 (40 points)

    I'm an Exchange Admin and we noticed this also disappeared when setting up one of our users.  We noticed immediately after setting up the account you can go back into the mail settings and No Limit will be there.  However, once the option for "Mail Folders to Push" appeared, it lost the option for "No Limit' but still functioned the same.  We've tried this on iOS 5, 5.0.1 and 5.1.1 and had the same issue.  We did not change anything on our Exchange Servers and did work fine before.  Maybe something Apple changed in iOS 5 for Exchange accounts?

  • tomtully Level 1 Level 1 (0 points)

    Fabulous AtomicVariable...this worked great. Except, I had to delete my exchange account and then reinstall to get this result. BTW, I am also with Godaddy!

  • AtomicVariable Level 1 Level 1 (0 points)

    Happy to continue to hear that this solution helps!

     

    @MessagingTech - others have reported no issues or changes post iOS 5, so I canot think this is an iOS quirk.

     

    Oddly, you are the first and only NON Go Daddy Exchange user of the bunch... Glad you got it sorted for your users.

  • MessagingTech Level 1 Level 1 (40 points)

    It was in fact a policy issue on our end.  Apparently there were multiple policies being applied to different users besides our "default one" which was caused the issue.  It was interesting to see that even though the policy said to limit to 30 days, if you set it up prior to the policy taking effect, the no limit option stays in place. 

  • AtomicVariable Level 1 Level 1 (0 points)

    Thank you for the update MessagingTech.

     

    I wish Go Daddy would investigate their own server policies and make the fix so that users do not end up limited to 30 day sync. Heck I regularly reference year old message. If you have the available server space, there should never be a limit unless the user chooses that limit themselves.

     

    That would be my admin policy. I have a 4GB mailbox and use only like 500MB of it. There should be no reason to limit my Exchange syncing on my smartphone by age of message.

  • MessagingTech Level 1 Level 1 (40 points)

    I'm curious to see if someone can bypass this "Go Daddy" policy by setting the "no limit" option before their policies take effect?  What I encountered was if immediately after adding the account I went back into the sync options and "No Limit" was there.  As soon as the Exchange policies hit, I lost the option but "No Limit" is still in effect. 

     

    We decided to keep it at 30 days because are users can have very large mailboxes (going back several years) so our admin did not want someone downloading gigabytes of email over their 3G or 4G connection or filling their phone storage with their mail and complaining that they were out of room for music or apps. 

  • AtomicVariable Level 1 Level 1 (0 points)

    This essentially does seem to work. As long as you set it immediately to no limit it will remain in effect after the option disappears. Problems only seem to arise if you go back and select a limiting option.

     

    The only way to then change it back is the previously mentioned suggestions... Up to and including deleting and re-adding the exchange account.

  • ChazMiller Level 1 Level 1 (0 points)

    This is actually not a problem with the iOS, we have recently learned with our internal exchange server that the e-mail sync setting is an policy issue on the exchange side, once we upped it to one month then checked the iphone and the one month option appeared. So again check your exchange policies, this is NOT an iOS problem, and the reason they did remove it in iOS 5+ was because this was causing crashes on exchange servers.

  • Zhakathoom Level 1 Level 1 (0 points)

    Thanks a bunch AtomicVariable! Really saved my day there. Finally got the damned thing to sync the friggin' subfolders. All 140+ of them...

     

    - Z

  • AtomicVariable Level 1 Level 1 (0 points)

    @Zhakathoom, I am glad you were able to finally get where you wanted to go with your sync.

     

    Do you use Go Daddy for Exchange Hosting by chance?

     

    I am beginning to think Go Daddy has other issues in addition to this - at least with my iOS devices and syncing always hanging up downloading messages from the server.

  • AtomicVariable Level 1 Level 1 (0 points)

    Just an update to all following the thread.

     

    Go Daddy has finally acknowledged this is an issue derived on their end. It is exclusive to their users on Exchange 2007.

     

    It was a major pain to force migration over to a 2010 server. They are slowly migrating all users over but can force an individual users migration.

     

    I had to export my exchange account into a pst file for backup and cancel my exchange account. This gave a prorated credit for unused time. Then immediately repurchased one year of exchange hosting and it forces the setup of your new account to e on a 2010 server.

     

    Mail days to sync problem gone and no more workaround needed. Other issues I was haing with syncing on my iOS devices has seemed to improve or go away as well.

     

    Big pain in the arse and resulted in downtime for my email which is always dangerous for my business. I did it late at night to minimize this. Then you just Moore your pst file and you are back up and running better than before.

     

    I just wanted to confirm tis update to all following these past months that Go Daddy has recognized finally this is an issue with their 2007 server. They did not know why the policy was changed. I had to really push into deep support levels to find anyone who was able to be truly helpful.

     

    Good luck to all.

  • sierran Level 1 Level 1 (0 points)

    I had the same issue with No Limit disappearing... but I don't have Go Daddy.  It's my wife's work email server, she's a teacher.  But these steps helped me fix the problem - thanks so much!   I do want to point out that after disabling SSL, you must actually try to open the inbox and wait for the connection to error before turning SSL back on.  A quick toggle off/on without opening the inbox does nothing.

  • MenesesInc Level 1 Level 1 (0 points)

    Connecting via corporate exchange not GoDaddy.

     

    Tried the steps for the iPhone and that worked nicely but did nothing for the iPad.  So I deleted the account and added it back with MAIL set to OFF, Calendar and Contacts set to ON.  After I did this, I was able to see the No Limit and click it.  Then went right back and switched MAIL from OFF to ON.  Now, I getting mail from last year... 

     

    Thanks to all for providing directions...

  • rafayel17 Level 1 Level 1 (0 points)

    AtomicVariable is a genius!!! The steps on page 1 worked perfectly.

  • AtomicVariable Level 1 Level 1 (0 points)

    So happy to have helped rafayel.

     

    Force migrating my account over to their 2010 server has helped in many other ways too.

     

    My ultimate suggestion to all Go Daddy Exchange users experiencing this issue is to bite the bullet at the cost of your own time and frustration to do what it takes to get your account hosted on the 2010 server.

     

    In the meantime, I am so happy the workaround still is helping!