4 Replies Latest reply: Apr 10, 2012 7:38 AM by Seth Neal
humphrey_g Level 1 Level 1 (0 points)

My internal hard drive failed on my iMac 24. Apple replaced it and re-installed Lion. Once I got it home I selected 'restore from a Time Machine back up' from the Wizard options. The new HD now has 152 GBs of data which I assume is my state before the failure - so Time Machine did its job. The login screen looks normal, but none of my passwords are being accepted.  The correct 'hint' appears. But I can't log in under my (Admin) account, nor my Superuser Account, nor does the Master Password work. Before I upgraded to Lion I created a bootable Disk running 10.6. I can start up under that and my password works fine. I also have a Mac OS X Install ESD on a memory stick which I made from my Lion download.  I can start up under that and get into Disk Utility which I thought I could use to reset my password.  However, when I select the HD, the option to reset password is greyed out.  I would be MOST grateful for any suggestions as to how to get back into my machine without losing my Time Machine back up.


iMac 24, MacBook 13, Mac OS X (10.5.6)
  • Peggy Lynn Level 4 Level 4 (2,470 points)

    Boot from your USB InstallESD stick. Choose Terminal in the Utilities menu at the top of the screen. Type in resetpassword. That will bring up a GUI interface where you should be able reset your password on your new drive.

     

    I had something similar happen when I swapped locations of two Macs with identical hardware and tried to boot from external clones. I had to also reset all the home folder permissions/ACLs as well as resetting the password before any of my clones would accept the correct password. That option is in the same GUI interface as resetting password.

  • humphrey_g Level 1 Level 1 (0 points)

    Hooray!  That worked a treat!  Thank you so much for your speedy answer.  I have no idea why this happened in the first place, but if it is a 'peculiarity' (bug?) between Lion and Time Machine, maybe the good folks at Apple might like to issue a technical note on how to reset the password using the USB Install ESD stick (or whatever they call a 'heads up' until they fix the problem.) 

     

    You have saved me hours of reformating and re-restoring which would no doubt have gotten me no closer to the solution.  Wishing you a great 2012!

  • Peggy Lynn Level 4 Level 4 (2,470 points)

    I'm so happy to hear you are now up and running. Thank you for the feedback.

     

    In my case it wasn't a Lion thing. I had two external Snow Leopard clones and one Lion clone. None would accept my password. My other Mini with identical hardware happily booted the other swapped external Lion and Snow Leopard clones.

     

    To add to the mystery the Mini that threw the password hissy fit booted with no complaining from two external Snow Leopard clones a few months earlier when a dead internal hard drive was replaced.

     

    I don't think the issue is common or we would see many more posts from people having correct passwords rejected when restoring from their Time Machine backups or booting from clones. I reported the password issue I had to AppleCare but I couldn't offer any insight as to what triggered the problem.

  • Seth Neal Level 1 Level 1 (50 points)

    I used the Snow Lepord install DVD and the Utility "Reset Passwords". Just an FYI for anyone else that has this issue.