Previous 1 2 Next 23 Replies Latest reply: Mar 23, 2016 2:08 PM by cotton770
margaritachick Level 1 Level 1

Can anyone tell me how to turn off the notifications when I am on a call. VERY ANNOYING to hear the alerts when I am trying to talk to someone. I can't seem to find the answer ANYWHERE!!!

iPhone 4S
  • Templeton Peck Level 9 Level 9

    You can't turn them off while on a call.

  • Meg St._Clair Level 9 Level 9

    Engage the mute switch while you are on the call. It's the little slider above the volume buttons.

  • Tunzjnky Level 1 Level 1

    Turn notifications off for Phone....  It worked for me! 

  • Tunzjnky Level 1 Level 1

    as in go to settings, notifications, click on the phone icon. switch notifications off. Problem solved! I still get text sounds, I still hear phone ringing when someone calls. but if I get a text during a call..... silence!

  • JH12 Level 1 Level 1

    That seems to be a work around rather than a solution.

  • Meg St._Clair Level 9 Level 9

    JH12 wrote:


    That seems to be a work around rather than a solution.

    The OP asked how to turn off notifications while on a call. Engaging the mute switch does that. How is that not a solution?

  • pointm Level 1 Level 1

    A little late but Meg, it is a workaround not a SOLUTION. Then you have to flip back the mute switch when you end the call, WOW! what a solution. A setting to mute all notifications while on a call is indeed needed, just like any other smart phone for the last few years. Wonder how long would Apple take to implement this feature.

  • Rockstarcf Level 1 Level 1

    That, does not work at all.  At least for iOS 5.1.1.  Went to Settings / Notifications & removed the phone from the Notification Center.  Still receive annoying email notification while in a call.  Mail was not in the Notification Center either.  In fact, the only apps in the Notification Center are the Calendar and Reminders.


    Like countless others (probably), I've placed feedback with Apple.  Oddly enough, I see that this ability / feature / enhancement (whatever you would like to tag it) is also not available.


    Personally, the truly annoying part of this for myself is that the same volume levels used to control the receiver during a phone conversation is the same level of volume used to set for the notifications.  Ergo, if you have someone that's got a weaker voice and you have to crank to the volume to hear them, you'll **** near go deaf when an alert comes in during the conversation you're having.

  • moetower Level 1 Level 1

    I agree!  The notifications during a call are extremely frustrating.  Yes a person can flip the mute button during a call, but for me I prefer to have my phone go to vibrate when it is flipped to mute so I can at least be buzzed when I get a notification.  To have the phone buzz while on a call (which rattles your skull) is very unnecessary!!  I have had many phones in my lifetime that had a simple option under the settings to disable all notifications ONLY DURING A CALL!  You would think that with the all mighty Iphone that this would be one of the simpler issues for them to fix! PLEASE APPLE TAKE THE TIME TO FIX THIS IN YOUR NEXT UPDATE!!!

  • Meg St._Clair Level 9 Level 9

    moetower wrote:



    You're not addressing Apple here. Submit your feedback requesting this feature directly to Apple using the appropriate link on the Feedback page:


  • jeff1sue1 Level 1 Level 1

    TUNZJNKY's response worked for me too.  Only rather than just turning off the Phone notifications, I also had to turn off the Messages notifications by going to Settings, Notifications, Messages and selcting the option for Off for that too.  Now when I get a call or a text message, my phone still makes the normal sound or ringtone when I'm not on the phone, but when I'm in the middle of a call, it doesn't make any sound at all.  Looks to me like this is the solution to the problem.  Thanks!

  • Abeah Level 1 Level 1

    I am having the same problem.  I have the latest o/s 6.1 and this is still an issue apple has not address.  All other cell phones has a solution for this ie Andriods and Blackberry.  This is extremely frustrating!

  • Shakirali Level 1 Level 1

    Hi Meg,


    I know i am not posting the question at right place but i need help from someone experienced.


    Actually, already using iPhone, recently switched from PC to iMac and have a small issue with Mail that whenever I open any emails on my iPhone it marks the same email on iMac as "Read" and vice versa.


    I need to keep emails on both devices as "UNREAD" until I open the email on that particular device. I do not want to automatically mark (sync) the email on iMac which I open on iPhone and vice versa.


    Any help appreciated!



  • Meg St._Clair Level 9 Level 9

    That is a function of your email service provider. If your provider is using IMAP, then what you're seeing is what's supposed to be happening: everything is being kept in sync across all devices.


    If you need more assistance with your email, start a new thread with a descriptive subject line. There are lots and lots of really experienced people here and more of them will see your question that way.


    Best of luck!

Previous 1 2 Next