11 Replies Latest reply: Jan 29, 2012 11:31 AM by CynthiaW
CynthiaW Level 1 Level 1 (0 points)

The software updater on my Macbook Pro refuses to allow me to turn it off and make updates manually. Also, it is trying to reinstall iLife update 10.4.? several times/day. How can I stop it? There appear to be multiple copies of the iLife update downloaded but I do not find them when I search. What is going on?

Thank you.

 

Cynthia


MacBook Pro, Mac OS X (10.6.8)
  • kurt188 Level 4 Level 4 (1,335 points)

    The software updater on my Macbook Pro refuses to allow me to turn it off and make updates manually.

    Are you saying that unchecking the box labeled "Check for updates:" does nothing, or that the preference doesn't stick?

    There appear to be multiple copies of the iLife update downloaded but I do not find them when I search.

    The only way it would appear they are downloaded is if you can find them, but you said you can't. If any are downloaded, they would be in your Downloads folder.. Did you try looking there? If you don't see it there, then it's not downloaded, since that's an option you must manually select for any updates; it's not automatic.

  • CynthiaW Level 1 Level 1 (0 points)

    Thank you.  I have looked in the download folder and found multiple copies of the latest update of iLife. I have also tried to uncheck the automatic software updater and change it to manual update or to change it to weekly, but it does not accept the change.

     

    any other suggestions? Maybe I need to reinstall it?  Will osx lion take care of this problem?

  • kurt188 Level 4 Level 4 (1,335 points)

    I have looked in the download folder and found multiple copies of the latest update of iLife.

    Then you need to delete all but one of them and install it.

    I have also tried to uncheck the automatic software updater and change it to manual update or to change it to weekly, but it does not accept the change. Maybe I need to reinstall it?  Will osx lion take care of this problem?

    So it appears your preferences are corrupt for Software Update. You can delete them and then set it up again:

     

    1. Quit Software Update if it's running.

    2. Go to Home/Library/Preferences and delte the com.apple softwareupdate.plist file.

    3. Restart Software Update and set it's preferences the way you want, then quit.

    4. Restart Software Updatte and check to be sure your preferences stayed the same.

     

    As for reinstalling, that would not solve the problem. Likewise, installing Lion wouldn't do it either, and there's no compelling reason to install Lion, unless and until you're familiar with how it will change existing applications and your overall user experience. Spend some extended quality time at the Apple Store exploring that before you even think of installing Lion.

  • WZZZ Level 6 Level 6 (12,660 points)

    Cynthia, you may find a few update packages in /Library/updates (and I think this was removed with the 10.6.1 update), but I can't explain what's in your downloads folder. I have my doubts they would be installable update packages provided by Software Update. Software Update in Snow Leopard, whether run automatically or manually, does not make any downloads available separately. This option used to exist in Tiger and Leopard, but it was removed in Snow. All you can do now is choose to install or not.

     

    I would be interested to learn what happens if you try opening any of those and installing.

  • CynthiaW Level 1 Level 1 (0 points)

    ok, I deleted the 4kb softareupdate.plist file, which was dated 4 May 2010 and am running software updater, but it appears to be stuck at the beginning. It has been running 3 min. and the bar is not progressing. I unchecked update weekly and clicked "update now" and got the message "unable to connect with the internet".   Thank you very much for the advice about Lion.  A friend of mine lost all his data when he tried to install it.  I use MobileMe, so I am not sure that I have any choise.

  • kurt188 Level 4 Level 4 (1,335 points)

    I unchecked update weekly and clicked "update now" and got the message "unable to connect with the internet".

    That just means that for some reason, your Mac (or Software Update) can't connect to the Internet right now. It may pass, or it may persist, which would be a different problem to solve.

    I use MobileMe, so I am not sure that I have any choise.

    You always have a choice. Just because you're a MobileMe user doesn't mean you have to upgrade to Lion to use it (or iCloud, as it's going to become). It's only if you want to be able to store things "in the cloud" that you have to upgrade to Lion. Your email should continue to work just fine.

  • WZZZ Level 6 Level 6 (12,660 points)

    Besides the file you trashed, see if you have any of these, "By Host," in your home folder library and try trashing them as well. (Don't empty the Trash yet.)

     

    /Users/yourusername/Library/Preferences/ByHost/com.apple.SoftwareUpdate.******** *******.plist

     

    Asterisks are a long string of numbers and characters.

     

    And, then, in the next level HD Library, this one  (This is not in the /System/Library)

     

    /Library/Preferences/com.apple.SoftwareUpdate.plist

     

    You will need to give your admin pword to move this one out.

     

     

    After doing this, try logging out and back in, then restore your SU Settings.

  • CynthiaW Level 1 Level 1 (0 points)

    thank you so much for the advice. I received a message from apple saying that mobileme would cease to function in March.

  • kurt188 Level 4 Level 4 (1,335 points)

    I've seen that notice, and as I recall, it only said the storage functions of the service would cease; the email service (whatever they might rename it to) should still work. After all, they have millions of users, many of whom can't run Lion even if they wanted to do so, as well as those who just signed up for MobileMe last year when Snow Leopard systems were still shipping.

  • CynthiaW Level 1 Level 1 (0 points)

    so happy you have cleared this up! thank you!!!