Previous 1 2 3 Next 33 Replies Latest reply: Oct 29, 2012 3:40 PM by joeblotnick
EdinNorway Level 1 (5 points)

Thanks for reading this post.  I've seen so many solutions that involve something like:


"hdiutil attach -readwrite -nomount -noverify -noautofsck /Volumes/Data/mbp.sparsebundle"


but I always get "hdiutil: attach failed - not recognized"


The 1.72 TB file resides on a 2nd generation Time Capsule.  My laptop disk died and I believe the errors in the disk must have continued to the Time Machine backup.  I have read so many posts across the web which all involve some form of the terminal command line above.


I can't mount the image. I can't open it in disk utilities but I can open the contents of the file and see the "bands".  I don't wish to restore, only recover certain files.


Is there something I'm missing?




MacBook Pro, Mac OS X (10.7.2)
  • Pondini Level 8 (38,740 points)

    The sparsebundle is corrupted.    


    You can't deal with the bands -- that's like looking directly at a HD's sectors -- just raw data you can't identify.


    You have a few options, none very attractive or cheap:

    • Find a service that can recover data from a Time Capsule.  That will be quite expensive, and they may remove the internal HD for access, which will void the warranty.


    • You could remove the HD yourself, then try to fix/recover the data with a heavy-duty utility. 


    • You might be able to "archive" the TC's internal HD to a USB drive connected to it.  You will need a working Mac to initiate the process.  See the green box in #Q6 of Using Time Machine with a Time Capsule.  That won't fix anything, but should get a copy onto an external disk, where you can try to fix/recover the data with a heavy-duty utility. 

    See Data Recovery for details. 

  • EdinNorway Level 1 (5 points)

    Thanks Pondini.  There is nothing wrong with the drive that the sparsebundle is resident on.  In fact, there is another sparsebundle alongs side it (see graphic) which mounts fine.  As you say, the sparsebundle is corrupted, but with such a large file I'm hoping there is a way to recover at least some of the files.


    Thanks for trying to help.


    edgrab sparsebundle screen shot.jpg

  • Pondini Level 8 (38,740 points)

    EdinNorway wrote:


    Thanks Pondini.  There is nothing wrong with the drive that the sparsebundle is resident on. 

    I didn't say there was (although it is a possiblity -- if there's a problem on the surface of the disk in an area used only by the one sparse bundle).


    As you say, the sparsebundle is corrupted, but with such a large file I'm hoping there is a way to recover at least some of the files.

    Yes, there may be.  Any of the three options posted.   I understand they're not attractive, but if Disk Utility can't mount or repair the sparse bundle, those are the only options.


    A sparse bundle is a type of disk image -- it has it's own partition map, format, directories, etc., just like a physical disk. It's full of files and folders, just like a physical disk.  But if you can't mount and open the disk image, you can't see them, much less copy or restore them.

  • grantdoug Level 1 (0 points)

    The Time Capsule hardware is a ludicrous travesty of a backup system. I hate this! I have a 1TB machine that has had SO MANY FAILURES AND ISSUES.


    It is absolutely wrong and stupid for Apple to provide a backup solution that is UNSTABLE and is highly susceptible to FATAL ERRORS.


    My Time Capsule yesterday, with ZERO changes in the environment, no system changes, nothing, backups stop working & when the backup sparsebundle for one of the 2 Macs go bad. BOOM I lost 6 months of backups.


    It cannot be opened with DISKUTIL or any other method, it is hosed!


    There is NOTHING wrong with the bloody Time Capsule drive, which has another Sparsebundle for Mac #2 that works perfectly.


    And, this insanity has hit me before... LOST DATA, plus hours of doing bloody terminal commands rebulding the Time Capsule.


    I hate this product.


    I'm on Lion 10.7.3 and everything is patched up. Nothing works to fix this. I've already spent 7 hours messing about trying to fix this bloody drive today

  • Pondini Level 8 (38,740 points)

    Are you connected via Ethernet cable or WIFI?

  • grantdoug Level 1 (0 points)

    I have tried both wireless or non-wireless- the backup was destroyed / corrupted by something OS X was updating into the backup and which failed. they hardware is OK.

  • Pondini Level 8 (38,740 points)

    grantdoug wrote:


    I have tried both wireless or non-wireless- the backup was destroyed / corrupted by something OS X was updating into the backup and which failed. they hardware is OK.

    You don't really know what's causing it, or whether the hardware is ok.  What do you mean by "something OS X was updating into the backup"?


    By the way, Time Machine backups to Time Capsules work just fine for many, many folks.


    It's possible the damage was done while on WIFI (possibly due to severe interference), but not detected until later, as TM only runs the lengthy, extensive check every few weeks.


    It's possible the damage was done when there was a power problem.


    It's possible the HD in the TC is failing.  (Sometimes they'll work fine most of the time, but have intermittent problems for quite a while, then fail entirely.  There may be a problem on the part of the disk where that Mac's backups are, so the other ones are fine.)


    It's possible other components in the TC are failing


    It's possible the installation of OSX on that Mac is damaged. 


    If you want help fixing it, we'll be glad to try to help.


    If you've given up, or just want to complain, then by all means back up some other way.

  • grantdoug Level 1 (0 points)

    THE BOTTOM LINE: It seems to me that Apple's Time Capsule is a good tool for restoring working files from time to time, and emergency system restores, but it should absolutely NOT be trusted as the only system archive, let's say for precious family photographs, documents, and videos!


    I just experienced unexplained destruction of my Airport Extreme Time Capsule backup for my MacBook Pro.

    There is nothing wrong with my TimeCapsule hardware, which has continued to work perfectly for my iMac, and has worked faultlessly for two weeks since I deleted the corrupted MacBook Pro backup and created a new one.  Something happened to corrupt the MacBook backup while it was processing. As Pondini suggests, it may be an interruption in the wireless connection. Who knows? All I can tell you is that it processed correctly @ 6am, but by 8am the backup was irreversibly corrupted. I was online the entire time, checking email, using Safari, never lost the connection.


    After a finally giving up on restoring the corrupted sparsebundle (and I tried many different methods in terminal after Disk Utility and Pondini's other suggestions failed), the TimeCapsule is again working perfectly - but I certainly do not trust it any longer, that's only logical. There was over a year's worth of backups on there! Thank G-d I have two Macs, with redundancy of my data on the other Mac and its backups (which are still working just fine on the same Time Capsule).


    When we say, 'were you connected wirelessly?' while conducting the backup as a possible reason for the fault, OK.. OK.. that's like being asked whether we were driving on a dirt road when our engine threw a piston. Either Airport Extreme works wirelessly safely, or it doesn't.  I'm not going to have Internet cables laying around the house from the Macs to the device. The Wireless connection was explicitly stable and undisturbed during the fault. There could be some glitch in the system logs to reveal I suppose.


    Again, don't trust this device with your precious personal computer file archives - back them up periodically on an offline disk.

  • grantdoug Level 1 (0 points)

    @EdinNorway I feel your pain!

  • EdinNorway Level 1 (5 points)

    Updated info....


    I connected (wirelessly) to the TC disk from a Windows 7 Pro 64b machine from my company.  As a reminder, I have two sparsebundles on the time capsule disk.  One of them works as it should when accessed from time machine on my Mac Lion.  The other one is not visible and won't mount.


    I mapped a network drive from the Win7 machine and can see both sparsebundle files.  When I doubleclick the file that works, I get a directory that looks like...



    When I open the problem sparsebundle, I get the following directory...


    So can it be that I need to somehow recreate the .plist, info and token files in order to access this sparsebundle?  Thanks so much for reading this!



  • Pondini Level 8 (38,740 points)

    It's still corrupted, certainly beyond OSX's ability to repair.   


    You could, theoretically, copy the files from the other one (making the appropriate changes), but OSX most likely won't let you delete the damaged ones and add the copies, even with your Admin password. 


    And that still wouldn't help fix what's corrupted in the .dmg inside the sparse bundle.


    Sorry, but your only options are as in my earlier reply (Jan 29).

  • EdinNorway Level 1 (5 points)

    Thanks P.  What heavy duty utility would you reccommend to use on the sparsebundle?  I'm using R-Studio for another failed drive but I don't believe that program works with such files...but as you can see I'm a newbie so I may be way off.



  • Pondini Level 8 (38,740 points)

    I don't know of any that will work on a Time Capsule at all.


    What a few folks have managed to do is either:


    * Physically remove the HD from the TC and place it in an enclosure, converting it into an external HD.


    * Copy the (damaged) sparse bundle to a USB drive connected to the TC (see below), then connect the USB drive to a Mac.


    Then use a utility like the ones in Data Recovery on the external HD.  Some folks swear by one, others like different ones.  So far as I know, there's no generally-accepted "best" one. It seems to depend on just what's wrong, which of course you don't know in advance.  (Catch-22 anyone?)





    Note that while there are several ways to copy an undamaged sparse bundle, the only way to copy a damaged one is this:  Time Capsule: Using AirPort Utility 5.3.1 or later to make a copy of the Time Capsule disk.  That copies the entire disk, so you'll have to delete the copy of the "good" one before trying to recover the "bad" one.   

  • EdinNorway Level 1 (5 points)

    Great news all!  I copied the files associated with a working sparsebundle to the non working sparsebundle (using MacDrive from a windows machine) and viola, the non-working sparsebundle now works.  On Mac OS X, these files where hidden so I didn't even know they existed.  Thankfully, Win7 is not native and showed whatever was there including the previously hidden files.  Copying .plist and token files (unedited) seemed to do the trick.  Thanks to all of you for helping

Previous 1 2 3 Next