Previous 1 2 3 Next 32 Replies Latest reply: Nov 21, 2015 4:05 PM by Inblut
Hayashi49 Level 1 (0 points)

I haven't had any issues with my iMac. It's a late 2010 27" model. I was in bootcamp last night and turned it off like normal to go to sleep. When I woke up this morning to turn it on, It boots, you hear the sound, but it just stays on the white screen. I've tried booting into the install disc, safe mode and holding down option to get the boot menu. It doesn't do anything past the white screen.

 

Any ideas? Should I just take it in?


iMac, Mac OS X (10.7)
  • macjack Level 9 (51,622 points)

    Do you have Extended AppleCare?

    If you do, call AppleCare and tell them the symptoms. You can get free on-site service, if they suspect hardware,

  • Hayashi49 Level 1 (0 points)

    No I don't =(

  • macjack Level 9 (51,622 points)

    Make a genius bar appointment and bring it in.

  • ds store Level 7 (30,325 points)

    Well we can try a few things.

     

    SMC reset

     

    https://support.apple.com/kb/HT3964

     

     

    PRAM reset

     

    https://support.apple.com/kb/HT1379

     

     

    You can try everything on this "Grey Screen" page too just in case it's something else hardware related. (another drive or monitor)

     

    https://support.apple.com/kb/TS2570

     

     

    Sort of a Hail Mary try and might solve your issue.

     

    A white screen appears before the grey screen I think, which the grey screen comes from the hardware firmware according to what I read about the Intel Mac boot process.

     

    The keyboard commands won't work as those actions come later after the firmware has handed things over to EFI etc.

     

    So the only low level is SMC reset, perhaps the PRAM reset will also assist. Not that knowledgeable exactly how things boot on a Mac, perhaps one day I'll read those books I've bought from Apple.

  • macjack Level 9 (51,622 points)
  • Hayashi49 Level 1 (0 points)

    Very nice list, thanks macjack.

     

    Also, I've done the PRAM reset and that works but doesn't do anything haha.

  • ds store Level 7 (30,325 points)

    macjack wrote:

     

    http://support.apple.com/kb/HT2674

     

    Yea that's it, but no white screen though, so I'm guessing the hardware firmware isn't loading the initial gray screen, thus it's white. (aka blank)

     

    http://refit.sourceforge.net/info/boot_process.html

     

    When I downgraded my 15" from 10.7 to 10.6, zeroing the drive beforehand, the first 10.6 boot actually had the thatched gray screen from 10.7, then it changed later to the 10.6 gray one, so the hardware firmware has something going on far as storing that splash screen on a EPROM, and perhaps other data.

     

    OS X can be deemed as really two operating systems, one OS X and the other is EFI (the second firmware) which programs can be loaded in there at run at boot time. (scary) and a hardware firmware that splash screen and hands off to EFI firmware.

     

    So I'm guessing no gray screen at all means a failing hardware firmware or else it would at least display the splash screen.

     

    Question is how can something mess that up? Malware from Windows?

     

     

    I guess the OP can try reinstalling their own firmware and see how that goes.

     

     

    https://support.apple.com/kb/HT1557

     

    https://support.apple.com/kb/HT1237

  • escoles Level 1 (0 points)

    I have seen this on iMacs in my company.

     

    In our case, what's worked in almost every instance is to press the power button once, without holding to reset. The white screen appears to be a state where some of the hardware is powered on, but the system has not been signaled to boot; the power button seems to accomplish that task.

  • nlb2008 Level 1 (0 points)

    I found this discussion when I experienced the same issue. All I ended up doing was unplugging everything from the back of my iMac and it started right up.

  • boyhollywood Level 1 (0 points)

    try unplugging your ipod, especially if its in disk mode......worked for me!

  • Mark Petereit Level 1 (25 points)

    Thanks, nlb2008! I unplugged a cheap USB hub and she booted right up!

  • zorand Level 1 (0 points)

    One way to fix white screen on your Imac:

     

    1 Turn off your computer.

     

    2 Unplug everything.

     

    3 Leave power, mouse, keyboard and monitor plugged.

     

    4 Turn on your mac.

     

    Good Luck

  • zpearl Level 1 (0 points)

    Unplugging everything worked for me.  I think the culprit was my ipod for some reason... go figure.

     

    Unlike others when I couldn't get past the white screen, I was able to boot via the option key and it gave me a choice of my 500GB drive or Recovery.  I chose my internal drive and it booted fine.  So, I knew there was something else that was the problem and not the drive itself. 

     

    Unplugging took care of it and I've rebooted several times with no problems.

     

    Thanks for your help on this....

     

    Gary

  • Reddo-fides Level 1 (0 points)

    I got this white screen problem after having used Apple TV with my iPad. The screeen on my 27"  iMac turned first gray then white and I couldn´t get pass the white screen. After having tried different suggestions I found on the net I turned the power off of my iPad. Prior to that I had also removed the power cable of the Apple TV box and all other cables from iMac. It was the turning off the iPad that made the difference ! The iMac started normally after I rebooted it.

     

    My iPad is set up to synchronize wirelessly.

     

    This suggests that there is some issue connected to the simultaneous use of Apple TV-iPad-iMac.

Previous 1 2 3 Next