3 Replies Latest reply: Feb 15, 2013 10:02 PM by Abroscrinewtaislavaint
Abroscrinewtaislavaint Level 1 Level 1

A few days ago, I instaled Xcode, but didn't like it, so I used the uninstall-devtools exec to remove it. Now, when I open up x11, it crashes with a dialog:


Process:         X11.bin [60692]

Path:            /Applications/Utilities/X11.app/Contents/MacOS/X11

Identifier:      org.x.X11

Version:         ??? (???)

Build Info:      X11server-850300~2

Code Type:       X86-64 (Native)

Parent Process:  launchd [189]


Date/Time:       2012-01-29 19:33:07.842 -0500

OS Version:      Mac OS X 10.6.8 (10K549)

Report Version:  6


Interval Since Last Report:          157322 sec

Crashes Since Last Report:           14

Per-App Crashes Since Last Report:   7

Anonymous UUID:                      183E3713-9CEB-4B08-9CC9-E81ED2E83326



Exception Codes: 0x0000000000000002, 0x0000000000000000

Crashed Thread:  0


Dyld Error Message:

  Library not loaded: /usr/X11/lib/libAppleWM.7.dylib

  Referenced from: /Applications/Utilities/X11.app/Contents/MacOS/X11.bin

  Reason: image not found


Binary Images:

    0x7fff5fc00000 -     0x7fff5fc3bdef  dyld 132.1 (???) <486E6C61-1197-CC7C-2197-82CE505102D7> /usr/lib/dyld


Model: MacBook6,1, BootROM MB61.00C8.B00, 2 processors, Intel Core 2 Duo, 2.26 GHz, 2 GB, SMC 1.51f53

Graphics: NVIDIA GeForce 9400M, NVIDIA GeForce 9400M, PCI, 256 MB

Memory Module: global_name

AirPort: spairport_wireless_card_type_airport_extreme (0x14E4, 0x93), Broadcom BCM43xx 1.0 (

Bluetooth: Version 2.4.5f3, 2 service, 12 devices, 1 incoming serial ports

Network Service: AirPort, AirPort, en1

Serial ATA Device: Hitachi HTS545025B9SA02, 232.89 GB

Serial ATA Device: MATSHITADVD-R   UJ-898

USB Device: Built-in iSight, 0x05ac  (Apple Inc.), 0x8507, 0x24400000 / 2

USB Device: BRCM2070 Hub, 0x0a5c  (Broadcom Corp.), 0x4500, 0x06100000 / 2

USB Device: Bluetooth Module, 0x05ac  (Apple Inc.), 0x8218, 0x06130000 / 4

USB Device: Apple Internal Keyboard / Trackpad, 0x05ac  (Apple Inc.), 0x0236, 0x04600000 / 3

USB Device: USB Receiver, 0x046d  (Logitech Inc.), 0xc52f, 0x04100000 / 2

I suspect that uninstall had something to do with it, but I'm not sure.

Anyone have a soloution?

MacBook, Mac OS X (10.6.8)
Solved by Abroscrinewtaislavaint on Feb 23, 2012 6:32 PM Solved

Nevermind about that.