Previous 1 2 3 Next 67 Replies Latest reply: May 4, 2016 6:29 AM by Birck Cox
lsb Level 1 Level 1

Hello,

 

I upgraded to Mac OSX Lion some months ago and my trackpad connected without a problem.  In the past week, my trackpad has been losing connection with the computer when it is sleeping.  I have tried the trackpad with my laptop and it works fine, so I know it is an iMac/trackpad issue.  I have also reset the PRAM to no avail.

 

Anyone have any ideas how to resolve this issue?  The computer simply does not discover the trackpad.

 

Thanks.

lsb


iMac, Mac OS X (10.3.x)
Reply by Jeff DeMello on Nov 29, 2012 10:29 AM Helpful

Here's what I did to make the Magic Trackpad to connect:

 

 

  1. Take off the battery cap of the Magic Trackpad
  2. Turn off Bluetooth on the computer (in Bluetooth Preferences)
  3. Turn on Bluetooth on (in Bluetooth Preferences)
  4. Replace battery cap of the Magic Trackpad
  5. Press "+" to add a device in Bluetooth Preferences on your computer
  6. Press, AND HOLD, the Power Button on the Magic Trackpad, AND KEEP HOLDING while green light is blinking.
  7. Select the Magic Trackpad
  8. Once the Magic Trackpad is connected you may release the Power Button on the Magic Trackpad
Reply by James Mol on Sep 10, 2012 5:38 AM Helpful

Mine too has started disconnecting and reconnecting every 2 seconds after I replace the batteries.

 

I tried several different sets of rechargable batteries and found that, for me, it was in the batteries.

 

I have used some ultra pro for the last year, rotating and recharging them. This time, trackpad would not stay connected. The engergizer recharge I stuck in is working fine and it even shows the same battery level as the Ultra Pro.

 

Before I verified the battery solution, I did try Bluetooth Explorer and did what Joe K. advised. It was a simple to download since I had registered as a developer years ago. BE started up and I found the Device Cache and deleted my device, then use system preferences>Bluetooth to pair it up again.

 

I will update if I start having trouble again.

Reply by lsb on Feb 1, 2012 12:47 AM Helpful

Well, tried your suggestion and it didn't work-still can't discover the trackpad as a device-I did initially discover someone else's smartphone, but on second attempt, that didn't come up either.  Trackpad still works with laptop.  Other suggestions?

 

Thanks.

All replies

  • 6ITManagement Level 1 Level 1

    Turn the bluetooth on your computer off and back on. Also turn the trackpad off and on, it's not much of a solution, but the small things often fix huge problems!

  • lsb Level 1 Level 1

    Thanks for the thoughts.  I've done both things.  The issue is a connection one-the device is there, but can't be connected or discovered on my iMac-works fine on my laptop, which is very strange, especially as both have Lion running.  I've even run Repair Permissions in disk repair to no avail, and can't figure this out-ahh!

     

    Other thoughts appreciated and thanks again.

    lsb

  • 6ITManagement Level 1 Level 1

    Hmm... Do other bluetooth devices connect to the iMac?

  • lsb Level 1 Level 1

    I couldn't get my other wireless mouse to connect-does that help?

     

    Thanks.

  • 6ITManagement Level 1 Level 1

    Well, it kind of means that there really is something wrong with the iMac's bluetooth, and not just with the connection with your trackpad. Unfortunately I can not find any 'special' options in the bluetooth settings.

    However you could try this:

    • Open "System Preferences"
    • Select the "Bluetooth" pane
    • Find your trackpad (it should say "Not Connected" underneath the name)
    • Select the trackpad and press the little "-" and confirm by clicking on "Remove"
    • Now, turn your bluetooth off and back on again, just in case

    Please let me know whether this works or not.

  • lsb Level 1 Level 1

    Well, tried your suggestion and it didn't work-still can't discover the trackpad as a device-I did initially discover someone else's smartphone, but on second attempt, that didn't come up either.  Trackpad still works with laptop.  Other suggestions?

     

    Thanks.

  • 6ITManagement Level 1 Level 1

    There probably is some solution that involves some terminal-magic, but since I only know a few Terminal commands, I'm afraid you'll have to wait for a Terminal-wizard to reply to this post. You could also try contacting Apple and see what they have to say.

  • lsb Level 1 Level 1

    Thanks for trying!  I'll give Apple a ring.

  • 6ITManagement Level 1 Level 1

    You're very welcome! Please let me know what Apple says about the issue though, thanks.

  • Greatestever1 Level 1 Level 1

    Did u ever solve proble with trackpad?

  • lsb Level 1 Level 1

    Well I guess the answer to that is yes and no.  The trackpad sometimes loses the connection, it can't be discovered, and then some hours or days later, it suddenly works again.  I can't figure it out so I just have a mouse on standby.

     

    Thanks...

  • JWPNJ Level 1 Level 1

    Any other solutions here?  I'm having the exact same problem.  My trackpad is connected to my iMac.  Went to the Apple store and tested the Trackpad and it worked fine.  Bluetooth keyboard works fine.

  • GMWDesign702 Level 1 Level 1

    Check to make sure your trackpad is not connected to another Mac in the area of your current Mac you're having the issue with. 

     

    In my experience the trackpad will not connect to a new device if it's currently connected to another device.

  • joeman42 Level 1 Level 1

    My new Macbook Pro (which was migrated from my older Mac Pro tower) failed to discover and connect to my trackpad this morning (despite having connected yesterday), so I used the Apple Developer tool called "Bluetooth Explorer.app", found and deleted the trackpad from the Device Cache, and walked through the Setup Trackpad steps in System Preferences. That seemed to work.

     

    I realize that not everybody has knowledge of or access to the (free!) Dev Tools at Apple, but if you know your way around developer.apple.com you can often find some interesting tidbits. Well worth signing up for (https://developer.apple.com/downloads/index.action?name=for%20Xcode%20-# Download "Hardware IO Tools for Xcode")

     

    I'm not sure why caching a device would prevent re-connection -- I've got a theory that it's something to do with Migration Assistant or upgrading from 10.7 to 10.8 -- the device is recognized as cached but the cached info is out of date or has metadata applicable only either to the older computer or 10.7.

     

    My other theory is that perhaps when the device lost connection that it did not get "put away" correctly. I also noted that prior to my removing from the cache, that the Bluetooth Explorer was unable to pull down the device's SDP record (error 0x4). The SDP record are how Bluetooth devices tell the host computer what capabilities they support, and I think the OS caches these.

     

    Joe K.

Previous 1 2 3 Next