Previous 1 2 Next 29 Replies Latest reply: Dec 22, 2014 3:19 AM by harmsway14 Go to original post
  • 25Bravo Level 1 Level 1 (0 points)

    Trying to open it in Quicktime did not work for me.  In fact, this issue seemed to stump Apple support as well.  I was on the phone with them for a little over two hours trying to solve this problem with no result.  We left off with the guy wanting me to back up my files and reinstall my OS which I haven't done yet but I may have to try.  I'm litterally out of options. 

     

    - I tried playing the files in both Quicktime and VLC

    - I've reinstalled iTunes and Quicktime

    - I even went so far as to buy Quicktime Pro thinking that would solve my issue

    - I deleted the files and re-downloaded them

     

    I tried a dozen other things with Apple support all which did nothing.  Someone has GOT to have an idea I haven't tried yet.

  • aloonz Level 1 Level 1 (0 points)

    I had the same problem on both my mac and windows laptop, its a simple solution that might sound really stupid. Close everything opened on your laptop. Shut down the laptop safely (dont click on the power button too long), open it again and it should play perfectly. I know it sounds like it wont work, but it did for me on both my mac and windows. I believe it has something with the add-ons not loading properly when opening, the only real way to reopen them is for a full restart. I prefer the shut down wait 5 minutes and open it back up.

    Good Luck!!

  • Borne2Run Level 1 Level 1 (0 points)

    Easy solution for everyone else:

     

    Stems from the helper add-ons not loading properly. To fix:

     

    Windows:

    Close itunes

    Open up the Command Line/Command Prompt from the Windows Button (search for 'Command Prompt')

     

    Type in: TASKKILL /IM ITunesHelper.exe -f

    ---- This ends the ituneshelper process. It will restart when you reload itunes.

     

    Then, open itunes.

    Run your tvshow or movie. It now works.

  • brettjw Level 1 Level 1 (0 points)

    That did it - thanks for the post and the help.

  • Wolf66 Level 1 Level 1 (0 points)

    This worked perfectly for me, too.  Thank you for the help.

  • Saltycturtle Level 1 Level 1 (0 points)

    Same problem here - I purchased two episodes, one of which did not play while the other was fine. QuickTime up to date, Taskkill attempted but still no luck :(

  • IAmDeanTate Level 1 Level 1 (0 points)

    I can't believe that worked. Why did that work?

     

    And why has it been known since december last year that it can fix the problem, and yet there's no official fix in an itunes build? So, so frustrating...

  • IAmDeanTate Level 1 Level 1 (0 points)

    I spoke too soon. It worked...for 3 seconds.

     

    And then I tried starting the movie from the beginning. Back to having a black screen, except now the timeline on the movie won't move ie. when I hit "play" I see the pause button flicker on for a split second, then back to being a "play" button, and nothing happens (no audio, no visual, and timeline isn't scrubbing forward anymore).

     

    Beyond frustrating.

  • IAmDeanTate Level 1 Level 1 (0 points)

    Hahaha...ha..oh god, I think I worked out part of the problem I'm having.

     

    I run on multiple monitors. The second time I tried running the movie (in post above) I had moved itunes over to a secondary monitor (to have a movie running in the background while I work). It appears that's the problem. Moved itunes back to primary monitor, movie now runs.

     

    Really? This is some DRM BS preventing me from watching a movie on a monitor that is *not* the one I'm trying to do work on?

  • cyberion8 Level 1 Level 1 (0 points)

    Thanks IamDeanTate!  That was my exact scenario.  Now it's playing....you're a genius :-)  After I loaded the movie on my primary monitor, I can move it to the secondary and continue watching!!

    I also found out that if you try to "maximize" the iTunes window on the secondary monitor (while iTunes is playing your show), it will render your primary black also. 

    To dear Apple:  What the heck?  This shouldn't have been an"issue" in the first place!!!!!!!

  • Holland01 Level 1 Level 1 (0 points)

    Here is what I experienced:  I purchased a TV show last night from the iTunes Store.  When I tried to play it on my PC, the screen remained black with only the play/fast forward/pause etc buttons visible.  Thinking if I re-installed ITunes it might help, I closed iTunes, went to Control Panel, opened Programs, Uninstall Program and clicked on iTunes.  There is an option to "repair" so I thought what the heck, and tried it.  I re-opened iTunes and Voila! I was able to view the TV show.

  • truerock Level 1 Level 1 (0 points)

    I solved this problem on my Windows 7 PC.

    I read this article:

    Troubleshooting iTunes for Windows Vista or Windows 7 video playback performance issues

     

    and tried the tip about disabling "Enable Direct3D video acceleration" in QuickTime Advanced Preferences.

     

    It fixed the iTunes bug on my PC.

  • jogainvasion Level 1 Level 1 (0 points)

    I have the same problem, uninstall and reinstall itunes & quicktime (install itunes 1st after that quicktime) solved my problem.

  • Gristlebag Level 1 Level 1 (0 points)

    My fix involved audio - switch the quicktime options to 16 bit audio. This problem has been in there for years, although it may be related to Dell laptops specifically as that's where I have encountered it.

  • harmsway14 Level 1 Level 1 (0 points)

    I suddenly have the same problem. I could open it in Quicktime, but not iTunes. I tried:

     

    Deauthorizing/Reauthorizing my computer - Didn't work

    Quicktime >> Edit >> Preferences >> Advanced >> unchecked "Enable Direct 3D Video Acceleration" - Didn't work

     

    Then I tried:

     

    Go to Control Panel >> Programs and Features, selected iTunes then clicked "Repair" and IT WORKED!

     

    I went back into Quicktime and rechecked "Enable Direct 3D Video Acceleration" and it still works.

     

    Good luck.

     

    Note: I am using a Dell laptop with a monitor via Presentation settings (so it may be seen as another monitor).

Previous 1 2 Next