7 Replies Latest reply: Feb 11, 2013 8:59 AM by Mac_fool
AndreRosso Level 1 Level 1 (0 points)

I'm trying to put an 3d widget in a project using a model from Google Sketchup, exported in .dae format (collada).

The widget works fine, but my problem is that the initial view when I open the book on iPad is very different from that I used, when exporting from Sketchup. Example:

I want to shown a 3d animation for a motherboard, and I want  the animation, as seen by the reader, starts in a default position, let's say a top view, but the animation is starting with the back of the motherboard.

 

Sorry about my english.

 

André Rosso

Brazil.


MacBook Pro, Mac OS X (10.7.2)
  • Mac_fool Level 1 Level 1 (120 points)

    Hi André

     

    I'm having the same issue. This issue is quite well documented, but there appears to be no real fix for it yet. The problem appears to be two differing elements.

     

    1) The 'camera' tool that is used in Sketchup does not export to the collada file,

     

    2) iBook Author apparently has a non-standard way of handling the Axis - the vertical Z up axis is all wrong.

     

    Apple's suport page http://support.apple.com/kb/HT5093 doesn't really help at all.

     

    I have tried changing the axis in the Sketchup file, but that has no effect on the exported .dae file. You can rotate the finished model in Sketch up (keeping the axis as is) but I have yet to hit on a 'miracle' number that sets the view as the default view in Sketchup.

     

    Apparently, cameras can be set in other (much more expensive) 3D modelling software such as Maya, etc, but these packages are much more difficult to learn.

     

    I will post back here with any progress I make on it.

  • Mac_fool Level 1 Level 1 (120 points)

    Hi again André.

     

    Not got a perfect solution by a long shot, but I'll share what I've done with you.

     

    1) Open Sketchup and 'save as', so you don't muck up your original.

    2) Rotate your model 180º on the horizonal plane.

    3) Rotate the model 90º clockwise along the green axis.

    4) you model should now be standing with it's bottom facing your default view, with it's 'front' facing down.

    5) export as .DAE.

     

    Like I say, it's certainly not perfect, but it's much closer than we were. Hope that helps.

     

    Unless Apple put extra work into iBook Author that would involve setting the 'camera' in iBooks Author ( very unlikely), or Google updating Sketchup specifically for .dae for iBook (also unlikely), the best chance for a solution is a very clever person writing a 3rd party plug-in for Sketchup. That person isn't me, I'm afraid.

  • stowler Level 1 Level 1 (20 points)

    Obviously I'm late to this thread, but I ran into the same problem this morning and created this work-around. It's similar to what Mac_fool describes above, but I'm re-using a pre-rotated placedholder until Apple fixes this. Hope this helps : http://sketchup.google.com/3dwarehouse/details?mid=de262856580e80834b892bc5603ca b56

     

    best,

    Stephen

  • Mac_fool Level 1 Level 1 (120 points)

    Good one Stowler.

     

    Unfortunately Apple arent interested in fixing this – its not really their issue to fix. I have actually taken a largher step for some 3D work and teken to using Blender.

     

    Its a much bigger program, with a blisteringly high learning curve, but its free, more powerful, and the cameras work. Used it to create a 3D animation at the beginning of an iBook demo. Pretty cool stuff for a typesetter.

  • Kay Pictures Level 1 Level 1 (0 points)

    Hi Mac_fool,

     

    Im following the same road, currently fighting with blender. Camera position perfect, but whether importing or exporing to/from blender, the textures/maps disappear!

     

    Any insights welcome!

     

    Iain

  • Mac_fool Level 1 Level 1 (120 points)

    Hey Iain.

     

    I remember having a bunch of issues in Blender regarding the use of an image-mapped sky dome, that it wouldn't render at all. In the end I used a texture instead. Unfortunately my only Blender experience (other than tutorials) was for producing an intro movie, not a collada .dae.

     

    In all honesty, the best place to get a resolution to this is the blender.artists forum. Most of the action happens in the States, so an answer can take a while, but they did give me some great pointers on making camera paths, etc.

  • Mac_fool Level 1 Level 1 (120 points)

    Hey again, I just remembered something that I found after tinkering. Probably nothing to do with your issue, but I remember problems with the lighting of stuff that washed out the material texture in the resulting .dae. In the end I removed all light sources, including the default lamp, and the colours/materials looked much more natural.