Previous 1 2 Next 15 Replies Latest reply: Feb 6, 2012 9:56 AM by ~Bee
JC1983 Level 1 Level 1

I am using a macbook that i bought in 2007. I have snow leopard installed. I recently restored my system using Time machine (probably did this about 2 weeks ago). Ever since this restore my computer has been draining the battery really fast. Looking at other discussions I discovered that a particular process is opened whenever the computer is being used. Many times the process when checked in system monitor has been opened multiple times. I thought perhaps the computer had some malware on it or a virus. When I scan for these things nothing unusual is found. The name of the process is gentatsdb- user_atsserver as the user. I can't figure out how to keep this process from popping up. It is draining my battery, and causing the fan in the laptop to overwork so that it is very audible. I am used to a quiet mac not a loud one. Does anyone know How I can fix this problem?. By the way I have tried running disk utility, verifying, and repairing any discrepancies. Help Thank You


Macbook, Mac OS X (10.5.1)
Reply by fane_j on Jan 30, 2012 8:34 PM Helpful

My guess would be that you have quite a few PDFs, which Spotlight is re-indexing, which calls up ATSServer.

 

I'd say, one night, before you go to sleep, re-index your entire drive and let it work until it's done.

 

<http://support.apple.com/kb/HT2409>

All replies

  • fane_j Level 4 Level 4

    My guess would be that you have quite a few PDFs, which Spotlight is re-indexing, which calls up ATSServer.

     

    I'd say, one night, before you go to sleep, re-index your entire drive and let it work until it's done.

     

    <http://support.apple.com/kb/HT2409>

  • JC1983 Level 1 Level 1

    I think you may be right...now that I think of it spotlight did try to index some files about 2 weeks ago but i never let it finish. I will try and see if that fixes my problem. Thank You

  • JC1983 Level 1 Level 1

    So i managed to index the whole drive. I thought that it worked but...I didn't restart the computer yet and it started going again on its own maybe i will do a restart to see if that helps.

  • JC1983 Level 1 Level 1

    Yea so that didn't work for me...Does anyone have any other suggestions about why this is happening?

  • fane_j Level 4 Level 4

    JC1983 wrote:

     

    Yea so that didn't work for me

    Sorry it didn't work. Let's try something else.

     

    The runaway process has something to do with Apple Type Services. I assume that "genatsdb" means something along the lines of "generate ATS database". So perhaps the issue is not indexing PDFs (which would be Spotlight calling on ATS), but your font collections themselves.

     

    So, first, I'd read Kurt Lang's paper on managing fonts

     

    <http://www.jklstudios.com/misc/osxfonts.html>

     

    Then I'd prune my font collection of all possibly dubious or defect fonts, after which I'd follow the instructions on completely removing all font caches. And then, test again…

  • JC1983 Level 1 Level 1

    yea i tried removing the font caches with the program font nuke and removed the suitcase caches. Restarted many times but still no cigar. I wonder if I will have to restore to an earlier time when this wasn't happening. Or does anyone else have suggestions??? I am still getting this process appearing multiple times in my system monitor and it is using 96% or more of my battery when activated. I can hear the fan running as well still

     

    Thank you for your help thus far

  • JC1983 Level 1 Level 1

    So it appears after skimming the beginning of the font article/link that I am missing fonts from my library folder. Does anyone know how to recover these?

  • fane_j Level 4 Level 4

    I don't know what Font Nuke does; it may be an excellent programme, but I prefer to use Terminal commands, when I know exactly what is being done. Also, make sure to disable and remove any font managers (eg, Suitcase), and check your fonts for defects. If you're missing fonts, figure out why. Keep in mind that, deleting the font caches may clear corruption in the caches, but if you have a problematic font, the issue may re-occur.

  • ~Bee Level 7 Level 7
    expertise.macosx
    Mac OS X

    JC1983--

     

    A couple of questions, OK:

    1.  Do you have a font manager on there (like Suitcase)?  Or are you just using Font Book application that came with your Mac?

     

    2.  Have you opened up Font Book to check for duplicates?

     

    3.  How do you know you are missing some fonts?  And which Library are you missing fonts from?  You have three:  HD > Library > Fonts;  HD > System > Library > Fonts (which you should NEVER touch); and HD > Users >YourName (Home Folder) > Library > Fonts.

  • JC1983 Level 1 Level 1

    Looks like I have just font book. The reason I know I am missing fonts is because I looked in one of the folders at the time. I don't know which one but either way I put fonts in there via a document that was referred to me if you look up at the previous pots. Looks like when I opened font book that I do have some duplicate fonts to resolve. I will go ahead and do that. Thanks for your help

  • JC1983 Level 1 Level 1

    The duplicate fonts have been deleted, I also used font nuker to clear any font caches. What are the next steps that I should take? by the way fontworker is now the major process that is running at the high CPU %

  • ~Bee Level 7 Level 7
    expertise.macosx
    Mac OS X

    JC --

     

    Go to this file, and copy and paste the list of fonts that are in there, OK?

    HD > SYSTEM > Library > Fonts.  Don't change anything there, just copy & paste the list here.

    :-)

  • JC1983 Level 1 Level 1

    ok here you go....

    Apple Braille Outline 6 Dot.ttf

    Apple Braille Outline 8 Dot.ttf

    Apple Braille Pinpoint 6 Dot.ttf

    Apple Braille Pinpoint 8 Dot.ttf

    Apple Braille.ttf

    Apple Symbols.ttf

    AppleGothic.ttf

    AquaKana.ttc

    Courier.dfont

    encodings.dir

    fonts.dir

    fonts.list

    fonts.scale

    Geeza Pro Bold.ttf

    Geeza Pro.ttf

    Geneva.dfont

    HelveLTMM

    Helvetica LT MM

    Helvetica.dfont

    HelveticaLight.ttf

    HelveticaLightItalic.ttf

    HelveticaNeue.dfont

    Keyboard.ttf

    LastResort.ttf

    LucidaGrande.ttc

    Menlo.ttc

    Monaco.dfont

    STHeiti Light.ttc

    Symbol.ttf

    Thonburi.ttf

    ThonburiBold.ttf

    Times LT MM

    Times.dfont

    TimesLTMM

    ZapfDingbats.ttf

    ヒラギノ明朝 ProN W3.otf

    ヒラギノ明朝 ProN W6.otf

    ヒラギノ角ゴ ProN W3.otf

    ヒラギノ角ゴ ProN W6.otf

    儷黑 Pro.ttf

    华文细黑.ttf

    华文黑体.ttf

  • JC1983 Level 1 Level 1

    Well thanks for everyone's help so far. It appears that the problem has resolved itself sometimes after deleting the duplicated fonts. I noticed the operating system stopped running the process in the background at the full CPU %.  My battery also lasts the appropriate amount of time. Thanks again. Let me know if there is anything else i should do.

     

    Janelle

Previous 1 2 Next