11 Replies Latest reply: Aug 26, 2014 8:20 PM by MiracleTip
bradhotdog Level 1 Level 1 (15 points)

i'm running a macbook pro

10.7.2

2.5 GHz Intel Core 2 Duo

4 GB 667 MHz DDR2 SDRAM

 

i've got all my final cut pro x events and projects saved on an external hard drive that i'm working off of

 

final cut pro x runs exteremly slow. i am just editing a simple video that has one track of video. no multiple layers, no color corrections, no transitions, nothing different than the raw footage. i even had final cut interpret the footage to make optimized footage and proxy footage to work with easier.

 

i find when even trying to watch back my timeline once everything has been transcoded in the background and there is no processing going on, after about 15 seconds of video playback, it starts lagging. then it starts skipping, then it starts stuttering up so badly it's unbareable to the point where i have to pause, then start playing again.

 

does anyone else experience this issue?

 

i know this is suppose to be running in 64bit but i feel like it isn't.

 

i feel like this is a much slower working program. it seems like it has to take up so much energy to generate all these different components on final cut pro x like all the thumbnails of every clip in my event, it has to load every effect that i hover over, it just uses way to much processing just to do nothing.

 

is anyone else having this same problem? is it because i'm using a macbook pro from 2007? even so, i have plenty of space and enough ram that i should be able to run final cut pro x just fine if i could handle final cut pro 7 before.


Macbook Pro, Mac OS X (10.7.2)
  • andynick Level 5 Level 5 (4,925 points)

    You should have your Events and media on a different drive to the MBP System. This would be the same with FCP 7 although I suspect FCP X uses more power (it uses more of everything else).

    I have a fairly powerful Mac Pro and that struggles with some footage on the System Drive.

    Are you sure all your footage is transcoded to ProRes 422?

    What is the original codec?

    Andy

  • Pancenter Level 6 Level 6 (8,835 points)

    Don't forget that Apple is a hardware company, the software is designed to sell hardware.

    The minimum FCPX memory requirement Apple lists (2GB) is about 1/4 of what you actually need.

     

    Between resource hungry Lion and memory intensive FCPX you're probably running low on RAM, plus an older machine has considerably slower bus speed/memory access so it's just going to be slow.

     

    Fixes suggested are deleting preferences and/or opening terminal and typing "purge"  (minus quotes) which should free some memory.

     

    Some related threads that may help.

     

    https://discussions.apple.com/message/17438517#17438517

     

    https://discussions.apple.com/message/16724421#16724421

     

    https://discussions.apple.com/message/17446300#17446300

  • andynick Level 5 Level 5 (4,925 points)

    For anyone having similar problems, here's my pet answer for this (very common) question - don't lose heart! It's an awesome application - you just need to see why it's not working well on your system.

     

    FCP X runs very well (not perfectly, by any means) on my 2009 MacPro 2 x 2.26 GHz Quad-Core Intel Xeon with 16 GB RAM and ATI Radeon HD 5870 1024 MB

     

    First, check the spec of your iMac against the system requirements:

    http://www.apple.com/finalcutpro/specs/

     

    Particularly your graphics card. If it's listed here, it's not suitable:

    http://support.apple.com/kb/HT4664

     

    If you are getting crashes, there is some conflict on the OS. Create a new (admin) user account on your system and use FCP X from there - if it runs a lot better, there's a conflict and a clean install would be recommended.

     

    Other ways to improve performance:

     

    Create optimised media.

     

    Hide Waveforms at all times when you don't need them (both in Browser and Storyline / Timeline). They take up a lot of processor power.

     

    Create folders in the Project library and put any projects you are not working on currently, in there. (Twirl it closed to hide them).

     

    Move your Projects and Events to an external HD (make sure it's formatted OS Extended - with journaled on or off) and run from there.

     

    The biggest single improvement I saw in performance was when I upgraded the RAM from 8 GB to 16.

    Andy

  • Graeme White Level 1 Level 1 (15 points)

    My first experience with FCP X was horrifically slow - seems that it had imported H264 Video but had only transcoded 2 of the 9 clips to ProRes422. This was only one of several nasty surprises (including crashes on an otherwise super-stable machine, endless disk thrashing despite background rendering being turned off etc) I ended up transcoding all the video and audio myself.

     

    This was with 10.0.0.3 - I wanted to like it, I really did, but it does NOT do what it says on the tin. I'm seeing a load of workarounds posted to coax FCP X into stability (as above) but for me, while I need to earn money with editing, I'll stick with something fast and let the hobbyists beta test this version.

  • alainpire Level 1 Level 1 (0 points)

    Hi,

    I also have the same problem. I'm editing a 2 hours long concert with 8 cameras. I transcoded everything to ProRes and in the beginning of editing, everything went fine.

    Then, after an hour of film, I began to have crashes and endless turning wheel. I upgraded my I7 quadcore machine to 16GB of ram but it did'nt help. I only have internal HD's 7200, so that's probably where the problem lies.

    I had to split the project in half, but after heavy editing, both parts are real slow,

    My question is : will I gain fluidity if I turn off all unused clips ? - On a selected area, I only use one clip of course, but in all layers in the bottom of that clip, I left all clips ON

    Thanks

    Alain

    PS I'm in 10.0.7

  • JimmyJackson182 Level 1 Level 1 (10 points)

    Alain I'd do some or all of the following to speed up your workflow:

    1. Turn off background render - you can still edit and see changes while working, but it saves you time

    2. Put your events/project files on a separate external drive, preferably ssd or thunderbolt.  You are correct that with eight cameras, even in multicam, that's a lot of info for a 7200rpm drive.

    3. Double that ram to 32 if you can

    4. Too late to upgrade the graphics card - what are you running?  I'd say you need at least 1GB of GC memory, but more always helps.  The GC does a ton of heavy lifting especially in FCPX, and especially with all those camears.

     

    Not sure if turning off those clips will help.  But if you're doing work like this often (mulitple cameras, etc) I'd say you want to invest in an external RAID setup with Thunderbolt to push all that data.  Your mind would be blown.

     

    Hope that helps, good luck!

     

    - Jimmy

  • alainpire Level 1 Level 1 (0 points)

    Thanks for all your wise tips Jimmy, but it's a one shot project - a concert that we taped with my band.

    So I'm not sure that I will invest that much. But I do think that a 512 gb SSD drive would help a lot + a better graphic card and 32gb memory ... maybe in the future.

    I'm now almost at the end of the project and I have some more disturbing things happening.

    Some clips that are on, just don't show - I have a black screen instead !

    If I do an export, I see them, but with green flashes here and there, it's deeply annoying because it's not the files themselves. In an earlier export, that very song was alright -

    I defragmented the drive to no improvement

    Alain

  • JimmyJackson182 Level 1 Level 1 (10 points)

    No fear, I've had this happen before and posted about it here.  The easiest fix is usually a deletion of all render files and then a re-export.  Try the following, after you make sure you've got the latest update.

     

    1.  From the project browser select your project.

    2. Go to File>Delete Project Render Files

    3. It will ask you which ones, select "All render files" and delete.

     

    The entire project will then rerender (could take a while depending on the size) and then export a fresh copy.

     

    KEY: DO NOT EDIT IT AT ALL BEFORE EXPORTING A FRESH COPY.  This can make it glitchy, and cause more patchiness.  Hopefully that works.

  • Thabo Da Husky Level 1 Level 1 (10 points)

    Sorry mate but I wouldn't go near FCPx with an Intel Core 2 Duo - this is old old tech and you're just asking for problems. Sell her and with the money you could get a little i7 mini. You will notice a huge difference even with the cheapest and lest powerful computer apple now offers.

     

    I can happily edit footage in FCPx on my Mac Book Air, you could try a low end version of those that can be had for $1000 on the refirb store.

  • sdhammond Level 1 Level 1 (0 points)

    I can't believe that all I needed to do was move all the project and event files off my HD and onto an External HD! Brilliant now it is perfect Thanks JimmyJackson182!

  • MiracleTip Level 1 Level 1 (0 points)

    Ive had the same problem...You can upgrade if you want, i am sure that would help somewhat. BUT what I did was (after I chopped through angles on the MULTICAM TIMELINE), took OFF the "Viewable Angles", AND turned OFF the "Event Viewer".  Now with only one video showing (your timeline), PROBLEM SOLVED! The video now plays smoothly with no skipping.

     

    Now in the timeline you can expand/subtract each "angle" to fit your need. Good luck!