4 Replies Latest reply: Dec 4, 2012 8:21 PM by Menuken
adamlea Level 1 Level 1 (95 points)

I can't download anything from the iTunes U catalog. When I access the catalog and select something, the button turns grey and says "Downloading," but the catalog box stays open - it doesn't flip to the shelves, like iBooks, and show the download. I'll invariably get an error message telling me the material is unavailable and giving me a retry or later option.

 

I'm running an iPad 2 and a 13" MacBook Pro (early 2011) - all software (iOS, Mac OS, and apps) is up to date. After reading the posts in this forum, here's what I've done to troubleshoot:

 

1) I've deleted the iTunes U app and reinstalled from the App Store on the iPad

 

2) I've deleted the iTunes U app and reinstalled it from iTunes on the MacBook Pro via sync

 

3) I've tried various combos of delete - hard reset - reinstall

 

4) I've tried downloading all different types of catalog material at all different times of the day and night - thinking there might be a server issue

 

5) I've even tried downloading material through iTunes on the MacBook Pro and syncing it to the iPad - everything downloaded fine through iTunes, but it wouldn't sync

 

Nothing I've tried works. One way or another, I always get the same "Can't download" error message. I don't get it. Does iTunes U work at all?

  • turingtest2 Level 9 Level 9 (55,445 points)

    I'm certainly having some mixed results at the moment. Some courses that I'd previously subscribed to are showing phantom episodes and no amount of deleting and redownloading makes them go away. I have two courses from the Open University that are each a single iBook, but both courses insist on opening the same book. I can open each individually from iBooks, but not from within the iTunes U app. When using the Catalog I can sometimes download material to view on demand but not subscribe to the course.

     

    In each case I suspect the answer is to track down the contact details for the course provider and get them to look into the problem. For example the contact for the OU is itunesu-editor (at) open.ac.uk. Tracking down the correct contact can be a challenge... I eventually found this one from the main OU page in iTunes, then down the right-hand side was a section called "OU Links" and under that one called "Contact the Editor". I'm just about to send in some feedback so time will tell...

     

    tt2

  • turingtest2 Level 9 Level 9 (55,445 points)

    Here are some examples of the things I have noticed...

     

    IMG_0252.png

     

    IMG_0259.png

     

    IMG_0250.png

     

    IMG_0261.png

     

    tt2

  • adamlea Level 1 Level 1 (95 points)

    tt2:

     

    Thanks for your replies.

     

    On a whim, I revisited the iTunes U tonight. No change - still can't download anything. Whenever I try, I get the same "Unable to Download Podcast" error message. Pity. So much interesting material. For now, however, iTunes U is nothing more than a good-looking icon on my home screen.

     

    I have canvassed these forums and tried every remedy that's been suggested - all to no avail.

  • Menuken Level 1 Level 1 (0 points)

    Hi thought maybe this would work for you. I went into my apple account and deauthorized all attached devices connected to my apple account, and then re-entered into itunes and reauthorized my Mac.  I can now download ItunesU course material.