Skip navigation

Address book not syncing with Google contacts

2774 Views 4 Replies Latest reply: May 30, 2012 8:56 AM by KAKershaw RSS
Richard Tse Calculating status...
Currently Being Moderated
Jan 30, 2012 11:16 PM

How is it that my Address Book does not sync with Google Contacts?

 

I have a Google Apps account with a non-"@gmail.com" domain name with tons of contacts in there.

 

Under Address Book, "On My Mac" (Local), I have checked the "Synchronize with Google" and have configured the settings to log into my google account.

 

I have waited for days, weeks, and still it doesn't sync anything into my Address Book.

 

What is going on?  Help!

 

Do I need to add a separte Exchange or LDAP account to Addressbook?

  • westynz Calculating status...
    Currently Being Moderated
    Feb 5, 2012 8:13 PM (in response to Richard Tse)

    Hi Richard,

     

    Are you using Little Snitch by any chance?

     

    If so, I had the same issue, and couldn't find a fix anywhere.

     

    I came to the conclusion that *something* must be stoping it, as come people are reporting this feature to be working.

     

    Allowing '/System/Library/PrivateFrameworks/GoogleContactSync.framework/Versions/A/Resou rces/gconsync' in Little Snitch seems to have fixed the issue for me.

     

    Hopefully this helps,

    James

  • jb0815 Calculating status...
    Currently Being Moderated
    Apr 20, 2012 2:06 AM (in response to westynz)

    Hi guys,

     

    I have a similiar problem. My address booked has synced correctly with google contacts since 2 years

    And suddenly it stopped syncing. Furthermore when I go to settings/acconts  I still find

    my "Local" account where i configured my google account, but now the right window is empty.

    There is no button to edit or show this account !!

     

    (I mentioned this after update to 10.6.8, but I'm not sure if it worked shortly before doing the update)

     

    What could be wrong ?

     

    Regards jb0815

  • theganga Calculating status...
    Currently Being Moderated
    Apr 28, 2012 6:52 AM (in response to jb0815)

    This worked for me:

     

    http://support.apple.com/kb/TS2481

    particularly restarting in safe mode then back again.

     

    Good luck

  • KAKershaw Calculating status...
    Currently Being Moderated
    May 30, 2012 8:56 AM (in response to Richard Tse)

    Hey Gang, I seem to have a similar problem. I have been trying to sync my Mac address book with google and each time I try, it does not sync all my contacts, There are a number of contacts missing (and not in alpabetical order as if it stopped somewhere during the process). This is important because I use an Andriod cell phone (Samsung Galaxy S2) and while the info on my MacBook Pro and iPad are correct, the cell phone is not showing the same info... HELP..

Actions

More Like This

  • Retrieving data ...

Bookmarked By (0)

Legend

  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.