Previous 1 2 Next 21 Replies Latest reply: Mar 13, 2013 7:24 PM by MichelPM
Canman Level 1 Level 1

Looks like this.



iMac, Mac OS X (10.5.4), 16GB Ram
Reply by Beige_00 on Feb 7, 2012 6:45 AM Helpful

Yes, or whatever OS came with the computer. I honestly don't think this will fix it, but if you've got a drive with the space, it won't cost you anything but time, and hey, software might be the problem. We can't say for sure that it's not software at this point.

All replies

  • Beige_00 Level 1 Level 1

    Canman, Is that a screen capture or did you draw those squares? I'm not sure if it matters, but it might.

  • Canman Level 1 Level 1

    Its a screen shot.  Seems to cover certain app windows.

  • Beige_00 Level 1 Level 1

    Hmmm. Have you run the test DVD that came with the iMac? I think you can download a Tech Tool disc image from Apple, and there's instructions on how to burn the DVD so it will boot the iMac and test it.

  • Canman Level 1 Level 1

    Its gotten very worse.  Apple says I'm out of luck and to bring to repair shop.  A $500 repair.

  • Beige_00 Level 1 Level 1

    I'm sorry to hear that. I was afraid it was a hardware issue.


    I guess you ran your serial number to see if you had an AppleCare agreement that you'd forgotten about? (A guy at work had a bad logic board on his almost three year old laptop, but he had put it under AppleCare--which he was sure he hadn't.) You can check it from Apple's website at If you click on the Apple icon in the top left corner of your screen and hit the button for more info, it launches a utility which (among a lot of other things) will tell you your machine's serial number, which you can then copy and paste into Apple's website (and it's on the label on the back of the stand-- and whomever you talked to from Apple probably already told you all that).

  • Canman Level 1 Level 1

    I have been doing lots of testing for this.  I don't have apple care so I want to make sure that I know its a hardware problem before I pay to have something replaced. (video card) for example.


    Movies Play fine, Games play fine.


    I ran the Apple hardware test with results saying there is no hardware problem.


    The squares of color come up randomly and can be erased by moving a window over top of them.  So if you have a floating window, you can drag it around the screen and the pixels disappear.  I call them pixels but they are bigger than a pixel.  The come in different colors and can show up any place on the screen.


    The only thing I can do to get them to show up is play a movie in preview mode from the icon.  So to recreate,


    Browse finder, click on the play icon within a movie.  The squares show up.


    If I launch the movie and play it full screen no problems.

  • Beige_00 Level 1 Level 1

    I don't know; that's somewhat subtle. If the problem is only showing up with one specific software package, I suppose it's possible that it's the software (or the preference file for the software package), but it looks like a hardware problem--especially since you said it was getting worse. What movie software are you using; I've never done a view in preview mode. Oh wait, I just did a "Quick Look."


    AHT didn't find the problem. Did you run the quick or the extended test? The extended test will take a long time (say 20 minutes or more, depending on how much RAM you have).


    Do you have another computer or rather do you have some extra RAM (of the same type, natch) that you could swap out? Or do you have an external drive you could boot from and see if you can reproduce the problem when booted from it? If you reproduce the problem when you've booted from another drive, then the problem isn't software.


    Likewise, if you trade out the RAM and that fixes it, then the problem was the RAM. I would try booting from a hard drive first then swap  out the RAM.

  • Canman Level 1 Level 1

    I did trade out the ram so that isn't the problem.


    I did run the extended test. twice.


    So your saying, install mac osx lion on a hard drive and boot from it? 

  • Beige_00 Level 1 Level 1

    Yes, or whatever OS came with the computer. I honestly don't think this will fix it, but if you've got a drive with the space, it won't cost you anything but time, and hey, software might be the problem. We can't say for sure that it's not software at this point.

  • Canman Level 1 Level 1

    Yes, I want to exhaust every possibility.  It could even be a loose cable or something.  The next step is open it up and have a look at the inside.  Maybe order video card and replace.  It looks hard but I think I am up for it.


    Thanks for your help!

  • Beige_00 Level 1 Level 1

    You're welcome. Go for it.

  • Canman Level 1 Level 1

    Tried to install leopard with restore disks.  No luck.  Seems after you install Lion they make it tricky to go back.  Tried a few things, boot from DVD, Boot from external drive etc.


    Now I am getting a kernal panic.  Didn't want to do this but I guess I have to open her up. 


    Here is the panic report, not much help.


    Interval Since Last Panic Report:  8895 sec

    Panics Since Last Report:          1

    Anonymous UUID:                    44F5CDCD-2CF3-4C0A-857B-5BC010D794CD


    Thu Feb  9 09:01:18 2012

    panic(cpu 2 caller 0xffffff80002c266d): Kernel trap at 0xffffff7f8188a267, type 13=general protection, registers:

    CR0: 0x000000008001003b, CR2: 0x000000011080d000, CR3: 0x000000002279e000, CR4: 0x0000000000000660

    RAX: 0x0000000000000000, RBX: 0x7fffffffffffffff, RCX: 0x000000000000001c, RDX: 0x0000000000000025

    RSP: 0xffffff80467bb9a0, RBP: 0xffffff80467bb9d0, RSI: 0x0000000000000000, RDI: 0xffffff800819ad80

    R8:  0x000000000000001c, R9:  0x7fffffffffffffff, R10: 0x0000000000000003, R11: 0xffffff80002d8220

    R12: 0x0000000067656f70, R13: 0xffffff80080bf800, R14: 0xffffff800819ad80, R15: 0x0000000000000000

    RFL: 0x0000000000010246, RIP: 0xffffff7f8188a267, CS:  0x0000000000000008, SS:  0x0000000000000010

    CR2: 0x000000011080d000, Error code: 0x0000000000000000, Faulting CPU: 0x2


    Backtrace (CPU 2), Frame : Return Address

    0xffffff80467bb660 : 0xffffff8000220702

    0xffffff80467bb6e0 : 0xffffff80002c266d

    0xffffff80467bb880 : 0xffffff80002d7a1d

    0xffffff80467bb8a0 : 0xffffff7f8188a267

    0xffffff80467bb9d0 : 0xffffff7f815bd4da

    0xffffff80467bbac0 : 0xffffff7f815a6c5d

    0xffffff80467bbb10 : 0xffffff7f8156810a

    0xffffff80467bbb40 : 0xffffff7f8156131f

    0xffffff80467bbb70 : 0xffffff80006528bd

    0xffffff80467bbbe0 : 0xffffff8000652c5c

    0xffffff80467bbc40 : 0xffffff800065341b

    0xffffff80467bbd80 : 0xffffff80002a3b78

    0xffffff80467bbe80 : 0xffffff8000223006

    0xffffff80467bbeb0 : 0xffffff8000214829

    0xffffff80467bbf10 : 0xffffff800021bb58

    0xffffff80467bbf70 : 0xffffff80002aeb80

    0xffffff80467bbfb0 : 0xffffff80002d8383

          Kernel Extensions in backtrace:

   [F4FEA23A-BEEF-313E-B4B8-0E2FB91BC0B9]@0xffffff7 f81548000->0xffffff7f817defff

                dependency:[F63D4ABE-42DA-33EF-BADD-3415B0CB0179]@0xffff ff7f80823000

                dependency:[4B3F84DC-18B3-3897-BC56-4E3940878047]@0xff ffff7f80c53000

                dependency:[FE536983-1897-3D6B-965E-24B5A67080DA]@0 xffffff7f80c1b000

   [3FEA7F49-3538-32EA-8319-B665CD87A8DC]@0xff ffff7f81882000->0xffffff7f81893fff

                dependency:[A87503EC-9C34-3613-9A86-7296B23BC344]@0xfffff f7f80ba3000

                dependency:[F63D4ABE-42DA-33EF-BADD-3415B0CB0179]@0xffff ff7f80823000

                dependency:[FE536983-1897-3D6B-965E-24B5A67080DA]@0 xffffff7f80c1b000

                dependency:[89B3F21E-C41D-34FD-B7F7-5F98DE677E1E]@0xffffff 7f813be000


    BSD process name corresponding to current thread: WindowServer


    Mac OS version:



    Kernel version:

    Darwin Kernel Version 11.3.0: Thu Jan 12 18:47:41 PST 2012; root:xnu-1699.24.23~1/RELEASE_X86_64

    Kernel UUID: 7B6546C7-70E8-3ED8-A6C3-C927E4D3D0D6

    System model name: iMac11,3 (Mac-F2238BAE)


    System uptime in nanoseconds: 68721051404

    last loaded kext at 14486039233:    1.9.4d0 (addr 0xffffff7f81ad8000, size 28672)

    loaded kexts:    1.9.4d0    3.0    3.5.9    1.0.26    122    1.59    7.1.8    2.1.7f9    2.1.7f9    7.1.8    1.0.2d2    100.12.42    1.0.0d1    7.0.0    1.2.2    4.7.5d4    3.0.16    1.5.3    170.1.9    312    3.0.1    1.0.0d1    1.0.0d1    33    3.0.3    2.0.1    4.8.9    4.5.0    502.60.2    1.5.0    2.2.0    3.0.8b2    4.5.8    4.4.5    1.4    1.4    1.6    1.7    1.4    1.5    167.3.0    3.2.30    1.1    167.3.0    152.3    152.3    4.0.3f12    1.0    2.1.7f9    2.1.7f9    1.0.10d0    7.1.8    7.1.8    80.0    4.0.3f12    10.0.5    2.2.4    1.0.0d22    2.1.7f9    2.1.7f9    1.8.6fc6    1.3    3.0.16    3.1.1d8    4.7.5d4    1.0.10d0    3.0.16    1.0.3    2.3.2    2.3.2    13    4.0.3f12    4.0.3f12    4.0.3f12    4.4.5    3.0.3    3.0.1    4.5.3    4.5.8    3.0.3    1.6    1.7    1.7    403    2.0.1    3.0.3    4.4.5    4.5.8    412.2    2.0.7    1.0.0d5    2.0    4.5.8    1.5.0    1.7.1    1.1    177.3    1.0.0d1    7    331.3    1.7    28.18    1.4    2.6.8    1.4

    Model: iMac11,3, BootROM IM112.0057.B00, 4 processors, Intel Core i7, 2.93 GHz, 2 GB, SMC 1.59f2

    Graphics: ATI Radeon HD 5750, ATI Radeon HD 5750, PCIe, 1024 MB

    Memory Module: BANK 1/DIMM0, 2 GB, DDR3, 1333 MHz, 0x80CE, 0x4D34373142353637334648302D4348392020

    AirPort: spairport_wireless_card_type_airport_extreme (0x168C, 0x8F), Atheros 9280:

    Bluetooth: Version 4.0.3f12, 2 service, 18 devices, 1 incoming serial ports

    Network Service: Wi-Fi, AirPort, en1

    Serial ATA Device: WDC WD1001FALS-40Y6A0, 1 TB

    Serial ATA Device: OPTIARC DVD RW AD-5680H

    Serial ATA Device: APPLE SSD TS256B, 251 GB

    USB Device: hub_device, 0x0424  (SMSC), 0x2514, 0xfa100000 / 2

    USB Device: Microsoft Optical Mouse with Tilt Wheel, 0x045e  (Microsoft Corporation), 0x00d1, 0xfa130000 / 5

    USB Device: BRCM2046 Hub, 0x0a5c  (Broadcom Corp.), 0x4500, 0xfa110000 / 4

    USB Device: Bluetooth USB Host Controller, apple_vendor_id, 0x8215, 0xfa111000 / 6

    USB Device: Internal Memory Card Reader, apple_vendor_id, 0x8403, 0xfa120000 / 3

    USB Device: hub_device, 0x0424  (SMSC), 0x2514, 0xfd100000 / 2

    USB Device: WD1600BB-59GUC0, 0x0c0b  (Dura Micro, Inc.), 0x5fab, 0xfd130000 / 5

    USB Device: Built-in iSight, apple_vendor_id, 0x8502, 0xfd110000 / 4

    USB Device: IR Receiver, apple_vendor_id, 0x8242, 0xfd120000 / 3

  • Beige_00 Level 1 Level 1

    Yeah, sometimes you gotta bite the bullet.

  • Lexiepex Level 6 Level 6
    Mac OS X

    Did you install apps like mackeeper, antivirus, antimalware or whatever crapware? There is a little chance that it may be that, but personally I think it is an hardwarefailure. Maybe a failing harddidk.

    Did you check temperatures (iStatPro widget), or have you looked in Activity Monitor to see what unknown process is running?

Previous 1 2 Next