Previous 1 2 3 Next 99 Replies Latest reply: Oct 27, 2015 7:25 PM by ChristineRCox
Kelsey12 Level 1 (0 points)

My iPhone 4 has been working perfectly up untill yesterday.

My iMessages stopped working from my phone number and started sending from my email address.

It says my phone number is waiting on activation


I have tried everything..

Resetting network settings

Turning iMessages on and off

Resetting my phone

Checked my phone number in settings>phone

Called apple who were as of no help


I have an iPad too I don't know if that has anything to do with it..

  • razmee209 Level 7 (30,346 points)

    look in this link and see if it helps out


  • azriel550 Level 1 (0 points)

    I have the same problem.  All I did was turn iMessage off and then back on and now it fails to verify the phone number.  Still works off of the email address in my apple id but that's not good enough.  It's was working fine since the day iOS 5 was released.


    I've read countless forums and tried a thousand things but nothing seems to solve this problem.  Here's a list of the things I've tried:


    • Checked Settings > Phone > My Number and changed it from having the + country code to without and back
    • Reset Network Settings
    • Reset All Settings
    • Ensured Date and Time is set to auto
    • Ensured that Settings > Mail, Contacts & Calendars > My Info points to my card (and have deleted the card completely and re-added it)
    • Ensured my card in contacts has my phone number under the iPhone category
    • Restored the OS entirely and recovered from a backup
    • Added, to the DNS settings of my wifi connection
    • Tried activate via 3G instead of wifi
    • Removed sim card, inserted and rebooted
    • Rebooted a thousand times
    • Toggled all options under Settings > Messages back and forth, several times (including signing in and out of apple id)
    • Removed and added my phone number to my Apple Id account via web interface
    • Changed my Apple ID password
    • Tried disabling and re-enabling FaceTime (which doesn't seem to authorise now either)


    And there are probably more things I've tried than this that don't come to mind right now.


    My last resort was to walk into the store I bought the phone from where they said "er....... what er..... yeah probably an apple problem just er.... wait for a patch" without even attempting to offer any kind of troubleshooting advice whatsoever.  There is no Apple store in my city either so no genius bar to go to.


    HELP!  Apple? Anyone?

  • Defiled Level 2 (385 points)

    You stated restored the OS entirely and recovered from a backup.


    Have you tried Restoring the device and setting up as new, not restoring from a backup?

  • azriel550 Level 1 (0 points)

    No I haven't.  I was really hoping that I wouldn't have to do that as it's a real pain to have to go though and tweak everything the way I want it. 


    It's seeming increasingly likely that I will have to do that but I wanted to make sure I'd exhausted every other option first because if that doesn't work, then I'll have to waste even more time setting everything back up.


    It puzzles me to no end why and how this happened in the first place and was hopeful Apple may have another solution.

  • Defiled Level 2 (385 points)

    Have you tried toggleing auto date and time off and on?

  • azriel550 Level 1 (0 points)

    Yes. Several times.


    I appreciate your suggestions though.

  • Kelsey12 Level 1 (0 points)

    Thanks for all the suggestions guys I've tried them all previously, I haven't restored as new I also was hoping it wouldn't come to that it's such a painfull process. I'm thinking of going into my genius bar tomorrow but I'm already thinking they won't be able to help.

    Mine also suddenly stopped working due to just switching it off.

    Could it be a Carrier issue ? I'm with telstra. I would say that's unlikely to be the problem though.

    So frustrating..

  • azriel550 Level 1 (0 points)



    Funny you mention that, I'm with Telstra too!  My sister (who's with Vodafone) had the same problem after going overseas and once we fixed her Settings > Phone > My Number entry (which had changed to an overseas number), it activated right away!


    I have read a number of posts that say that the activation process is handled behind the scenes by sending a text message to the carrier which then responds but I don't know if that's actually what happens or if it only happens with certain carriers.  To test this theory I went to two Telstra shops this morning.  Both were useless and didn't take any interest in the problem, although the second said that I wasn't the first customer to come in with the problem today.


    I'm in Adelaide so no Genius bar to go to.  Please let us know how you go!

  • Kelsey12 Level 1 (0 points)

    Well that's Interesting because my brother is also having the same problem and is with Telstra.

    I seen a discussion yesterday which the girl was ith telstra too. I live in Melbourne so I'll try and get to a genius bar in the morning sometime. Hopefully they don't just tell me to restore!

    In the end it's no big problem because it still works from my email but it just annoys me haha


    I will let you know how I go

  • I3lue Level 1 (0 points)

    I'm with Telstra too!

    I switched mine off yesterday and only just thought to turn it back on, and no matter what I try, it just WILL NOT come back on, and it is frustrating me like you wouldn't believe.

  • Kelsey12 Level 1 (0 points)

    Very interesting

    I Wonder if its worth Calling telstra

  • I3lue Level 1 (0 points)

    I'd say so, I'm about ready to rip out an abusive call to either apple support or Telstra.


    Neither of them are any help with any other problems with ANYTHING I've needed.

    So if they're unable to help with this, all sorts of things are going to hit the fan lol.

  • Kelsey12 Level 1 (0 points)

    Yeah it's rediculous none of them can help!

    It's been frustrating me for two days

  • Antman1984 Level 1 (0 points)

    I'm having this exact issue...


    Was running an iPhone 3GS with iOS 5.0.1 and iMessages were working fine.


    Two days ago bought a second hand iPhone 4 from a friend. Did a full factory reset on it so I could start with a clean phone.


    Cannot get iMessages to work... it sits there saying "Waiting for Activation"


    It will work via my Apple ID, but not my phone number.


    I've tried everything listed in this thread plus a few things I found on google not listed here.


    Rang Apple Support and they talked me through a number of things to try... after a 45 min call they escallated me and that person said "the iMessage server is down at the moment".

    Um, really? Wouldn't they have known about that sooner?

    Why would it still work for a friend who already has iMessages set up under his phone number, yet I cannot "activate" my number with iMessage?




    For what it's worth, I'm with Telstra in Adelaide, SA.

Previous 1 2 3 Next