12 Replies Latest reply: Aug 14, 2013 11:55 AM by Tzipora Ne'eman
billjhart Level 1 Level 1

When I place my mac pro in sleep (or it goes to sleep by time out) I have lost my internet connection when I reactivate.  Merely restarting Safari will not acquire the internet.  I have to restart the computer.  Anyone know how to fix this?

Mac Pro, Mac OS X (10.7.2)
  • John Galt Level 8 Level 8

    There have been many many problems reported with this. Try updating to 10.7.3 - it's in Software Update.


    Read this first: About the OS X Lion v10.7.3 Update

  • billjhart Level 1 Level 1

    John, thanks.   Just downloaded and installed 10.7.3 and put computer to sleep with Safari (now 5.1.3) and Mail running.  When I awakened the computer I had no internet for either, Closed Safari, had to force quit Mail and then restarted each....still no internet for either.  Had to restart the computer to regain internet.  As I think about this seems as though it started about 11/2 months ago when I migrated to iCloud.....I had upgraded to Lion a number of months before that but didn't go to iCloud initially.  Wonder if all of this is some how related to iCloud?

  • sylvie2 Level 1 Level 1

    I have the same loss of internet both before the 10.7.3 update and after. It was supposed to fix this. But I want to suggest that you don't have to go through the trouble of restarting your computer. If it is on a wireless connection, you can turn wifi off from the menu bar and turn it on again. That has restored the connection, again both before this update and after.


    Also, I have not done anything with iCloud, so it's not that that is the problem.

  • John Galt Level 8 Level 8

    That is disappointing.


    Here are some things to try.


    1. Go to System Preferences > Network, and click the gear icon under the network interfaces like so:


    Screen Shot 2012-02-02 at 1.14.31 AM.png

    Whatever service order you have set, drag Wi-Fi either to the top (assuming it's not already there) or someplace else in the list. Click OK and then Apply. Sleep the system then wake it again to observe any changes.


    2. Click Wi-Fi in the above then click Advanced. Select all the networks your computer has ever joined and delete them with the "-" button. OK then Apply again. Select your network under the AirPort icon to re-join it. Sleep and wake again to see if that did anything.


    3. Try creating a new, temporary user account. Log in under that account to see if its behavior is any different.


    You may have done all of these already but perhaps there is something you have not thought of. If nothing helps we may just have to wait a bit longer for Apple to release a fix.


    I doubt iCloud has anything to do with it. iCloud is just another service like Safari or anything else that wants to connect to the Internet. The computer either connects or it doesn't.


    As Sylvie wrote a restart is not necessary - cycle the AirPort power or simply select your network again.

  • RJRandalls Level 1 Level 1

    OK. The last post helped a lot!

    By putting my own home router at the top of the list (see above), and also by closing wifi then restarting wifi on the little icon upper right of screen, I was able to solve the problem.


    Of note, it still took the computer a little bit (about 45 seconds) to re-establish internet connection. Not much faster than restarting the computer altogether.



  • Tzipora Ne'eman Level 1 Level 1

    John, I just tried all this.  No help.   I'm waiting, waiting for Apple to fix this problem... sigh.



  • Tzipora Ne'eman Level 1 Level 1

    I've just learned from my Mac listserve here where I live that the loss of internet is a feature of Lion and not an error.  I'm told that the blogosphere is complaining a lot and so, Apple, if you're reading these posts, please put back our connections the way they were!


    It was good to be able to close the screen on my MBP and open and still be connected or that when I walked away from the computer and it went to sleep I could press any key to wake it and my connection was still there.





  • Tzipora Ne'eman Level 1 Level 1

    I'm responding to my own note from December 2012.   I was still losing my wi fi connection everytime my computer goes to sleep.  Annoying to say the least when I walked away for a bit from my computer.  Or stopped working on it for a period of time.


    I went into preferences > energy saver >power adapter and battery and changed 'computer sleep' to one hour.  I suppose one could put it to 'never'.  Unchecked 'put hard disks to sleep when possible.


    Only solution so far.  Not the best.


    Still hoping Apple will do a 'fix' on this...



  • chie@ashop Level 1 Level 1

    yeah right..

  • chie@ashop Level 1 Level 1

    power nap :D

  • Tzipora Ne'eman Level 1 Level 1

    Sorry, I'm missing the point of this note, Chie.

  • Tzipora Ne'eman Level 1 Level 1

    I tried something else and it worked !  Went into system prefs>network>chose my network name> unchecked 'ask to join new networks'.


    It worked.   My network stays on when I put computer to sleep or it goes to sleep on own.


    That simple.




    I hope others find this works for them.