Previous 1 2 3 Next 37 Replies Latest reply: Jun 20, 2013 8:59 AM by YUZA-Tom Go to original post
  • edljedi Level 1 Level 1 (0 points)



    Reading the kb linked to above has the following line:


    PPTP can only be used if you are managing network users or users connected to a directory server. Local user accounts can only be used with LT2P.

  • Adam U. Level 1 Level 1 (0 points)

    My VPN L2TP connections also stopped working after 10.7.3 update. I kept getting "DSAuth plugin: Failed to retrieve MPPE encryption keys from the password server: errno -14484, ctxt 4" whenever I tried connecting. But I resolved the issue now by following the instructions in for all OD users INCLUDING the new "VPN MPPE Key Access User" (find that user's short name in workgroup manager and use the command line to set the new policy). It appears this tech note is applicable even if you're not using PP2P. Hope this helps others experiencing this same annoying error.

  • elgringito Level 1 Level 1 (20 points)



    I had the same problem as most people here, namely, I could not connect to my 10.7.3 Lion server using the credentials of a network account. I could connect using the credentials of a local account though. Typing the following line solved my problem:


    sudo pwpolicy -a (diradmin) -u (vpn_idname) -setpolicy "isSessionKeyAgent=1"


    (with the correct diradmin and vpn_idname, which can be found as indicated here: And yes, this is not limited to PPTP, it works with L2TP too. Thanks dacary !

  • Spammerboy Level 1 Level 1 (0 points)

    Yep, worked for me too. Thanks.

  • James Rothschild Level 1 Level 1 (55 points)

    Well, I have done all the above and I still get:


              "The L2TP-VPN server did not respond.

               Try reconnecting. If the problem continues, verify your settings and contact

               your Administrator."


    I have all my portforwarding on my Netgear FVS366Gv2 setup perfectly as per known working solutions for OSX 10.6.latest Servers.


    How has Mac become so terribley difficult and troublesome with 10.7.

    I have a reasonable 20 year knowledge base on all systems up to 10.7 and now it's pants :-(

    I'm not a UNIX geek, that's not what Mac is about IMO.


    OSX Server 10.7.3 w L2TP-VPN setup

    OSX Client 10.7.3 connects to other PPTP and L2TP based OSX 10.6 servers fine

    Netgear FVS366Gv2



  • James Rothschild Level 1 Level 1 (55 points)

    Well, isn't always the case !, grump away on the list, Panic, then fix it :-)


    I did what worked for everyone above.

    Had my issues...

    Then retraced all my steps umpteen times...

    Turns out the sharedsecret was not matching.


    #forgiveness Yay! :-)

  • jpatdtsl Level 1 Level 1 (0 points)

    I had to re-create the OD for PPTP - lucky for me I did not have to many network users only a handfull.

  • YUZA-Tom Level 1 Level 1 (0 points)

    I believe I have a fix for this solution here:

Previous 1 2 3 Next