Skip navigation

after Security update 2012-001 cannot save any Office 2004 file

12639 Views 95 Replies Latest reply: Mar 29, 2012 9:08 AM by cathy fasano RSS
  • Chriz555 Calculating status...

    SOLUTION: Here's the folder (Framework) to restore to get it working again (From a TM or a previous Backup):


    /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/I mageIO.framework/


    Solved my problem with AppleWorks, at least.



  • nydiscussion Calculating status...

    Yeh...don't know what this guy did but this works...I'm glad I went on here before bothering to go through downloading rosetta off of my original disks because if that didn't work I'd have freaked out...he says it's a "bandaid" until apple has a permanent fix but all I know is it restores my office 2004 for now and addresses the issue which he says is how the update works with rosetta

  • nydiscussion Level 1 Level 1 (0 points)

    Thought I put this in but the developer's apple name is J. Morris and he's in Nebraska and he said his team came up with the rosetta fix after apple developers had no answer today...that fast.

  • Flying Writer Calculating status...

    Installed the rosetta fix and it did absolute zilch for me.


    Office 2004 is still deader than Al Gore's marriage.


    My blood pressure is going up and I just called the Apple Store and unloaded on the guy. Told him to call the SOBs in charge and advise them that millions of Apple users are fixing to get real whizzed, real fast.

  • Al Cellier Level 2 Level 2 (205 points)

    SOLUTION: Here's the folder (Framework) to restore to get it working again (From a TM or a previous Backup):

    /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/I mageIO.framework/

    ...  had an extra space in the final folder name ...

    This seems to be the same fix posted by the Nebraska folks.

    But strangely, the folder and contents look identical here in my re-installed system, and in a copy saved that was "updated".

  • J.Morris Calculating status...

    @Flying Writer


    What kind of problem are you still seeing?

  • Flying Writer Level 1 Level 1 (0 points)



    Same problem as after the (bad) security update--MS Office 2004 problems. Word will not open through the application, will not print, nor will Excel or any of the MS Office applications. You can "save" in some Excel documents, but not all. You can't save in PowerPoint and can't save in Word.


    I downloaded and installed your fix, then re-booted. No joy. Repeated. No joy.


    But again, your efforts are hugely appreciated!

  • J.Morris Level 1 Level 1 (20 points)

    I uploaded a new installer. One that was built with Package Maker. If you could re-visit and download I would appreciate your feedback with that package installer.

  • Flying Writer Level 1 Level 1 (0 points)



    Will do. Be back in a moment.

  • Flying Writer Level 1 Level 1 (0 points)

    @ J. Morris,


    Deleted the original installer and package. Revisited the/your site and downloaded the package. Installed, re-booted, fired up MS Office/Word.


    No joy. Same stuff. Crashes when attempting to print, can't save as, etc.


    I'm whizzed at Apple beyond comprehension.


    Thanks for the effor and suggestion, though. You're doing a helluva lot more than Apple is.


    Got to be hard for them to sit comfortably with their thumbs up their collective rears.

  • J.Morris Level 1 Level 1 (20 points)

    Is your office updated to the latest version? That's the only thing that I could think of that would be different from the version that I used to test. I used the latest Office 2004 version on my testing machine.

  • theo23 Calculating status...

    I too tried your update and it didn't work. I have the latest version of Office 2004, I checked on that last night when I started having these problems.  I'm having the same problems as everyone else, cannot save or in fact use any command and if I try I have to force quit to get out of it.  It's the same on Excel and Word.   I'm still wondering if this isn't Apple's way of getting us to give up our Rosetta software so we can all drink the Kool-Aid that is Lion. 

  • Delox Calculating status...

    THIS WORKED!!!!!


    /System/Library/Frameworks/ApplicationServices.framework/Versions/A/Frameworks/I mageIO.framework/


    Solved my problem with AppleWorks, at least.



  • ds store Level 7 Level 7 (30,305 points)
    • All you have to do is clean and polish up the 10.6 install disk and reboot holding the c key down


    • Second screen simply reinstall 10.6 and reboot, then when you Software Update, do NOT apply that problematic security update.


    • What this will do is replace OS X itself, not your files (but backup off the machine anyway)





    Most programs will still work just like before, unless they installed kext files into OS X (only a few do this), which all you do is simply reinstall just them from original sources and update for 10.6.8


    If by chance you reboot and you get a gray screen, that's the incompatible kext files with 10.6.8 update (a known issue), all you do is hold the Shift Key down while booting for Safe Boot (no kext files) and update those programs to work with 10.6.8.


    No need to wait as Apple is not going to fix your issue with a update, they are going to recommend you do what I'm already recommending.



    Also a hack that hasn't been widely tested isn't a solution neither, it's because Apple didn't test this security update on a large enough amount of willing users is why it's all messed up your machines.


    The sooner you start the above process, the sooner your back to normal.

  • Flying Writer Level 1 Level 1 (0 points)

    Mr. Morris,


    Yes, I have all the latest updates for MS Office 2004. I'm not too keen on 2008 and even less so on 2011, so have been "holding on" to 2004 as long as possible. Was doing just fine until Apple's boneheaded release.


    Have pretty much tried every trick in the book, but no joy. Cannot find the original 10.6 install disks--may be at our second location. I have Time Machine and a Time Capsule, but do not back up the System or Applications.


    Worst case scenario, I'll buy a (used) version of Snow Leopard and re-install.


    Again, your help is very much appreciated.

1 2 3 4 5 ... 7 Previous Next


More Like This

  • Retrieving data ...

Bookmarked By (3)


  • This solved my question - 10 points
  • This helped me - 5 points
This site contains user submitted content, comments and opinions and is for informational purposes only. Apple disclaims any and all liability for the acts, omissions and conduct of any third parties in connection with or related to your use of the site. All postings and use of the content on this site are subject to the Apple Support Communities Terms of Use.