4 Replies Latest reply: Mar 16, 2012 9:47 AM by John Ashley1
Jonah Lee Walker Level 3 (565 points)

I am trying to make a purchase from the App Store in Snow Leopard 10.6.8, but can't make any purchases. When I try to purchase, I get the message, "Additional security information is needed. To use this Apple ID you must first login to the my info web page then provide additional security information." But when I click on Update Security Info, it brings me to a page at https://myinfo.apple.com/ but the page will not load, and it says that Safari can't establish a secure connection to the server. I have also tried it in Firefox and it does not work there either.

 

I went to the Apple Store online, and updated my account info with the proper credit card and information, but it has not helped. What is going on here.

 

This is for my bosses account and not my account, and we need to purchase some software for this machine, but are completely unable.

 

Any help would be appreciated.

  • Carolyn Samit Level 10 (103,365 points)

    and it says that Safari can't establish a secure connection to the server. I have also tried it in Firefox and it does not work there either.

     

    If there is anti virus software installed, disable that and turn off the Firewall in System Preferences > Security.

  • John Ashley1 Level 1 (5 points)

    I'm having the same issue.  We have recently signed up for the Volume Purchase Program.  I created the Facilitator account, logged into the VPP site, then got a message that additional information was needed. more-info-needed.jpg

    When I click the link to "Update Security Info", I get an error page on the browser...safarierror.jpg

    I have tried the same process in Firefox and received a similar message...firefoxerror.jpg

    I then proceeded to try the same thing on a Windows 7 computer with Internet Explorer, no good...

    Next, I thought the problem might be related to my firewall, so, I attempted it on a computer OUTSIDE the firewall, no good.

    Then, I tried it from home on my ipad, no good...

     

    Anyone have any ideas?

  • Jonah Lee Walker Level 3 (565 points)

    Try taking the s out of the https in the URL it gives you. That finally worked for me.

  • John Ashley1 Level 1 (5 points)

    Thanks Jonah, that seemed to work for me as well.