Previous 1 2 Next 16 Replies Latest reply: Jul 28, 2012 10:53 AM by Khourshed
Lionhaterfromwa Level 1 (0 points)

I am a professional presenter and rely heavily on Keynote.  I purchased a new Macbook pro (and RUE THE DAY).  Lion has caused me endless problems.  I have just come off holiday and try to give a presentation using keynote (09) and lo and behold

KEYNOTE cannot be opened because of a problem  ...bla bla, check with developer to make sure keynote works with this version..bla bla...  be sure to install any available updates bla bla.


I'm running Lion 10.7.2.  I reinstalled IWORK 09 with the keynote upgrade patch from Apple.  No progress.  I am frantic.  Any help available??

MacBook Pro, iOS 5.0.1
  • dwb Level 7 (22,625 points)

    Lots of us are using iWork 09 and Lion so the problem is with your installation. Probably the best solution is to delete iWork and reinstall it - this will be easier than jumping from one folder to another looking for files to delete. Here's an AppleScript from Yvan Koenig, an iWork guru, which will totally delete every trace of the iWork installation (except your personal files).  Look for the iWork09 file and use the uninstall zip. After reinstalling your problems should be over.

  • Lionhaterfromwa Level 1 (0 points)

    You are the MACMASTER.  Thanks for that advice, It did work and I was obviously flipping out, having had a rush of blood to the head.  Once I followed your instructions.... all was well.


    thank you cybergenius.

  • cloudfe Level 1 (0 points)

    Hello dwb,

    I followed your instructions, but I keep having the same problem ("An unexpected error has occurred.

    Please quit and reopen Keynote." after a right-click).

    Is there something else I can try?

  • dwb Level 7 (22,625 points)

    You ran the uninstaller from Yvan. You then reinstalled iWork (you didn't drag it from another location or use TimeMachine). Keynote was working before you upgraded to Lion. Are these statements all correct?

  • cloudfe Level 1 (0 points)

    I cannot be 100% sure Keynote was working before Lion (I didn't use it for a long time), but most probably it was.

    Yes, all the statements are correct.

  • dwb Level 7 (22,625 points)

    The only other thing I can think of is that you have one or more 3rd party templates that Keynote doesn't like. Look in your Application Support folder (~/Library/Application Support) for a folder called iWork and open it. If there is a folder inside called Keynote, move it out - put it in your Downloads folder for example. Also look in the main Library for the same thing. Then restart Keynote.

  • cloudfe Level 1 (0 points)

    I have checked, and I have nothing of sort.

    Before asking here, I googled it a lot, and it seems I'm not the only one. Most of the things I read were Lion-related, but I also found a post where the same problem appeared in Snow Leopard.

  • dwb Level 7 (22,625 points)

    Create a new user account (System Preferences>User & Groups tab) and log into it. See if Keynote crashes there. That will let you know if the problem is local to your account or not. I'm betting it is.

  • cloudfe Level 1 (0 points)

    Just did the test: same error.

  • ricky* Level 1 (0 points)

    Just came back to check if the problems with large files in Keynote (iWork 09) and Lion have been solved through the upgrade to Keynote 5.1.1 released on Dec. 01. 2011??


    But it looks like that is not case??? Do you still encounter the spinning wheel after upgrading to Vers. 5.1.1.??


    Does you see any improvements after upgrading to Lion Combo Version 10.7.3??


    This is really embarrassing for Apple not being able to solve this issue which seems to be related to the autosave option of Lion.


    For all of you who need to work with Keynote, I recommend to completeley uninstall the new 5.1 Version and to reinstall with all upgrades up to Vers. 5.0.5 ! This is the one that works best

  • ricky* Level 1 (0 points)

    By the way this thread might help



    as you can see Apple was not able to solve the problem???


    Best you stay with Vers. 5.0.5 (and ask your money back from apple - we paid for that sowftware - remember?

  • splate Level 1 (0 points)

    I'm having same probs with Keynote not working after upgrading to Lion. Going to uninstall keynote. But how do i "reinstall"? Where do i get the program from?

  • ricky* Level 1 (0 points)

    Dear Splate


    we all had this problem with Keynote and large files and Apple is not capable of solving it (since the last 2 years???) just unbelivable!!


    Here I get you the helpfull thread thanks' to Fuzzydog. This worked for me!


    I have found only one solution and it only works for those of us who have a iwork disk to reinstall from. Those who downloaded from the app store are I think out of luck unless they managed to save the downloaded .dmg somehow.


    I have downgraded iwork from 9.1 to 9.05 and have had no problems in keynote since then!!!


    Here is how to do it.


    1. Remove iwork 9.1 using the script supplied by Yvan Koenig. See this post in a pages discussion with the location of the file. If this link doesn't work go to the iwork discussions and search for his name and "remove". It will get you to a post of his with the link to the script. If you do a manual uninstall you have to do more than simply remove the iwork folder from applications. Try using easyfind to locate all iwork files. There are many spread throughout your system. Make sure that the following folder is uninstalled before you reinstall the earlier version as a reinstall of an earlier version will not overwrite them. ~/library/application Spport/iwork '09/Frameworks.


    2. Reinstall iwork from your disk.


    3. Update iwork to version 5.05. You can get this here.


    4. When you restart iwork check the version number to make sure that it has been successful. If you reinstalled without a successful total removal it will still show version 5.1. The script mentioned in #1 above does not remove your personal templates stored in your user/library/application support/iworks folder.


    5. The first time you open an iwork app it will ask you to upgrade to 9.1. Do not do this and check the box indicating not to be reminded again.


    The fact that 5.05 works flawlessly under Lion proves that version 5.1 which has the offending autosave features for Lion is the cause of the problem. 5.05 works great in Lion. No issues. Manual saves like the old days. No spinning ball down time (except on command S saves which still take a long time but that is the same as it ever was for big files with lots of media).

  • joanmcarthur Level 1 (0 points)

    Actually using your link for the Key Note uninstall gets me to a website that says (in HUGE letters) MOBILE ME...and has a sign-in box.

    I am using Chrome, would Safari be better ( it is Apple's browser isn't it)?


    Thanks - this is so frustrating, hard to believe that Apple won't address a front and center issue like this, created by their own products!

Previous 1 2 Next