14 Replies Latest reply: Apr 10, 2013 7:23 PM by MulliganStew68
hamsammich75 Level 1 (0 points)

Disclaimer: I have searched for answers to my particular problem, but either a) the problems aren't the same or b) there's still no answer to problems that are even remotely similar.


I have an iPhone 4s that I sync via iCloud and/or with my MacBook Air, and all devices have the latest software updates. Here's the problem: just yesterday, my iPhone lost the ability to update apps. I'll go to the App Store on my device to check for updates and see one or two or however many...I'll hit the update button, enter my password, and then the app icons turn grey like normal, with the empty progress bar underneath. The problem, however, is that nothing happens past that. The icons remain greyed out, with an empty progress bar underneath and the apps never update.


I've tried updating over different WiFi networks as well as over 3G, yet nothing works. I can update the apps on my MacBook Air, but it doesn't even work when I plug my device directly into the Air. The same apps still need updating on my iPhone. I've tried resetting my iPhone via the normal two methods, and the problem still persists. And additionally, my iPhone keeps randomly popping up the iTunes password box on my screen. This usually happens at some point after I've attempted to update an app, gotten frustrated because it won't update, and then reset my phone.


Any help would be much appreciated.

iPhone 4S, iOS 5.0.1
  • tsjordan2899 Level 1 (0 points)

    I am having this same problem. I tried installing a new app and that did not work either.

  • diane140 Level 1 (0 points)

    I had the same problem on Iphone 4 - finally thought of the old PC fix for everything - reboot! Turned it off and on - finally prompted me for password and got rid of the update flag. You probably thought of this...its my first Apple product. :-)

  • unclefungus Level 1 (0 points)

    First, delete the apps from the iPhone.  Next, check for updates through iTunes on your Mac and download the updates there.  Then, sync your iPhone again.  The updated apps will transfer, and the badge will disappear from the App Store app.


    Alternately, you can just delete the apps from the iPhone and sync to your Mac again without updating them though iTunes.  This will put the unupdated apps back on the iPhone where they should now successfully update through the App Store app.

  • hunnerbun Level 1 (0 points)

    I have a 4s and have tried all the above suggestions and nothing worked for me.  I don't have a Mac  but that doesn't matter.  I tried plugging in and syncing through I tunes, I deleted and tried reinstalling the apps but nothing changes.  I even went so far as to wipe the phone and restore to a previous backup.  It seemed like it worked until I checked the app store and there were 2 updates.  Same thing happened, it tries to get them but the icons just turn grey and say waiting.

    I am at my wits end.  My b/f has a iPhone 4 and his is fine.  Is this a 4s only thing?

  • HisMah75 Level 1 (0 points)

    I have the exact same issues, with no resolutions, regardless of all the different things I have tried. Software updated to OS5.1, etc, nothing changes the problem. Frustrating!!

  • tsjordan2899 Level 1 (0 points)

    After several failed attempts to fix the problem I took my iPhone 4S to the genius bar. The "genius" messed around with it for a bit and decided that it needed to be restored. He plugged it up restored it and everything was working great after that. So plug your phone up to iTunes and restore it

  • HisMah75 Level 1 (0 points)

    Thanks tsjordan2899!


    You saved me a trip to the Genius Bar. But most importantly, my probably is now solved.


    I did a RESTORE as suggested and everything is working fine and back to normal!!


    Thanks heaps! 

  • Kirk1962 Level 1 (0 points)

    Ok, this is what the problem is.  At some point, you attempted to download an app or apps and they got hung up for some reason and didn't install properly.  Your phone thinks that they are installed and want's you to update them, but it can't because they really aren't installed.  Look though all of your apps and see which ones haven't downloaded to your device.  Write down the names of what apps they are and then delete them from your phone.  Once you have deleted them, re install them one at a time and you should be good to go.

  • phmann Level 1 (0 points)

    I was having the same problem with the Starwalk update.  Try deleting the app form your iphone and then go to the App Store on your iphone and select Updates, then Purchased, then All.  Scroll down to the app you are wanting to update and select it.  If you have synced to iCloud you will be able to recover it from there.  It worked for me.

  • ihate_apple Level 1 (0 points)

    Same problem on my iphone 4s however can resolve the probem by synchronize iphone with iTune.

    I am posting this reply to ask what the devil is going on on this issue.

    Updating the app on iphone is core function and it has some problem.  what the **** are they doing at Apple?


    Too busy responding the cahrge of slave labor camp at Foxcon?

    Same on Apple!


    From my exeperience onsoftware quality assurance, this is critical issue or bug. Needs to be resolved at once!

    Samung being no. 1 samrtphone shipping on 1Q of 2012, what will Aple do about that with all these quality issues?   

  • Lucassiciliano Level 1 (0 points)


    Theory from my experience- typically I update apps individually-

    I had at least 6 to update and decided to tap update all

    Doing so I am experiencing the common theme dilemma-

    Intriguing thing is I have update all multiple apps

    At once another time prior to this and it didn't happen so not sure if

    theory is correct-

  • farl Level 1 (0 points)

    Same problem here. But when I update again with iTunes. The problem seems to be fixed!

  • johnsonfrombellevue Level 1 (0 points)

    I had the same problem on my 4g. I think it happened when I was trying to update where my service was pretty weak. I read all the answers and none of them worked. Then, basically by accident, I selected one of the stall apps ...not in the apps app or on  my computer...just on my phone. The app started to download, then gave me an error message that it couldn't download, and then the icon just went to "normal status" (no bar showing install progress). Once I had done this will all the stalled applications, I went into the apps app and downloaded all and I was back up and running! I hope this works for you too!

  • MulliganStew68 Level 1 (0 points)

    Installed IOS 6.1.3 last night and to do so, had to make space on the phone as it was near full.


    After that, it took a dirt nap.


    I have the 4S and experienced  the same "problem" documented all over these message boards. Frustrated after trying all the fixes, including a hard reboots, resets of settings, deleting apps, reinstalling apps, new apps, synching ... everything that made sense.


    Finally, frustrated and wishing I owned something other than an Apple product at this moment, I decided to go back to what I did to "free up" space -- once I fixed this, the apps stopped "waiting" and started updating.


    The issue was in iTunes where I had selected on my phone's settings (to be clear, this is under "Apps" in iTunes), and DESLECTED "Automatically Fill Free Space with Songs."


    Solution/Issue: my guess is that the updates were spooling because there wasn't enough space to run the sync.


    Thank you Apple -- for NOTHING. A simple error message "Not enough space" would have been brilliant.