13 Replies Latest reply: Feb 18, 2014 10:35 PM by soumikdutta
paulgummo Level 1 Level 1 (0 points)

I have both an iPad2 and an iPhone 4s.  My iPad NEVER looses connection to the Wi-Fi, but my iPhone looses connectivty everytime it goes to sleep.  They appear to be setup the same way (use the same SSID, same security, same users name, same password)

 

help please.


iPhone 4S, iOS 5.0.1
  • paulcb Level 6 Level 6 (19,095 points)

    If the iPhone is not connected to power, wifi will disconnect when the phone sleeps but it should automatically reconnect when you wake it.  Is this what you experience or does it stay disconnected after waking?

     

    If connected to power, wifi should stay connected when the phone sleeps.  That being said, apps using wifi may also sleep when the phone does.

  • paulgummo Level 1 Level 1 (0 points)

    The iPhone will not automatically restore the connection.  The iPad will.

  • ArthurGaudio Level 1 Level 1 (0 points)

    I had a problem with this some time ago. The iphone would just stop working on WIFI. Then after monitoring my router, I noticed that my iPhone was waking up and trying to reuse the address it had previously but that the same address had meanwhile been leased by our laptop. So there was a conflict. My solution was simply to hard code the IP address of the iPhone in the upper range of the IP range. In other words, since all my other devices at home have IP numbers ending around 10 or 20, I hard coded the iPhone's IP in the iPhone WIFI settings to 201.

  • paulcb Level 6 Level 6 (19,095 points)
  • ttyers Level 1 Level 1 (0 points)

    did you ever find an answer to this?  i can not get a resolution to this. the apple store has no clue except to reset the network settings (to no avail of course).

  • paulcb Level 6 Level 6 (19,095 points)

    This is old but may be helpful... http://www.madbot.org/?p=189

  • ttyers Level 1 Level 1 (0 points)

    Thanks.  I already had tried that fix.  No good on my 4s.

  • paulcb Level 6 Level 6 (19,095 points)

    If it's a 4S, then it's still under warranty.

  • Coppertiger Level 2 Level 2 (490 points)

    Settings\Wifi... is Ask to Join Networks option, on or off?

    regards, Ct

  • ttyers Level 1 Level 1 (0 points)

    yes, it's under warranty.  on my 3rd phone in a week.  seems they would rather hand out phones than actually solve an issue!  I thought the people in the Apple store knew the products.  The last two guys that tried to help me told me thaey didn't own an iphone.

  • essentiae Level 1 Level 1 (0 points)

    The iPad 3/"new iPad" is having similar problems. Poke around the forums and you'll find evidence of major wifi problems on both of the new devices.

  • maryanntherese Level 1 Level 1 (0 points)

    The solution by ArthurGaudio solved our problems. Thank you! I hard-coded a static ip address for my home wifi. Solved the problem on both of our iphone 4s's. We now have 5 idevices on our wifi, and for some reason when the 4s tries to reacquire the wifi on wake, it defaults to the last ip address. If another device has since taken that address, it reverts to 4G. This only happens with the 4s phones, not the two 3gs or the original iPad. Hope Apple will fix this with a firmware update.

  • soumikdutta Level 1 Level 1 (0 points)

    well there, i have too faced the similar problem in my family everyones fot iphone 5 and 4, but myself have 4s. so its only me that was facing the problem of dropping wifi when locked or sleep. all the devices are either OTA or itunes updated to the latest IOS software. so i tried all the means but none worked but recently i went to Apple community and read out some articles about setting wifi connection. well now i tried to change the ssid of my network from the default ssid to something unique or to said something unique name, rather than have same either NETGEAR, CISCO, LINKSYS OR BELKIN whatever comes as a default generic company given name. so after changing it, it stopped putting the wifi into sleep mode. and now its on forever. hope this posts helps, as it did to me.

     

    Try improvising with your apple......well i as well set out mine to static IP and auto Http proxy leaving the url empty.