14 Replies Latest reply: Oct 10, 2012 2:43 PM by LMHahn
cdestre Level 1 Level 1 (0 points)

Hi all,


I have just updated FCPX 10.0.2  to 10.0.3 and it is a disaster.

The video preview is not working anymore: when i try to view one video from my events and pass the mouse over one, i hear the video sound, the time progressing but nothing appears in the video preview. If i try to play it (using the play button), FCPX hangs. I have to kill it.

It is the same when i edit a project: no video preview at all. It is very strange.

I tried a new project, import new videos, trash the prefs, reinstall FCPX from scratch with no events no projects, even make the lion combo 10.7.3 update (I updated lion the day before)...

My FCPX is useless. Do you have any advice that may help me?


Is it possible to roll back to 10.0.2 version via the mac app store?


My config; MBP Mid2009 15" (GPU 9600MGT).





MacBook Pro, Mac OS X (10.7.3), MBP 5.3
  • cdestre Level 1 Level 1 (0 points)

    Just some precisions: i made some tests.

    I used Time machine to restore to the v10.0.2 and Lion 10.7.2. Updating to 10.0.3 gives me the same behavior with Lion 10.7.2 and 10.7.3: no video preview at all, freeze when play button is clicked: totally useless. I have to precize that i use H264 AVCHD file without transcoding.

    Does anybody use successfully non-transcoded AVCHD files with 10.0.3? (If yes, i would say that there is an incompatibility between FCP 10.0.3 and my mybookpro mid 2009 9600MGT). Strange as v10.0.2 is working quite well.

  • AllieC14 Level 1 Level 1 (0 points)

    I'm having the same problem, just slightly different. My preview window is still intact and plays, but my viewer window is either a black or static screen upon playback and skimming. The audio plays, but the video does not. It's not a problem with any other projects, just this one. My quick fix so far has been to add random effects. This lets me play the video, and edit, but once I change something such as color, it goes back to black or static. Hopefully, someone will know the answer to our problem soon.

  • John Bertram Level 1 Level 1 (125 points)



    FWIW, I seem to be having similar issues. Used 10.0.3 for the first time earlier today (under Snow Leopard, on an 8-core Mac Pro now with 24GB of RAM). Constantly losing video -- audio plays fine. Never seemed to have this problem in 10.0.2.  (Lots of other problems, mind you -- just not this one.)


    Found I can usually get video back by opening Playback Prefs and making a change (like switching between "use proxy media" and "use original/optimized"), then waiting 2-3 minutes while the orange bar which has now appeared over the ENTIRE timeline -- even though NO changes have been made to the timeline whatsoever -- slowly goes away.


    One of the triggers for losing the video in my case seems to be letting the Timeline play through till past the end. And I say "past" the end, because there's now suddenly a weird 2-3 minute void after the final clip of video. No audio, no "gap clips", just a big stretch of nothing. I can't figure out how to get rid of it, and the fade out I'd applied long ago to the last video clip no longer works. When the playhead reaches that transition (or nears the end of the last video clip, even with the transition removed) the video just cuts to black. The audio then ends normally while the playhead just keeps going into this mysterious blank emptiness for almost 3 minutes -- at least that's how much extra black I get when I do an Export of the Project.


    Naturally I've tried re-doing the end transition; and have of course made sure there is no media of any kind down at the end of timeline which might be causing this strange empty section. Even tried carefully selecting all the real clips on the Timeline and Copy/Pasting them into a whole new project. No difference. The gap at the end just reappears.


    (Meantime, as others have reported, I also experienced loss of parameters on several simple titles in Projects created in 10.0.2 and updated/imported into 10.0.3. Likewise for the irrational re-re-re-re-re-re-re-re-re-re-re-re-rendering. Have not yet had time to test any of this on a newly-created 10.0.3 project, but I really do look forward to the day when the bulk of my work in FCP-X might actually involve  editing, with the time spent in trouble-shooting and unpaid beta-testing perhaps reduced to just a few hours a week. A crazy idea, I know -- but I can still dream.)


    John B


  • Ast A. Moore Level 4 Level 4 (1,570 points)

    Looks like the problem lies in how FCPX handles display profiles. Go to System Preferences > Displays > Color and make sure you have selected one of the profiles for “this display only,” that is, above the separator line in the list.

  • John Bertram Level 1 Level 1 (125 points)

    Thanks A.A.M.


    I just went there, and in my case that's what was already checked and selected. And no separator bar in the list, just three instances of "Cinema HD" and then a fourth option of "Cinema HD w darker 2.2 Gamma". I'm presuming three of those four choices represent various attempts of mine to custom calibrate the display in the distant past.


    It's currently set to the third "Cinema HD" option in the list. The path to each of those three (when you mouse over them) is Library/ColorSync/Profiles/Displays/, followed by "HD-42463609.icc" for one of them (which I'm guessing was the pre-installed default), and "HD- +much longer number strings" for the other two (which I'm guessing are profiles I created at some point in time.


    The fourth option ("Cinema HD w darker 2.2 Gamma") shows a path beginning with MY Library folder (i.e. "~/Library"), followed by "/ColorSync/Profiles/" and then "Cinema HD w darker 2.2 Gamma.icc".


    When I switch between the four different profiles in the list, the differences I can see onscreen in my current work environment are so subtle as to be unnoticeable. So based on what you wrote above, should I try choosing the "Cinema HD" profile with the shortest filepath (the one I'm assuming is the default), and see if it makes any difference to this loss-of-video issue in FCP-X?




    BTW, that loss of video issue is now also happening each time I do a Share or Export of any kind. In this scenario, I don't lose the video in FCP's Viewer, but what gets exported (regardless of which output option I've selected) is Audio Only. So after each successful export of Audio&Video -- even though the video for that project still plays in the Viewer, I have to go through the same nonsense of changing my Playback Prefs and and then resetting them (and waiting a couple of minutes for the orange bar to go away), otherwise the NEXT export from that exact same, unchanged timeline will be Audio only -- guaranteed.


    Weird, weird, weird.

  • Ast A. Moore Level 4 Level 4 (1,570 points)

    Hi John,


    I tried several exports (one after another, sometimes making changes to the test project in between), and I cannot reproduce your issue of no video on export. I'll experiment some more.


    Re ICC profiles. I found this Apple Knowledge Base article: http://support.apple.com/kb/HT4589

    In the release notes for FCP 10.0.1 it says:


    • Fixes an issue in which custom ICC color profiles affected the image in the Viewer


    Perhaps they've reintroduced that old bug. (As was the case with some titles reverting to their default settings in 10.0.2, for example.) At least we know that this is not a new bug. Later today, I'll send a bug report to Apple and attach the offending ICC profiles. I recommend you do the same.

  • James Cude Level 4 Level 4 (1,235 points)

    Resetting your preferences might also help here- http://www.digitalrebellion.com/prefman/

  • javiquil Level 1 Level 1 (0 points)

    What happens when we do that?

  • javiquil Level 1 Level 1 (0 points)

    Im having same problem here. Updated to 10.0.3 everything fine but yesterday I moved some events from 1 disk to another one and now my viewer is completely black and no skimming at all


    Im desperate

  • Casciari Level 1 Level 1 (0 points)

    I am in the same situation. Black viewer/canvas skimming any type of clip. Audio skims. Trying to play means an endless spinning beachball. Tis happened three days ago, after an Apple software update, I suoppose: three items I don't even remember, I thought not so important.


    I have a deadline on wednesday and I'm desperate. DigitalRebellion software didn't help. I tried creating another administrator User: Final Cu Pro x 10.0.3 works as usual. Now I'm copying events on an external HD in order to work from as a new user. Sad...

  • javiquil Level 1 Level 1 (0 points)

    I finally found the solution... doing what James Cude suggested here... resetting the preferences fixed it

  • Ben Johnston Level 1 Level 1 (10 points)

    I'm still on 10.6.8, but found the FCPX 10.0.3 update caused playback issues, especially with compound clips.


    Trashing all FCP preferences solved this - snappy playback again.

  • CTYankee Level 4 Level 4 (1,920 points)

    I realize this is an older thread, but I was having the same issue. Everything in FCPX worked BUT playback. If I tried to play a video (event preview, import preview, timeline) it would hang FCPX. I tried to reinstall, trash prefs, etc.


    What fixed it? Using a different color profile. I was using my custom profile, switching back to the default profile restored all FCP functionality.


    I had worked on a prior project with the same version of FCPX, but an older version of OSX (10.8.1?). Seems it may be a bug reintroduced to 10.8.2 (what I am now using).

  • LMHahn Level 1 Level 1 (0 points)

    Ok, here was the solve that worked for me.  I finally gave in and called Apple Care.


    They had me create a test log in and launch fcpx through that account.  It worked fine that way.  (System Preferences>Users&Groups>Unlock the padlock at the bottom>Hit the plus button>Call it "Test" and no password.  Log out of your account and into the Test account.  Launch FCPX.  They also had me go to apple.com/trailers and download a movie trailer to bring in as a test, although during a second test they just had me generate blobs in FCPX to see if things were working.)


    Once I was clear in the test log in, I logged back into my main account.  Still wasn't working.  They had me go into my home, then my "movies" folder.  They had me create a "Movies Backup" folder and move everything into there and relaunch.  Bingo!  Since there were only 3 movies and one other folder, it was easy to pinpoint.  There was a folder called "Motion Templates" that I had not been deleting.  I was just deleting the final cut events and projects folders.  The Motion Templates did have a plug-in, but I saved that file and will reinstall.  In the meantime, I trashed the Motion Templates folder and am back in business!