6 Replies Latest reply: Feb 9, 2012 8:19 PM by lamont_ancient
lamont_ancient Level 1 Level 1 (5 points)

My problem is a variation of the well documented one relating to Home Sharing not showing in iTunes side bar. Strangely it works in about 80% of my network but steadfastly refuses to cooperate just where I need it the most.

 

I wish I was able to provide a diagram to simplify this explanation but will do my best using text.

 

My local network consists of a Belkin N1 Modem/Router, a 27” iMac, a 13” MacBook Pro, a Mac Mini, an iPhone 3GS and an iPad 2.

Both the iPhone and the iPad can see the Home Shared libraries on the iMac, the MacBook Pro and the Mac Mini.

The Mac Book Pro can see the libraries on the iMac and the Mac Mini.

The iMac can see the library on the Mac Book Pro but NOT the one on the Mac Mini

The Mac Mini can see the library on the Mac Book Pro but NOT the one on the iMac

 

Expressed another way (see below)...

 

(a) can see only (c)

(b) can see only (c)

(c) can see both (a) & (b)

(d) & (e) can see (a), (b) & (c)

 

 

                                                      Belkin N1 Modem/Router

 

 

 

(a)iMac                                                                                                         (b) Mac Mini

                 

 

                                                         (c) Mac Book Pro

 

 

 

 

                    (d)iPhone                                                                     (e)iPad

 

 

As (a) the 27” iMac contains my ‘main’ iTunes library and is where I do all the downloading etc. and (b) the Mac Mini performs a kind of Media Server roll in another room near the TV and HiFi, at very least I would dearly like (a) to be able to see (b).

 

I have trawled many of these forums and tried many of the suggested fixes without success, things tried include...

 

Turned Home Sharing on and off multiple times

Ensured that Sharing was turned on in iTunes Preferences

Repaired Permissions

Verified all HD's

Deauthorised iTunes Store Account on all machines.

Authorised iTunes Store Account on all machines.

Ensured that the Apple ID was identical on all machines when turning on Home Sharing

Restarts

PRAM resets

Ran Main Menu

Checked and disabled Firewall settings

Modem/Router restarts

and so on

 

If you are still with me and can help I would greatly appreciate your comments and suggestions.

  • lamont_ancient Level 1 Level 1 (5 points)

    At the suggestion of a local Apple Authorised Service Centre, I setup a new network (different modem/router) and went through the iTunes Home Sharing setup over again. The result.......no change still the same problem.

    At least that should eliminate my network from any 'blame'.

     

    The search for a fix continues.

  • lamont_ancient Level 1 Level 1 (5 points)

    Yet another drastic step (because of the need to move equipment) - changed all computers from WiFi to Ethernet.

    You guessed it no change - problem remains.

     

    I'm now thinking software

    Do I...

     

    Wait for a fix from Apple?

    Re install iTunes?

    Re install Lion?

    Create new users and iTunes libraries on each machine as a test?

     

    Who knows???

  • mirth23 Level 1 Level 1 (0 points)

    I don't know the answer to your problem but here's a couple more diagnostic suggestions:

     

    Rule out network issues entirely: get a cheap/dumb ethernet switch and replace the Belkin with it to make entirely sure that the router is not the problem. Some routers interact badly with the multicast protocols that macs use to find each other (I had one that would totally melt and crash if someone turned on AirPlay).

     

    Creating new users might be a useful exercise. Also, are all users on all machines running as admin?

     

    Is it possible anything else is blocking traffic on your computers? e.g., do you have Little Snitch installed?

  • lamont_ancient Level 1 Level 1 (5 points)

    I did mention a couple of posts back that I had completely replaced the Belkin with another Modem/Router and got the same result. So the network is definitely not to blame.

     

    Creating new users (and new iTunes Libraries) on both the iMac and the Mac Book Pro eliminted the problem but is there an easy way to get all my stuff over to the new user space on each machine, and when I do will it 'import' the problem as well?

     

    I don't have Little Snitch or anything similar.

     

    A suggestion was made to attack the Preference files - I deleted the iTunes ones and that didn't fix it I'm now wondering if I can safely delete my whole Preference Folder? Or perhaps all the com.apple.xxx ones?

  • mirth23 Level 1 Level 1 (0 points)

    The best way I've determined to copy an iTunes library is to use a home sharing import. That maintains the integrity of the metadata. I'm unfortunately not sure how to do that between two accounts on one machine. You could import from one machine to the other, and then back.

     

    I suspect doing the above might clear your problem if the iTunes apps are all seeing each other properly in the new accounts. The import should only bring song data and metadata over, not whatever broken preferences you've got.

     

    I'd definitely make a backup before you start nuking other preferences files. I do think most apps can rebuild them without a huge issue, but I wouldn't risk them not being able to. Don't forget that you've got two preferences folders - /Library/Preferences/ and ~/Library/Preferences

     

    If deleting the iTunes preferences didn't fix anything, I wonder if there's something messed up in System Preferences. It might be worth going through the panels on machine (a) and machine (c) side by side and see if anything is checked on (c) that isn't on (a), or vice versa.

  • lamont_ancient Level 1 Level 1 (5 points)

    A happy ending?

     

    Here's what I did.

     

    On the Mac Mini.....

    As a safe guard I duplicated the Preference folder in my user library and moved it to the desktop. Then from the original Preferences Folder I moved all the com.apple.xxx plists to the trash and restarted.

     

    No fix

     

    I then moved the rest of the contents of the Preference Folder (the system won't allow trashing the actual folder) to the trash and restarted.

     

    Following that I set up Home Sharing again on both the iMac and the Mac Mini and BINGO.

     

    It must have been a non apple preference of some sort causing the odd behaviour. Who knows which or what.

     

    Note that I did not have to move or get rid of any preferences on the iMac!

     

    Now to try to get the Mac Mini (preferences) back to looking and acting as I want - a reasonably big job but probably worth the effort in the end.