Previous 1 2 Next 26 Replies Latest reply: Feb 11, 2013 10:44 AM by Bici
Joe Borzellino Level 2 Level 2

I was wondering whether anyone else had this trouble.

 

After combo update to 10.7.3, in Safari 5.1.3 the "show in finder" magnifying glass will not open my downloads folder to show downloaded files.That is, if I have invoked "Show Downloads" from the View menu in Safari and then hover over the magnifying glass, you see a "show in finder" in gray under the downloaded file's name. In the past, clicking the magnifier then would open a Finder window and highlight the downloaded file. This seems to be broken for me.

 

Anyone else with this issue?


Mac Pro (Early 2009), Mac OS X (10.7.3)
Solved by Joe Borzellino on Mar 12, 2012 10:38 PM Solved

Looks like Safari 5.1.4 released today fixed this glitch for me.

Reply by Joe Borzellino on Feb 5, 2012 11:22 PM Helpful

Ok, I solved the problem. I think this is new behavior from the last version of Safari. But this is what I have found out.

 

In order for the magnifier to activate and open the Finder window, the item to be located in the "Show Downloads" drop down must be highlighted by clicking somewhere in the row where it is listed. In my setup this highlights the item in blue and then clicking the magnifier will open the Finder window. If the item is not highlighted, then clicking the magnifier does nothing, even though the magnifier icon itself indicates feedback that it has been clicked.

 

Like I said, I think this is different behavior from the previous version of Safari and thus it takes 2 mouse clicks to open the Finder window rather than one.

All replies

  • Carolyn Samit Level 10 Level 10
    expertise.safari
    Safari

    Joe...

     

    I see what you are referring to. The Finder preferences may be corrupted.

     

    Go to ~/Library/Preferences/com.apple.finder.plist

     

    Move the com.apple.finder.plist file from the Preferences folder to the Trash.

     

    Quit then relaunch Safari to test.

     

    If that didn't help, go to ~/LIbrary/Safari/Downloads.plist

     

    Move the Downloads.plist file to the Trash.

     

    Try again.

  • Joe Borzellino Level 2 Level 2

    Already had tried these and it doesn't fix the problem. Thanks for the suggestion though.

  • Joe Borzellino Level 2 Level 2

    Ok, I solved the problem. I think this is new behavior from the last version of Safari. But this is what I have found out.

     

    In order for the magnifier to activate and open the Finder window, the item to be located in the "Show Downloads" drop down must be highlighted by clicking somewhere in the row where it is listed. In my setup this highlights the item in blue and then clicking the magnifier will open the Finder window. If the item is not highlighted, then clicking the magnifier does nothing, even though the magnifier icon itself indicates feedback that it has been clicked.

     

    Like I said, I think this is different behavior from the previous version of Safari and thus it takes 2 mouse clicks to open the Finder window rather than one.

  • Brian burrow Level 1 Level 1

    I have always had to double click since lion, but since 10.7.3, it has not worked correctly. I would call it broken, but I believe that Joe Borzellino is correct in that it's a new behavior. it's not a welcome one though. I liked when we could just click once  (previous to Lion) and locate the downloaded item.

     

    Having to click to highlight the line and then again to open is... odd. I did find that you don't have to aim at the magnifying glass icon though.

  • lucafrombrooklyn Level 1 Level 1
    expertise.iwork
    iWork

    Thanks for the solution Joe, I had the same problem, I was equaly puzzled. Silly behavior, but that's how it works now.

     

    l.

  • dileep_s Level 1 Level 1

    Alternatively you can 'right click' in the downloads popdown and choose 'show in finder'. You are absolutely right Joe, this is a different behaviour to previous releases. I cant see how deleting the ~/Library/Preferences/com.apple.finder.plist as suggested by Carolyn is going to change a bug.

  • Joe Borzellino Level 2 Level 2

    Ok, this bug is going to be hard to track down. On my Mac Pro (Early 2009), I experience the problem. On my Mac Pro (Early 2008) I do not. On both machines Safari is similarly configured. I'm not sure what the source of the issue is, but since it occurs on one machine and not the other, I will try a little more troubleshooting to see if I can track the issue down. If anyone else finds out anything, please post.

  • gogster Level 1 Level 1

    I'm having exactly the same issue. I can click directly on the magnifying glass on my Macbook Air (2010), but not on my Mac Pro (2008), I have to highlight it first.

  • derfla8 Level 1 Level 1

    This problem is inconsistent, my MacBook Pro (Early 2011) exhibits this and the two clicks is required; however, on both my Mac mini server (Mid 2011) and iMac (Early 2008) a single click on the magnifying glass works.  All are 10.7.3.

  • Joe Borzellino Level 2 Level 2

    Looks like Safari 5.1.4 released today fixed this glitch for me.

  • gogster Level 1 Level 1

    Solved it for me too.

  • derfla8 Level 1 Level 1

    Solved with 5.1.4!  Yay!

  • Glenn Cogar Level 1 Level 1

    I think the problem may be back in Safari 6, anyone else having this problem again?

  • gogster Level 1 Level 1

    No, it's working fine for me. Whole heap of other bugs though!

Previous 1 2 Next