Previous 1 2 Next 19 Replies Latest reply: Jun 27, 2013 4:38 AM by Peter Panther Go to original post
  • X423424X Level 6 Level 6 (14,205 points)

    Based on that HWPortDetect_driver you have in StartupItems I did a little google searching and found a page that documents on hpw to remove all the other stuff that would have been installed when it was installed.  Basically here's the other stuff that page mentions:

     

    /Library/Modem Scripts/HUAWEI Mobile Connect - 3G Modem

     

    /System/Library/Extensions/HuaweiDataCardDriver.kext

    /System/Library/Extensions/USBExpressCardCanWake_Huawei.kext

  • ilim Level 1 Level 1 (0 points)

    Well, let's hope. It seems to repeat every 19 minutes and indeed it just did but... I didn't restart, just logged out. So I'll restart and seem what's up tomorrow. I certainly appreciate the effort you've made.

    ilim

  • X423424X Level 6 Level 6 (14,205 points)

    Ok, good luck. 

  • ilim Level 1 Level 1 (0 points)

    Thanks, today all is well.

     

    ilim

  • Peter Panther Level 1 Level 1 (0 points)

    Thanks for the advice I found here, but I have to add something!

    X423424X wrote:

     

    Based on that HWPortDetect_driver you have in StartupItems I did a little google searching and found a page that documents on hpw to remove all the other stuff that would have been installed when it was installed.  Basically here's the other stuff that page mentions:

     

    /Library/Modem Scripts/HUAWEI Mobile Connect - 3G Modem

     

    /System/Library/Extensions/HuaweiDataCardDriver.kext

    /System/Library/Extensions/USBExpressCardCanWake_Huawei.kext

     

     

    I had the same problem. Since I did have a Huawei USB driver on my system, I found this thread and followed the proposed instructions, but the problem persisted.

     

    In the log, I still found the following line:

     

    23.06.13 21:14:41,986 com.apple.SystemStarter: (C) 2004-2008 HUAWEI Technologies Co., Ltd. All rights reserved

     

    It turned out to be another file called HW_CreateNetwork in the /Library/StartupItems folder. I deleted this one as well, and from then on, the strange message was gone.

     

    In addition to that, my TimeMachine backups began to work again. Before, the backup process used to stall after some 500 MB had been backed up. It was extremely slow, too. Now it is back to nromal, and I am extremely thankful to regained this safety!

     

    My advice to all: While the Huawei UMTS modems are quite useful, NEVER EVER install the drivers that come with the device. It is absolutely unnecessary and might run your system.

Previous 1 2 Next