Previous 1 7 8 9 10 11 12 Next 177 Replies Latest reply: Feb 8, 2016 1:35 PM by Richardfromon Go to original post
  • Rexis Level 1 (0 points)

    Nope("and made backups like never"), looks like I had to not trust the Mac this time.. - despite auto-saving documents goes out and stuff.


    Ergh.. dead end then, and a lesson to back up things(not only iPhone).

  • Old Toad Level 10 (135,388 points)

    It might be time to enable a backup strategy - an external HD and Time Machine.

  • canadianartist Level 1 (0 points)

    I did what you say and I got .....

    the folder can't be found

    i am so frustrated

  • canadianartist Level 1 (0 points)


    Re: My iphoto library has disappeared. How do I find it?


    Oct 5, 2012 3:09 AM (in response to amandainthebarn)


    This worked for me, after an idea presented here:



    if you do a


    Finder> Go> Go to Folder


    enter /Volumes in the search box


    Click Go


    You should get a list of Volumes the machine knows about.


    I deleted the Macintosh HD alias file listed, and magically iPhoto Library reappeared and iPhoto worked normally.

      DOES NOT WORK......

  • canadianartist Level 1 (0 points)

    I have a Mac Book 10.8.5


    Doctor Random procedure  DOES NOT WORK


    I lost all the picture in my Iphoto all my work ,,,,plz  some one help me

  • LarryHN Level 9 (76,951 points)

    the simple solution is to restore your backup from before this happened



  • Terence Devlin Level 10 (137,920 points)

    If you're not restoring then we need information to be able to helo you.


    If you want help you’ll need to give us more information. There are 9 different versions of iPhoto and they run on 8 different versions of the Operating System. The tricks and tips for dealing with issues vary depending on the version of iPhoto and the version of the OS. So to get help you need to give as much information as you can. Include things like:


    - What version of iPhoto.


    - What version of the Operating System.


    - Details. As full a description of the problem as you can. For example, if you have a problem with exporting, then explain by describing how you are trying to export, and so on.


    - History: Is this going on long? Has anything been installed or deleted? - Are there error messages?


    - What steps have you tried already to solve the issue.


    - Anything unusual about your set up? Or how you use iPhoto?


    Anything else you can think of that might help someone understand the problem you have.


    Posts that consist of "iPhoto doesn't work. Help" or "iPhoto won't print" or "Suddenly I have no photos!!!!!!!!!!" mean that any helper is simply guessing. More information means you get better assistance.

  • bearstarweb Level 1 (0 points)

    This one worked for me, too. Thank you!

  • phoebe9 Level 1 (0 points)

    I had this problem too, after finally calming my nerves i was able to find that i had accidntally deleted my iPhoto gallery and made a new one (which was the only one i could find). If you cant find your library make sure not to empty your trash!!! Look through there and good luck!

  • stephccc Level 1 (0 points)

    Hello people,




    My iphoto also disappeared when I plugged in my iphone and imported what was on my iphone.  But I went to the website below and they can explain what happen in detail, but basically you iphone just created a new library, but didn't delete your photos.  Open up iphoto, go up and click on "File", then click on "Switch to Library", it will then ask you to switch to previous library, click yes.  Then it will load your original library.  Job done!!


  • Terence Devlin Level 10 (137,920 points)

    Well you have the solution for people who have two libraries. It's not much of a fix for those who actually have lost their library, is it?

  • onpurpose Level 1 (0 points)

    It's not that i am using iphoto everyday, but it worked well in storing the pictures, and until today it contained nearly 13 years of my life. I have used iPhoto since the beginning, and never - I must repeat - never it deleted a single file because it got corrupted in some way.


    But here, I guess some time between last upgrade and today, the computer decided to simply delete 3 entire libraries.


    I'm really trying to stay stoïc in front of such a horrible issue, but anyway, as matter of a fact, I have lost everything.


    I know where my 3 libraries were stored, in a custom folder, which appears to be totally empty, nowadays. There's only a subfolder containing one of the 3 disappeared libraries, and this subfolder is gray out, I can't access to it.


    No libraries at all after trying several of solutions in this thread.


    So far so good, the libraries were deleted for another reasons, not related to iPhoto. Disk Permissions? checked and repaired. Disk corrupted? Checked and everything is fine.


    My libraries simply... disappeared.

  • LarryHN Level 9 (76,951 points)

    Best solution is to restore them form your backup before they "disappeared"



  • Terence Devlin Level 10 (137,920 points)

    NOt sure what's gone on, but whever deleted this material wasn't iPhoto. It hasn't got the tools to delete a library. It can delete from a Library, but the Finder or other file manager or the Terminal are the only things that can delete entire Libraries. So, if you said "I opened and Library and it was empty" then I would say iPhoto is a possiblr cause of the issue. But when the Library package goes, it's not iPhoto, and you need to explore other possibilities for the cause.


    For instance:


    There's only a subfolder containing one of the 3 disappeared libraries, and this subfolder is gray out, I can't access to it.


    How are you trying to access it? From the Finder? From iPhoto?

  • onpurpose Level 1 (0 points)

    Hello, I am trying to access from the finder, because I know the exact place where my libraries were before. they just vanished. It's not a question that my libraries deleted some photo, the libraries simply vanished.


    The main folder contained 2 libraries, and one subfolder containing a third library. Everything left in this folder is the subfolder, gray out. When checking the folder info, it shows zero bytes, and created date is very funny : tuesday 24 january 1984.


    I didn't do anything tricky either with the terminal, either with anything else. And of course, last year i deleted backups because i expressly needed a disk because of a crash.


    I guess my personal history has been removed there....