3 Replies Latest reply: Jul 16, 2012 7:56 PM by Hawaiian_Starman
Samuel Lewis Level 1 Level 1 (125 points)

I have an Airport Extreme (set to b/g/n mode) wired into an ethernet network, and a separate Airport Express (set to b/g mode) that joins the network through the Airport Extreme.  I've checked and signal strength seems to be good, response time for pinging the Express through the Extreme is 1-6 ms, and I've set signal robustness on.  Despite this, and despite efforts to switch channels to ensure that there's no significant interference, iTunes keeps cutting out when playing music through AirPlay.  When it cuts out, and I try to re-start the music, I get the following message:

 

The AirPlay devices "Express2" cannot be found on your network.  Please verify your network settings and AirPlay configuration or select another device from the menu at the bottom of the iTunes window.

 

This comes up despite the fact that connectivity remains good to the Airport Express device.  I've tried upgrading and downgrading the firmware on the Airport Extreme, and it seems to make no difference.  To make this problem even more confusing, there are some days when the setup works without a hitch, and other days when it can't play more than 30 seconds worth of music without failing repeatedly.

 

In terms of software, I'm running Lion (this has been happening under 10.7.1, 10.7.2 and 10.7.3) and iTunes (this has been happening under 10.5.1, 10.5.2 and 10.5.3).

 

The only thing I can think of is that iTunes AirPlay implementation is timing out for some odd reason, but I can't seem to find any meaningful settings for AirPlay in iTunes. 

 

Does anyone have any suggestions for adjusting the time-out in iTunes or other steps to take to narrow down the problem?


iMac, Mac OS X (10.7.3)
  • cajn Level 1 Level 1 (0 points)

    I have the same setup and all software is up to date. I'm finding that music has been dropping out between tracks, or really when a track ends. Then the next track is playing but with no sound. If I hit pause and then play again it comes back. Strange and also annoying. Any help much appreciated.

  • ashdown Level 1 Level 1 (0 points)

    I am getting this too, I am sure I didn't have this issue before but has arisen over the past months, it's really annoying and I need to find an answer, as all the other threads my signal strenght is good and it plays on the other devices fine, I also have Apple TV and I will do some tests and see if it drops out on this also, this will at least identify if it's a Express Port issue or a general on through Airplay.

  • Hawaiian_Starman Level 7 Level 7 (21,415 points)

    I'm experiencing a similar connection problem, but have not had any time-out issues.

     

    Rather, Airplay will simply not connect with my 2nd Generation Airport Express after quit/restart iTunes 10.6.3, or waking the computer from sleep (iTunes is open). I am using Lion 7.4. Only remedy has been to restart the computer. This freeze started after 10.7.4 was installed.

     

    I have reset the AE unit to factory specs, reestablished by connection via Airport Utility. However, same bug remains. Hopefully the next update of Lion addresses this problem.