Previous 1 2 Next 20 Replies Latest reply: Mar 25, 2013 1:16 PM by map0fthew0rld
rossejhendry Level 1 Level 1 (0 points)

Hi All,


I recently moved job and was forced in to a Mac > PC change.


I have managed to link up my Apple wireless keyboard via bluetooth to my new work machine. However, I have not yet figured out the equivalent key combination on the keyboard for Ctrl-Alt-Del to unlock my screen


Does anyone have a work around or a solution that they could share?


I have tried looking at the setting on the PC but can't find anything. (What a shock I know)


Any help would be much appreciated because I am currently typing from a doorstop of a Dell keyboard.

iMac, Mac OS X (10.7.2)
  • GeekBoy.from.Illinois Level 4 Level 4 (2,805 points)

    In most cases, <fn><delete> on a Mac keyboard is the same as <del> on a PC keyboard.  If that is true for you, then <ctrl><alt><fn><delete> should give you the desired key combination...

  • teranine Level 1 Level 1 (0 points)

    This does not work (Fn+Ctrl+Alt+del)

  • s.smith Level 1 Level 1 (0 points)

    I got this to work by pressing keys in the exact order: <ctrl> then <alt> then <fn+delete>.  Hope that helps clarify.  Thanks for posting and replying, everyone!

  • teranine Level 1 Level 1 (0 points)

    Pressing the keys in the exact order <ctrl> then <alt> then <fn+delete> does not work for me.  Pressing it in any order doesn't work either.  Or any other combination of keys.  So far the only way to log in to windows 7 is by using the virtual keyboard to simulate the ctrl+alt+del key combo.


    I'm using a native windows machine (does not have OS X and is not an apple computer).  Drivers, such as bootcamp or otherwise, will work once the user is logged in.  But once the user logs out or the screensaver login kicks in, the drivers appear to be disabled.

  • tmcbride67 Level 1 Level 1 (0 points)

    Sorry to say, but I don't think you can do what you want with the wireless keyboard.  I run XP and WIN 7 in Parallels on my Mac, and I had to switch back to using Apple's wired keyboard because I was never able to log in using the wireless model.

  • Zomp Level 1 Level 1 (25 points)



    Easiest way is to locate task manager (see above location)and create a shortcut on your desktop. Right click and Select Create Shortcut - then drag it to the desktop.

    I am happy to get rid of the oversized keyboards sold by PC vendors for a small form factor such as Apple's wireless keyboard.


    By the way; if you are using a 64 bit system, then change location from System32 to System64


  • teranine Level 1 Level 1 (0 points)

    How does making a desktop shortcut to the taskmgr program help with logging in?  At the log in screen, you do not have access to your desktop.

  • Zomp Level 1 Level 1 (25 points)

    you are right.. I'm sorry,, thought this was a Control Alt DeL thread.

    If you are using a Mac type computer or laptop - the drivers will be install through BootCamp and updated by using Boot Camp in PC mode.

    I'm testing the keyboard native on my Toshiba and I see there is a problem after sleep that the laptop does not recognize the keyboard and there is no way to use a password if required. That is a Driver issue and I will try to find the keyboard driver for windows and repost.

  • Zomp Level 1 Level 1 (25 points)

    Solution - hope it works for you.


    It seems the keyboard only remembers one device at a time and that is the very first Paired computer used when you set up your keyboard. If you set up the keyboard with a Mac, iPad, or another PC - then you must first disconnect (UnPair) the keyboard from the first device and then delete the device from the current computer you are using. The keyboard can be used with many devices temporarily (this is your case), it can only be used with one device as a permanently.


    Now start over and connect device (Pair) in windows using Custom rather than Express - type in the "key" provided by windows and create a shortcut on your desktop (for later) and that should do it.


    I did notice that after restart, windows  takes a few moments to switch on Bluetooth before it's ready to allow the keyboard to be used during "Password Login"- tap a key on the keyboard wait about 5 to 10. That's it.

  • dati_g Level 1 Level 1 (0 points)

    Excellent, good answer. You solved my trouble. I have only one note: I'm running Windows 7 64 bit, but the right link requires system32, not system64

  • thejonathontaylor Level 1 Level 1 (0 points)

    Just found a great work around.  Click the ""Ease of Access", then "Type without the keyboard (On-Screen Keyboard)", hold down alt-control then click Delete then login.

  • teranine Level 1 Level 1 (0 points)



    This solution does not solve the original poster's problem (nor mine).  The bluetooth keyboard is paired to only one computer, namely a native windows machine and not a mac running windows with bootcamp.  While logged into a windows account, the bluetooth keyboard works wonderfully.  It is only when the user is logged out and a login is required that problems occur. 


    As you stated above, "The keyboard can be used with many devices temporarily (this is your case)."  However, this is not our case.  Remember what the original poster stated, "I recently moved job and was forced in to a Mac > PC change."  We are on native windows computers and are trying to use mac products, such as the wireless bluetooth keyboard.


    If you know of a way to keep the apple wireless keyboard windows drivers resident in memory after the user logs out of their account, so that the ctrl+alt+del or fn+ctrl+alt+del works to initiate the login screen, please let us know.

  • teranine Level 1 Level 1 (0 points)



    Yeah this is a temporary workaround that has been known for a while.  Thanks for sharing here for people that don't know already.  Without the virtual keyboard, the apple wireless keyboard would be completely useless on the PC.

  • Zoranj Level 1 Level 1 (0 points)

    I am running Lion on Macbook Pro with 22" external screen and wireless keyboard.

    Inside I have Virtual Box with Windows XP that I used locally just fine but when I needed to start using it as a part of AD through VPN, couldn't get Ctrl+Alt Del combo for login.


    I looked at this thread which gave me ideas so I fiddled around and got it to work with CTRL+OPTION+COMMAND+FN + Delete


    It works every time but order is important, press Ctrl+Opt+Command, than FN and hold, than hit Delete.

    Sometimes I have to hit Delete twice but it could be my Mac fighting for pointer with Virtual box.


    Try this, hopefully it helps, it works for me every time.

Previous 1 2 Next