3 Replies Latest reply: Nov 7, 2013 6:23 PM by Mthanus
kt242 Level 1 (0 points)

I upgraded my iphone to a 4S 3 weeks ago.  Initially the visual voicemail and imessage worked.  For the last week neither has worked.  Every time i try to active imessage it says that there is an error. Regarding the voicemail- i occasionally get visual voicemail messages if i switch off the phone and turn it back on but generally they dont come through so i am not aware that i have received any messages.  my phone will also not send mms messages! I have tried restting all the settings and have also restored my phone to factory settings but this has not fixed the problem! I had no problems with the 3GS phone!! Can someone please help!!





iPhone 4S, iOS 5.0.1, network O2
  • Mthanus Level 1 (0 points)


    Take the phone and drop it in a lake, then get a new phone (not iphone) and all will be fixed.

    Or you can except the fact that apple is not what it used to be, because I have the same problems.

    I'm in a contract, but when it ends, I will switch to another brand.

    Visual voicemail should be working, no excuse for this.

    I wish I could be of more help, but the apple store could not help me, at&t gave me the same brush off, and all my tech friends at work are baffled about this problem.

    I wished I had waited for the reviews, before downloading the ios 7.



  • AmishCake Level 6 (9,282 points)

    Voicemails and texts are provided by your carrier, so you should be talking to them about these issues.

  • Mthanus Level 1 (0 points)



    Unfortunately, I did ask at&t about this problem, and then apple, and then went online to find so many others with the same problem, most of them with Verizon, T-Mobile.

    I have 3 iphones, 2 5's and one 4.

    This problem never existed before the ios 7 was downloaded.

    So do the math. The phones worked fine, then a 4 hour download from apple, and boom, no visual voicemail.

    Today I took this phone to a cell phone store, and even this tech, who has helped me before could not explain this problem.

    So whats up with the ios 7??