Previous 1 2 3 4 Next 58 Replies Latest reply: Mar 5, 2013 11:35 AM by greenday1987 Branched to a new discussion.
naruyume Level 1 Level 1

Since a while back the "images"-tab in google does'nt work on the iPhone in any of the browsers I've tried. I've searched the net to find others with the same problem but with little luck. Here's a description of the problem.


For example I search for "dog" in google in the Safari browser, this works just fine.
Then I press the "images"-tab and get a thumbnail view with pictures of dogs, of course.

But this is where it all goes wrong, when touching one of the images I get an enlarged view of an image next to it. The "back to the results" and "full image" buttons dim out (without being touchable) and swiping does not work. I don't know what has caused this to stop working properly, I know its not the new iOS version though.


HERE is a youtube video I prepared that explains the problem.



First, is there anyone else out there with this problem?


Second, this is what I've tried:
- Other iPhone web browser applications, for example "Mercury", "Opera Mini", "Skyfire" and none of them works except "Dolphin" (good work).

- Resetting any of the settings in the phone, clearing cache and such have no effect.

- Resetting the iPhone totally, factory settings. No effect.

- Using someone elses iPhone. I've tried on an iPhone 4 and iPhone 3S, same problems (with iOS 5.01).

- Trying out all of the settings in google, no change.

- Setting the google view to "classic" instead of "mobile" works of course, but that makes the site look just like on a PC or Mac and is not what I'm after.


Third, this problem seems to just affect Swedish users from what I can tell. There would be thousands of posts about this if everyone in the world was affected by it, but so far I've seen no posts on this matter. But after searching a while I found a swedish forum site on the subject. Link (in swedish). Also, when visiting google from Sweden some form of script automatically changes the url from .com to .se. I don't know if this has something to do with it?


Anyone know what causes this problem and how It might be resolved?

Best Regard
Stefan, Sweden

iPhone 4S, iOS 5.0.1
  • naruyume Level 1 Level 1

    old video link is bad.


    this is the new video link!

  • naruyume Level 1 Level 1

    Also, I've tried restoring the phone AND restoring the phone in DFU mode. First letting iTunes download a new firmware for me, no change.


    Second, downloading an ipsw manually and forcing iTunes to use it (by shiftclicking) but still no change. I've tried using iOS 9A405 and 9A406, same thing on both.


    Also, I've found that if i search for a longer string of words it sometimes starts working as it should. For example searching for "dog" does'nt work, but searching for "iphone background dog" works. Strange. Just searching for "background dog" does'nt work though. And not all combinations of three words work. I dont understand it.


    Anyone got any clues to why this is?

  • Frankie Fortran Level 1 Level 1

    Hi Stefan,


    First; this must be the most thorough error discription I have ever seen. Impressive.


    Second; yep for a couple of weeks now I've been having exactly the same problems as you describe. One other thing that I've noticed, is that for me, the 'word suggestion drop down list' or whatever it's name is, no longer works. More specificly:


    I open Safari in my iPhone, surf to Google image search and type for example "dog" in the search field. Below the field, I now get a list of suggested words or phrases that I think is based on the most popular searches. For me, the first suggestion in this list is "dogo argentino" (a specific and popular breed of dogs). When I tap on the words "dogo argentino", the search field normally would switch input from "dog" to "dogo argentino" AND starts the image search automatically. However, since the problem showed up, when I tap on "dogo argentino" the input field is not affected (still reads "dog") and I would have to type "dogo argentino" manually and hit "search".


    I use a Swedish iPhone 4S (5.0.1 (9A406)) in the Telenor network. I also have tested the same possible solutions that you describe in your post, but with no luck.


    All the best,


  • Ulf_o Level 1 Level 1

    Got exactly the same problem. From your conclutions i tried to use instead wich works fine, maybee the problem is  with the .se domain of google?

  • Nicklas Weidinger Level 1 Level 1

    I have recently posted this to Google Support division. I have not heard from them yet.

    Is there someone else who been in contact with Google regarding this malfunction?


    With Regards,


    Nicklas Weidinger


  • naruyume Level 1 Level 1

    Frankie, "dogo argentino" works fine for me. Strange.

    Ulf, smart! but I can't make my default search in Safari.


    Nicklas, good. It seems to be something with the swedish google coding., and works for example.


    I've also posted it on the google groups help-forums. Link.

    And another google forum. Link.



    Lets hope i get some replies.

  • Encrypted11 Level 2 Level 2

    It works quite fine for sometime for me until something goes broken for a reason I haven't really known of. Even in privacy mode.


    I think it could be the Nitro Javascript engine not working correctly.


    It's abit jumpy when I try to tap a result. Also, sometimes after getting in to the result's site as I hit back, it will bring me back to the site of the previous result I searched and I'm literally spam hitting my back button to get out of that page, and googling images isn't really a breeze for me.

  • arbory Level 1 Level 1

    exactly the same problem here in austria

    first i thought it has to do with my iphone 4 - did a reset of everything i could - but no impact.

    then i tried it also on two other iphones (one 3gs and one 4s), with the same results...

    the crazy thing is that "iphone backround dog" works as mentioned in yor post, but "dog" does not work!!!!

    for me it seems to be more a bug from google than apple, but i do not have really a clue....


    thanks for the mention that works!!!!

    the same for me:

    the built in google search in safari and do not work for images.

    but work as expected!!!

  • arbory Level 1 Level 1

    update: works, works for me, but and do not work properly in image search!

    seems to me now like localisation bug from google?

    hey swedish users please try an report if you have the same behavior like

  • Ulf_o Level 1 Level 1

    I'm sittting in Denmark, but I got the same result. .at and .se not working, .de and .dk working fine

  • Frankie Fortran Level 1 Level 1

    Hey Arbory,


    Yep, same malfunction when I try image search via Have changed my bookmark and now I'm image-googeling via Denmark



  • Emmdeedee Level 1 Level 1

    I'm having the same problem in Finland - it does seem intermittent though. iPhone 4 iOS 5.01 on Sonera. It seems worse late at night... Does that make any sense?  Agree most likely Google issue rather than Apple

  • abeabe Level 1 Level 1

    Yep. Same error on my Iphone 4 (ios 5+) and my girlfriends Iphone 4s.


    I just hope Google and Apple doesn't start blaming each other!


    - Just fix the problem!

  • Nicklas Weidinger Level 1 Level 1

    Is there anyone who has been in contact with Apple in this matter?

Previous 1 2 3 4 Next