1 2 Previous Next 15 Replies Latest reply: Apr 24, 2014 11:44 AM by SteveCNY
mbahundra Level 1 Level 1 (0 points)

A long time ago I partitioned my hard drive to have a separate boot disk. Since this is no longer necessary now that Lion does the same thing, I'd like to reformat my drive with a single partition. But Disk Utility says (when I boot from the Lion partition) "Disk Erase failed with the error: couldn't unmount disk". Googling this doesn't help - has no-one had this problem before? Any suggestions?


Mac OS X (10.7)
  • 1. Re: couldn't unmount disk
    Courcoul Level 6 Level 6 (11,470 points)

    Yep, no operating system will allow you to modify the current boot volume. In pre-Lion days, you'd boot from your install media and run Disk Utility off that. In Lion you either have to have a Recovery Partition, a Recovery Flash Drive or boot off Apple's servers via the Internet to be able to do what you want.

     

    Check this out:  http://www.apple.com/macosx/recovery/

  • 2. Re: couldn't unmount disk
    mbahundra Level 1 Level 1 (0 points)

    Yes, I did say I'm booting from the Lion partition...

  • 3. Re: couldn't unmount disk
    BuckChucklestik Level 1 Level 1 (0 points)

    Don't you love it when they don't read the one important key part of the question?! Ah, at least he tried.

     

    Try downloading the Lion Recovery Disk Assistant http://support.apple.com/kb/DL1433 and install it to a flash drive, then hold down the Option key while booting your Mac. Your new Lion Recovery Flash drive should be bootable, and you should be able to format your hard drive.

     

    "When the Lion Recovery Disk Assistant completes, the new partition will not be visible in the Finder or Disk Utility. To access Lion Recovery, reboot the computer while holding the Option key. Select Recovery HD from the Startup Manager."

  • 4. Re: couldn't unmount disk
    mbahundra Level 1 Level 1 (0 points)

    I hadn't tried that, I'll give it a go, thanks for the suggestion.

     

    In defence of the first reply, there probably are people who try to reformat the boot disk!

  • 5. Re: couldn't unmount disk
    Courcoul Level 6 Level 6 (11,470 points)

    There was a degree of miscommunication. When you stated "(when I boot from the Lion partition)", to me it meant the main partition where the regular O.S. resides and boots from, and that cannot be modified. Hence you need for the computer to boot from somewhere else. In pre-Lion days, you had bootable install DVDs, so that took care of the problem, but Lion did away with that option, replacing it with the Recovery partition or the Recovery drive (which can be a flash or a regular drive, external to the computer).

     

    Once you manage to boot from a partition different from those you want to merge, since Leopard days it is not necessary to reformat the whole device. Just delete the partition on the bottom, commit the change, then drag the edge of the partition on top downwards to resize it and occupy the space just vacated. Commit and you'll have a bigger partition without having had to lose its contents.

  • 6. Re: couldn't unmount disk
    shmengie Level 1 Level 1 (0 points)

    Hey, y'all:

     

    I'm having the same issue. I AM booting into Lion Recovery (cmd+r), but, I am unable to do any partition actions in Disk Utility. And, of course, I cannot reinstall Lion, as it does not see my disk. I tried a repair disk, but all is OK. I tried shrinking the volume, to see if it would maybe "release" it's hold on the partition.

     

    Another solution I read somewhere was to boot to a Windows or Linux CD, and format from there. Before I do that, anyone got a fix for this?

     

    Thanks!

  • 7. Re: couldn't unmount disk
    Courcoul Level 6 Level 6 (11,470 points)

    I was able to successfully shrink the main boot volume and create a second non-BootCamp boot volume by concocting a bootable Lion Recovery Volume on a 4GB USB stick I had and using the Disk Utility from there.

     

    http://support.apple.com/kb/DL1433

    http://support.apple.com/kb/HT4848

  • 8. Re: couldn't unmount disk
    maartendc Level 1 Level 1 (0 points)

    I had a similar problem as the thread starter, and was able to fix it by making a bootable Mountain Lion Recovery Volume on a USB stick, as Courcoul suggested above (http://support.apple.com/kb/DL1433).

     

    I had removed bootcamp and the associated partition from my Macbook Pro running Mountain Lion, and I wanted to reallocate that space on the hard drive to my main Mac partition.

    The bootcamp assistant had failed halfway through the process, and it could not extend the partition to include the unallocated space ("partition failed"). It had also created errors on my main Mac volume (when scanning with Disk Utility).

     

    1) The Disk Utility inside Mac OS was not able to repair the volume, so I had to boot from the recovery partition (cmd + r during boot), and then repair them. This would let the errors be repaired, but still I would get the error "Disk Erase failed with the error: couldn't unmount disk" when I was trying to resize the partition to include the unallocated space.

     

    2) So Finally, when booting from the recovery USB stick, and using Disk Utility, I was able to resize the main partition to the full size of the hard drive.

     

    I think the error "couldnt unmount disk" was due to the fact that somewhere in the process it said it was trying to "relocate the recovery partition". So I assume that if you boot from this recovery partition on the drive, it cannot do this part, and the process fails.

     

    Thank you all very much! Your comments were really helpful. I hope my explanation is useful to someone with the same problem. 

  • 10. Re: couldn't unmount disk
    Gfever Level 1 Level 1 (25 points)

    Found a fix!!!

     

    I closed all open applications then ejected the drive. Once ejected I disconnected for a min, plugged back in and gave it another go. IT WORKED!

     

    Good luck to those with the same issue.

     

    ps. Running Mountain Lion 10.8.3, 2011 27" iMac

  • 11. Re: couldn't unmount disk
    Anas birrashed Level 1 Level 1 (0 points)

    I found your solution the most complete and helpful among the other ones.

     

    Thanks for the comprehensive details.

  • 12. Re: couldn't unmount disk
    S0lidTech Level 1 Level 1 (0 points)

    I Know this might be late, but I managed to do my research and found a good solution and worked 100%. Easy to do and buy. It has to do with the HDD(Hard Disk Disk) Cable or ribbon what ever you want to call it. For Example mine is ( Macbook Pro Model A1278 HDD Hard Drvie Cable Part Number: 821-0814-A cost me about $20 bucks) Ordered it On ebay and replaced that Bad boy and Boom! Worked like a Charm. You have no idea what a Pain it was to figure this out. I hope it helped Most of you out and again Huge late notice to the Orginal post.

  • 13. Re: couldn't unmount disk
    SteveCNY Level 1 Level 1 (0 points)

    Adding my 2 cents for another workaround  - I also couldn't repartition a hard drive, because it was "mounted", tried a couple things above, so (you'd need access to a PC for this solution) I used "disk management" on windows and deleted the current volume, then put it back in to my mac to partition it.

  • 14. Re: couldn't unmount disk
    Courcoul Level 6 Level 6 (11,470 points)

    That's exactly why you have to have a USB flashdrive containing a bootable OS X volume to start up from. That way, the internal drive remains unmounted at all times. Besides the links I put up previously, if you had the precaution of keeping a copy of the Lion/Mountain Lion/Mavericks installer around, you can make a fully decked out bootable flashdrive OS X installer (which includes Disk Utility) with DiskMaker X.

1 2 Previous Next