10 Replies Latest reply: Jan 23, 2014 2:00 AM by Omorote Hideoshi
Antonio92 Level 1 Level 1


I have a weird issue with my new iPhone 4S with iOS 5.0.1 and found nobody with a similar problem.

All notifications on my iPhone 4S are working properly except for SMS (and iMessages). Facebook, Twitter, Whatsapp, etc. show up on the lockscreen when there are new messages, but when I receive a SMS (or an iMessage), the only way to know is going to homescreen and see a red circle with a "1" inside it, on the Messages icon. iPhone doesn't sound and there is nothing in the Notifications center, so I can't notice.

I don't have my iPhone muted, and notifcations are all enabled on Settings > Notifications > Messages.

When I configured my 4S, I restored the backup from my old iPhone 3GS (with iOS 4.3.3), which included all my SMS. I tried to set the 4S as a new iPhone (without restoring the backup), and then messages notifications work properly.


I really DO want my sms from my backup in the Messages up, but i also want my notifications to work properly.


Did anyone have a similar issue when restoring SMS from an old iPhone backup?


Any hints?



iPhone 4S, iOS 5.0.1
  • randers4 Level 9 Level 9

    In Settings>Notifications>Messages make sure you don't have Alert Style set to None.

  • Antonio92 Level 1 Level 1

    Thank you randers4 for your answer, but my settings for Settings > Notifications > Messages are as shown here:


    Notification center: ON, Alert style: Banners, Badge app icon: ON (the only think working).


    I don't know what to do... and as I said, I don't want to set the phone as new iPhone and lose my sms (what makes notifications work).


    Any hint will be appreciated.



  • randers4 Level 9 Level 9

    Try stopping the Messages app and resetting your phone:  double tap the home button to bring up the recently used app list at the bottom, locate the Messages app (swiping if necessary), press and hold on it until it jiggles, tap the red minus sign.  Now reset the phone: hold the on/off and home buttons simultaneously for 10-15 seconds until you see the Apple logo (ignore the red off slider that appears first), release and weit for the phone to restart. See if that clears it up.

  • Antonio92 Level 1 Level 1

    I did it many times with no success. Still no notifications for Messages

  • randers4 Level 9 Level 9

    Yea, I knew it was a long shot.  Since the problem is tied to your 3GS backup there may be no way to fix it other than to restore as new.  If you really want to save your message conversations there is 3rd party software you can purchase that will allow you to save them on your computer for printing/viewing (but not for importing into another phone).  Examples are PhoneView and Touchcopy.

  • Antonio92 Level 1 Level 1

    So, nobody managed to succesfully restore a 3GS backup on a new 4S without this problem? I am a bit confused, since I didn't find anyone with this issue.

  • randers4 Level 9 Level 9

    I haven't seen this problem before.  You could try turn off Message Center off for messages (and perhaps even turning iMessage off in Settings>Messages), resetting again and turning everything back on.

  • Antonio92 Level 1 Level 1

    Tried it with no luck...

    I hope Apple will fix it in a software update... I didn't find how to solve it.

  • Janettoe Level 1 Level 1

    This was the final step in a series of attempts and it finally worked for me... finally after an hour or two of reading every post I could find on getting repeat alert notifications. I closed the app (double clicking home and pressing the red circle with the white line in it which  turned off the messages app).  Then I held the home and off button until the apple came on...  I had also reset the DNS service numbers to,  I also made sure that the badge icon was on, a sound was selected and I had it turned to repeat alert 3 times.  When I tested after doing all these things the repeat worked.  I decided I wanted to turn it to repeat 10 times and it didn't work.... so I held the home and off button at the same time and it reset so that the alert repeats 10 times.  Perhaps the combination of all these these things did the trick, or maybe it was just the home and off button reset...

  • Omorote Hideoshi Level 1 Level 1

    I has same problem - I wasn't receiving notifications about SMS even it was on at the notification centre.


    How to handle it:


    1) Disable all notifications on messages

    2) reset the phone by Power and home button

    3) turn back the notifications


    Now they work again.