Previous 1 2 3 Next 37 Replies Latest reply: Aug 20, 2015 8:36 AM by mn_ny Go to original post
  • Llibbill Level 1 Level 1 (0 points)

    Hmm, there doesn't seem to be an option to modify extensions in the iPad Pages app. I assume you were doing this in Lion? I guess I could backup first to iTunes , then modify the filenames...

     

    I also tried emailing a document to myself - which adds the .pages extension for me, but after I open the document in Pages it's the same problem ...

  • JasonBB Level 1 Level 1 (25 points)

    Yes I was doing it in pages on my Mountain lion Mac, you don't need to sync with iTunes, it's all automatically synced through iCloud, make sure all the updates have been applied.

  • JasonBB Level 1 Level 1 (25 points)

    I just tried it on my iPad and all I did was touch the file name and it opened up the rename box, try that and just add .pages to the end if the name.

  • Qiitxx Level 1 Level 1 (0 points)

    Charles, I just got your  e message. I am facing a similar situation with pages. If I don't get this document to open I fail the course. There are just too many revision to reproduce. Did you have any solution?

  • Llibbill Level 1 Level 1 (0 points)

    strangely enough, last night my iPad just started syncing again, after two months of not working.

     

    I'm wondering if someone at Apple read my post and did something on their end...

  • MaryJoearmstrong Level 1 Level 1 (0 points)

    I have the same problem, I went in an apple store and they said that maybe the file was uploading and the connection stopped. But, is it possible to loose a work of month in this way?? I'm horrified by this, i hope someone will find a a solution. Scandalous.

  • JasonBB Level 1 Level 1 (25 points)

    I am guessing you have tried adding the extension to the end of your documents, this was the one and only thing that solved my problem.

    If you use time machine you will have a copy backed up.  This is the link for instructions on digging out the backup.  http://www.desparoz.com/2012/08/14/backups-of-icloud-documents-in-the-cloud/

  • jflow Level 1 Level 1 (0 points)

    I had the same issue where I was unable to open several Pages documents on my Mac and on my iPad.  When I went to the "mobile documents" folder and looked at the package contets of the documents, they were completely empty. So, I restored from TimeMachine.  The problem is that this is the 3rd time most of my Pages documents in iCloud have become corrupt. 

     

    The first time I was unable to restore from TimeMachine, so I just completely errased the Mobile Backups folder re-installed Pages from the App Store and started over.  A few months went by with everything syncing beautifully between my iPhone, iPad and my Mac.  Then one day I noticed I could not open most of the documents again... 

     

    This being the second time it errased everything I decided to re-install all of iWork.  Again everything worked beautifully.  Then a few days ago, most everything was corrupt again. 

     

    This being the third time.  I completely trashed my Pages Mobile Documents folder and started over.  I actually restored from backup, moved the documents to Dropbox, and now have a clean slate in iCloud for Pages. 

     

    Just for the record.  I have used Dropbox for 3 years.  Number of corrupted documents or lost data:  ZERO.   Pages and iCloud I have had over 2 dozen documents become corrupt and had it happen 3 times. hmmm....

  • JasonBB Level 1 Level 1 (25 points)

    Hi,

     

    Just to see if its the same problem I had, what happens when you open Pages on your Mac and see the documents? I had some with the preview showing the contents of the document and others with the Pages icon instead of the preview, the ones with the Pages icon did not work and the others were fine.  To fix the "corrupted" documents all I had to do was right click on the filename, rename with .pages on the end and save it.  That fixed it, it continues to happen now but at least I know its a easy fix now.

  • marylynnOH Level 1 Level 1 (0 points)

    Same - a document that I typed on my iPad in Pages on 2/25/13  opens only as a blank on both my iPad and my iPhone 5, but the icon in Pages  on both devices shows my document!  I tried emailing it to myself as a Word doc and as a PDF, and that doesn't work. I tried making a duplicate file and that doesn't work.  I tried downloading it from iCloud on my Mac both as a Word doc and as a PDF and nothing works.  I tried putting .pages at the end of the file name, that does not work.  In every case, the icon shows my document, but either I open it and it's just a blank, or when I open it, Pages instantly shuts down. 

     

    I need this document!  In it I took notes from a meeting and the other people in the meeting also need those notes!  Please help!!

     

    Oh, and when I email it to myself from my iPad, if I try to open either as a Word or PDF from Gmail in Firefox, it shows as a three-page blank doc.  When I try to open it from Gmail in Chrome (in both Word and PDF), it says that it is a binary file.  When I try to open it from Gmail in Safari (Word), it is a one-page blank document.  Weird.

  • Rsrob5617 Level 1 Level 1 (0 points)

    I read somewhere that of you can get the .pages to your computer, you can change the .pages extension to .zip and extract the contents of the document to make it usable again

  • Charlie Evans Level 1 Level 1 (0 points)

    Just had the same thing happen again. I know I said I wouldn't use it again, but eventually I did. And today after months of everything working fine another document just locked up. I'm a pastor and I went to print my sunday sermon today (it's Easter, by the way), and the document would not open. Wouldn't open on my mac, wouldn't open on my iPad. Even after I changed the extension, nothing. Twenty or so hours of work just gone, and only a couple hours before our sunday service.

     

    Whatever this issue is, it makes Pages and iCloud unusable for anything serious. Users beware!

  • Llibbill Level 1 Level 1 (0 points)

    I've come to the same conclusion regarding the use of Pages and iCloud for my PhD dissertation. For now I dont have money to buy a new machine and I rely on my iPad, so I've resorted to emailing the Pages files to myself after after day of working on my thesis. Terrible inconvenience, but iCloud is simply unreliable. :-(

  • texinick Level 1 Level 1 (15 points)

    Just a quick suggestion, you could also use the 'Copy to iTunes' option, in the Share & Print menu. This simply copies the document to another folder on your iPad which is exposed for iTunes to see. If you did this after each edit of the document, should anything happen to your documents, you can use the 'copy from iTunes' option, when adding a new document, to re-open the document that got zapped.

     

    Please note, I'm not suggesting you actually use iTunes in anyway, this is all done on the iPad alone, but is an easy way to safeguard your critical docs and only adds a second or two when you're done editing for the day

  • gerttreg Level 1 Level 1 (0 points)

    HI guys,

     

    I have seemed to solve my problem of not being able to open the documents from icloud.

     

    How :

     

    first locate the icloud folder in the library

     

    http://osxdaily.com/2012/08/09/how-to-access-icloud-documents-from-the-mac-os-x- finder/

     

    when you are in finder , go to go finder and press option.

     

    find pages documents ....

     

    and I assume there still in the cloud there,

    so make a folder on your desktop or anywhere on your hard drive select them and move them to the folder

     

    I just moved them not copied them ...

     

    and now they open again ,

     

    Icloud, Pages, good idea but it ***** , had loads of problems with it.

     

    I'm gonna trynow to replace the documents icon in the library with a link to the dropbox account , to get around icloud altogether ... don't know it will work thought

     

    good luck with it