1 2 3 Previous Next 43 Replies Latest reply: Jan 27, 2013 1:54 PM by cRiLle Go to original post
  • 15. Re: EFI 2.6 error
    Philbyfish Level 1 Level 1 (10 points)

    I upgraded to Lion on my MacBook Pro by using a DVD disk image form the download on my Mac Pro...so that seesm the same as your situation.

     

    How do you fix it? Boot from the DVD?

  • 16. Re: EFI 2.6 error
    Philbyfish Level 1 Level 1 (10 points)

    Right, how do I get the firmware restoration CD for early 2011 13 inch Macbook Pro?

     

    This one below seems to be the lastest but doesnt cover the MacBookPro8,1

     

    http://support.apple.com/kb/DL1320

  • 17. Re: EFI 2.6 error
    edmechem Level 1 Level 1 (0 points)

    Same situation as you. I've tried a few other things:

    - deleting the bom file & plist file from /var/db/receipts/

    - creating another admin account and trying to install from there

    - turning off little snitch

     

    One other thing I have going on that is 'unusual' is - I replaced the internal optical drive (the DVD drive) with the 'Data Doubler' from OWC - an SSD drive in a mounting bracket that fits where the DVD drive used to be. That's now my boot drive, the drive in the HD bay is a second internal drive. Perhaps somewhere in the bowels of the EFI updater code, something is erroneously hard coded specifying *which* internal SATA bus to boot from? Thus it's failing because my boot device isn't where it's expecting it to be? (I'm just guessing that this even _could_ be a factor).

     

    Also I use the Firmware Password Utility to set a firmware password whenever travelling, but I've turned this off and restarted before trying the EFI updater.

     

    Like Andrew (& Tim & RJ), it just goes thru all the motions, looks like it's working fine, but fails to actually rev. the firmware - still stuck at MBP61.0057.B0C instead of MBP61.0057.B0F (EFI 2.6).

     

    I've saved a detailed Installer log from the 'pre-restart' phase, running from the downloaded disk image - but I probably need to look at the log from the post-restart phase, to actually figure out what's failing and why...    anyone know exactly which log file to look at?

  • 18. Re: EFI 2.6 error
    edmechem Level 1 Level 1 (0 points)

    Just to answer the obvious questions, yes both drives are GUID partition scheme, yes I'm plugged in to AC power, yes I already have a "Recovery HD" partition on the boot drive, yes I'm running latest 10.7.3, and yes I've tried via Software Update & via downloaded disk image. As well as trying the other more tweaky things I've outlined above. Like Andrew, Tim & RJ, it acts like it's working but it never actually succeeds.

     

    Again - anyone know which log file to look at, to see what's happening w/ this updater, in its 'post-restart' phase?  Thanks

  • 19. Re: EFI 2.6 error
    krazykid Level 1 Level 1 (0 points)

    I too am having this problem. And like edmechem I also have a OWC data doubler, SSD, and the original HD. I wonder. Anyone have any solutions?

  • 20. Re: EFI 2.6 error
    shaymanjohn Level 1 Level 1 (0 points)

    I've got exactly the same issue and the same setup as edmechem and krazykid (SSD boot drive in the optical bay)...

  • 21. Re: EFI 2.6 error
    krazykid Level 1 Level 1 (0 points)

    My SSD is a OCZ Vertex 3.

  • 22. Re: EFI 2.6 error
    FFox Level 1 Level 1 (0 points)

    Gorgeous! Seems that the Optibay Setup we all (?) have in common causes this problem.

    I have the same problem with an Intel Series 300 SSD (SSDSA2CW160G3).

  • 23. Re: EFI 2.6 error
    AndrewJSmith Level 1 Level 1 (0 points)

    Right.

     

    Yes, I also have an Optibay-SSD-setup with an OCZ-Agility2 which I use as my main boot drive...

     

     

    now what?

  • 24. Re: EFI 2.6 error
    edmechem Level 1 Level 1 (0 points)

    Aha! Well. Certainly seems to be the common factor.

     

    Tomorrow I'll open up my machine again, and try a couple things.

     

    - First I'll just, disconnect the additional hard drive that's in the HD bay; and boot from the SSD only (still in DVD bay) -- see if it succeeds w/ this configuration.

    - If not, then I'll try putting the SSD in the HD bay; and also put the HD back in, in the DVD bay. If *that* doesn't work, then I'll finally try:

    - Putting the SSD in the HD bay, and having that *only* - leave the actual HD disconnected.

     

    This series of tests should eventually work, and should also have the side benefit of finding out exactly how the logic in the installer script is flawed. I'll report back tomorrow evening.

  • 25. Re: EFI 2.6 error
    Alvin Nguyen Level 1 Level 1 (0 points)

    Yes, I have the same problem and I am using Optical Bay for my SSD as well!

     

    Please let us know it goes =)

  • 26. Re: EFI 2.6 error
    RJ V Level 1 Level 1 (0 points)

    I have doubts if this swopping around with SSD's and HDD"s wil work. I have only 1 SSD installed instead of my regular HDD and I have have the same problem. I think that the problem is caused by using a SSD. So this is were Apple should look around the corner and come up with a solution or help. No way that I will use a normal HDD ever again.

  • 27. Re: EFI 2.6 error
    RJ V Level 1 Level 1 (0 points)

    I succeeded in updating my Macbook Pro 15" (mid 2010) to EFI 2.6 firmware.

     

    What I did: I HAD TO REMOVE MY SSD DISK AND CHANGE IT BACK AGAIN TO MY OLD HDD DISK. AFTER DOING SO, UPDATING WAS NO PROBLEM. I SWOPPED my HDD back AND SSD AGAIN and had no problems restarting my Macbook.

    For me it doesn't make any sense. Why refused my Macbook to update with an SSD installed. Any computer nerds who have an answer?????

  • 28. Re: EFI 2.6 error
    Mallone Level 1 Level 1 (0 points)

    edmechem - Did you get the chance to try and work out the logic in the installer script?

     

    I've got exactly the same setup as you guys, with the SSD installed in my optical bay. I would try and disconnect the SSD as per RJ V's instructions but it is my main boot drive so I won't be able to actually perform the update if I do that.

     

    Is it possible to perform these EFI updates from an external drive?

  • 29. Re: EFI 2.6 error
    edmechem Level 1 Level 1 (0 points)

    Haven't had the chance to do it yet, hopefully later tonite or tomorrow. I do have an actual HD with Lion which I can boot from - either from the internal HD bay, or via an external USB enclosure - I'll obviously try this if all the other ways fail. Truly amazing that an installer script for a firmware update should care whether there's an SSD installed, vs. an HD...

     

    Perhaps this relates to the fact that Apple's SSDs do their cell-leveling under supervision of the OS, whereas some third party SSDs (like the OWC one I have, w/ Sandforce controller) do the cell leveling themselves... Perhaps there's some logic in the installer script which notices that there's an SSD, and then, when it inspects further and notices that it's not one of the ones Apple OEMs -- basically gives up, at that point... This would correlate w/ who's on this thread - basically, nobody with an Apple OEM SSD...

     

    Perhaps there's some aspect of the firmware update that relates to this part of the OS... thus this is a safety precautionary measure. In other words, ***** to be us now, but it would suck way more if the installer were scripted to just blindly go ahead... and people's boot drive SSDs got completely hosed.

     

    Not that it necessarily makes a difference, but mine's a 17"... I'd imagine those of us in this thread have a mix of 15" & 17", I really can't see at all how that would make any difference... but you never know.