13 Replies Latest reply: Mar 21, 2012 10:40 PM by Cynthia Bennett
Ryanns Level 1 Level 1 (0 points)

Hello,

About a year ago I was listening to music on my iPod Touch (Generation 3) and I fell asleep. I proceeded to wake up the next morning, only to find my iPod was in recovery mode. I thought "Oh well, no big deal, I'll just restore it on my laptop." However, the restore would NOT work. I then would wait for the regular iTunes updates, and try again. Finally, one software update worked, and my iPod went through the "new iPod setup", in which you configure Wi-Fi and other settings ON THE ITOUCH, but I had two problems:

One-my home button didn’t work.

Two-when I would power off my device, it goes back into recovery mode

This process was repeatable.

After the most recent software update, my iPod Touch Gen. 3 will not even show any progress in on the iTouch screen. It makes sounds like a USB device is being plugged in 2-3 times, and then gives me an error message.(1611) I am very annoyed, as the iPod has only worked for about a year before breaking. Any help would be amazing.

 

-Ryan


iPod touch, Windows Vista